Announcement

Collapse
No announcement yet.

New Error on .460

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • New Error on .460

    Upgraded to .460 this am from .420. Now seeing errors approximately every 3-4 Seconds in the log. It appears to have first surfaced in .435 and may be plug-in related.

    Did anyone ever track down the offending plug-in? Was the option to log callbacks implemented to find the chatty plug-in?

    Jul-28 10:30:17 AM Warning Dropping event callbacks due to full queue (Type: 2048) (500 entries), system may be too busy, plugins and HSTouch may not receive all device updates
    Jul-28 10:30:14 AM Warning Dropping event callbacks due to full queue (Type: 64) (500 entries), system may be too busy, plugins and HSTouch may not receive all device updates
    Usually seeing Type 2048, sometimes Type 64.

    4868 Devices
    482 Events,

    System and HS Touch Clients seem responsive and the system appears to be otherwise functional. More testing required.

    CPU is running around 18 - 25%, same as 420,
    Modules/Threads: 127 Modules, 478 Threads
    Available Threads: 3200
    System Processes/Load: 345 Processes, 8% Load
    Free / Total Physical Memory: 51.09 GBytes / 63.89 GBytes (80% free)
    Free / Total Virtual Memory: 54.75 GBytes / 73.39 GBytes (75% free)
    HomeSeer Memory Used: 207 Mbytes
    Plug-In Memory Used: 70 EXE Plug-Ins using 2 Gbytes
    Last edited by Mr_Resistor; July 28th, 2018, 01:09 PM.
    My home is smarter than your honor roll student.

  • #2
    Is .460 formally released ?

    Comment


    • #3
      .460 is Beta as far as I know for use with testing the new Mobile app.

      Am I reading that correct? 4868 Devices? Wow!

      Comment


      • #4
        Originally posted by jeubanks View Post
        .460 is Beta as far as I know for use with testing the new Mobile app.

        Am I reading that correct? 4868 Devices? Wow!
        Not playing "mine is bigger than yours", but if you are grand in your goals, you will have a lot of Devices and Events. While I don't have that many devices, mine is busy as well:

        Number of Devices: 2385
        Number of Events: 1521


        Randy Prade
        Aurora, CO
        Prades.net

        PHLocation - Pushover - EasyTrigger - UltraECM3 - Ultra1Wire3 - Arduino

        Comment


        • #5
          Well I just rolled over my other box with 10K devices... when you hit 10K the Dev DB starts over This is of course on my plugin test box.

          Comment


          • #6
            Randy, you were one of the folks who chimed in on the 435 thread as having see this error, but only when the system was busy (editing events). Did you ever find a resolution? Did it just die down?
            My home is smarter than your honor roll student.

            Comment


            • #7
              Originally posted by jeubanks View Post
              .460 is Beta as far as I know for use with testing the new Mobile app.

              Am I reading that correct? 4868 Devices? Wow!
              Yup. Afraid so. But there are some "devices" that appear multiple times due to being picked up by multiple plug-ins. And media and weather devices seem to propagate like Catholic rabbits.

              I fear my plug-in count of 70 may be a contributing factor. I've tried disabling some that created the most devices, but still haven't found the chatterbox
              My home is smarter than your honor roll student.

              Comment


              • #8
                Originally posted by Mr_Resistor View Post

                Yup. Afraid so. But there are some "devices" that appear multiple times due to being picked up by multiple plug-ins. And media and weather devices seem to propagate like Catholic rabbits.

                I fear my plug-in count of 70 may be a contributing factor. I've tried disabling some that created the most devices, but still haven't found the chatterbox
                That's a lot of plugins as well. Well I don't have an answer for the issue, but it's good to see HS3 can handle that many devices and plugins.

                Comment


                • #9
                  Originally posted by jeubanks View Post

                  That's a lot of plugins as well. Well I don't have an answer for the issue, but it's good to see HS3 can handle that many devices and plugins.
                  It has up to now...but I might be reaching a tipping point. Hope not though, still have more to do.

                  My home is smarter than your honor roll student.

                  Comment


                  • #10
                    The file that is linked as .460 beta is in fact .459??
                    RJ_Make On YouTube

                    Comment


                    • #11
                      Originally posted by ServiceXp View Post
                      The file that is linked as .460 beta is in fact .459??
                      It was at one point. Nor sure it it's been fixed yet. best to just download directly. https://homeseer.com/updates3/SetupHS3_3_0_0_460.msi

                      I've been through the posts here

                      https://forums.homeseer.com/forum/ho...ge=3&styleid=7

                      I've tried disabling the plugin mentioned as well as a few others, but haven't found anything yet. And I have no timers or counters defined.

                      Does anyone know another way to see what's flooding the queue?

                      It's possible that it's been doing it for a long time as the logging of this error didn't start until .435. I have noticed that my HSTouch Client ( windows 10 i7 Touchscreen PC doesn't always update device status graphics when devices change state...been that way since before .420 ). It responds beautifully when I change devices through the screen, they respond instantly, but they don't always update the graphic.


                      Homeseer Memory has creeped up a bit.. may have to punt and go back to .420 and give up on HSMobile for the time being.

                      Modules/Threads: 129 Modules, 490 Threads
                      Available Threads: 3200
                      System Processes/Load: 355 Processes, 15% Load
                      Free / Total Physical Memory: 49.60 GBytes / 63.89 GBytes (78% free)
                      Free / Total Virtual Memory: 52.01 GBytes / 73.39 GBytes (71% free)
                      HomeSeer Memory Used: 316 Mbytes
                      Plug-In Memory Used: 72 EXE Plug-Ins using 1 Gbytes
                      Last edited by Mr_Resistor; July 28th, 2018, 08:07 PM.
                      My home is smarter than your honor roll student.

                      Comment


                      • #12
                        Originally posted by Mr_Resistor View Post
                        [LEFT]Upgraded to .460 this am from .420. Now seeing errors approximately every 3-4 Seconds in the log. It appears to have first surfaced in .435 and may be plug-in related.

                        Did anyone ever track down the offending plug-in? Was the option to log callbacks implemented to find the chatty plug-in?
                        James in your comment on the chatty plug-in and the ability to log the origination of the callback messages are you talking about these messages in the HomeSeer log?

                        Dropping event callbacks due to full queue (Type: 64) (500 entries), system may be too busy, plugins and HSTouch may not receive all device updates
                        Dropping event callbacks due to full queue (Type: 1024) (500 entries), system may be too busy, plugins and HSTouch may not receive all device updates
                        Dropping event callbacks due to full queue (Type: 2048) (500 entries), system may be too busy, plugins and HSTouch may not receive all device updates

                        If so I agree with you, I am not sure how these messages are helpful unless you know where or what is producing them.
                        Billy Draper

                        Comment


                        • #13
                          Yes, they appear in the Homeeser system log. Triggering events and device changes is immediate. The indication is true. HSTouch does not reflect device changes. In the .435 thread there was a mention from RIch (I think) that they were going to add some additional logging info to identify the source.

                          One thing I did do is briefly turn on the Detailed HS Touch Logging (Setup / General Tab) and looked to see what devices updates were being sent immediately before and after the error.

                          In nearly instance, they were plex devices. I've dropped the polling from the Plex Plug-ins (BLPlex and Plex Monitor) from 5 seconds to 60 seconds. And the errors have slowed considerably. They still happen, but much less often. I may just have too many Plex Players for the status checks to not flood the queue.

                          Next step will be to disable both simultaneously and see if the errors cease.
                          Last edited by Mr_Resistor; July 29th, 2018, 11:33 AM.
                          My home is smarter than your honor roll student.

                          Comment


                          • #14
                            Disabling both PlexMonitor and BLPlex worked. Almost error free. 2 occurrences (3-5 messages) in the last 30 minutes.

                            It makes sense though, Since they both generated over 500 devices.... the polling was overflowing the queue. I'll shoot a note to Bob (Blade) to see if there's anything that can be done. Perhaps he can have the device updates split. Some device types update in one cycle, and another set update in a second cycle.

                            The other option is see if HS can up the message queue as others have been seeing the same queue overflow issue. When I see them, they come 3 to 5 in a row, which seems like it's overflowing the 500 message queue by a wide margin. Not sure if a queue of 1,000, 2,000, or even 3,000k is even possible.
                            Last edited by Mr_Resistor; July 29th, 2018, 12:07 PM.
                            My home is smarter than your honor roll student.

                            Comment


                            • #15
                              Originally posted by Mr_Resistor View Post
                              Randy, you were one of the folks who chimed in on the 435 thread as having see this error, but only when the system was busy (editing events). Did you ever find a resolution? Did it just die down?
                              I'm still seeing the warning. It comes in a blast of log entries a couple of times a week. It is usually a blast of 10-30 log entries at the same time. I've had 127 of these warnings over the last two weeks. I have never been able to correlate their occurrence with any specific event, nor have I seen any problems at the time the warnings are logged. It happens mostly when HS has just started.
                              Randy Prade
                              Aurora, CO
                              Prades.net

                              PHLocation - Pushover - EasyTrigger - UltraECM3 - Ultra1Wire3 - Arduino

                              Comment

                              Working...
                              X