Announcement

Collapse
No announcement yet.

What's the "Linux Tools" password?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    chmod -R 777 HomeSeer

    fixed that problem.

    Comment


    • #17
      Yup; here utilize Webmin to view for updates even though you can just SSH and update and WinSCP for much of the chmod stuff where I can just highlight a bunch of files and change the properties en masse.

      Is that the essence of what Linux Tools is? It does sound like a more elegant, integrated approach, but aside from that does it buy you anything over merely opening a Putty ssh terminal window and logging into the homeseer (hs) account?
      Just a means I guess to see stuff rather than using SSH.

      I am not sure too that the above posted Applet will work through a firewall. It takes a bit to load the Applet; once its running it does really resemble a regular SSH terminal program embedded into the GUI. Webmin defaults have this too, my 16 port KVM also does this, along with the firewall. Java has upped the security stuff and you have to adjust the Java default security stuff to include the running java ssh applet.

      The big push with Ubuntu over the last few years though is to use sudoer versus configuring yourself for root access. By default you can do sudo stuff with Webmin.
      - Pete

      Auto mator
      Homeseer 3 Pro - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e 64 bit Intel Haswell CPU 16Gb- Mono 6.8X
      Homeseer Zee2 (Lite) - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e - CherryTrail x5-Z8350 BeeLink 4Gb BT3 Pro - Mono 6.8X
      HS4 Pro - V4.0.5.0 - Ubuntu 18.04/W7e 64 bit Intel Kaby Lake CPU - 32Gb - Mono 6.8X
      HS4 Lite -

      X10, UPB, Zigbee, ZWave and Wifi MQTT automation. OmniPro 2, Russound zoned audio, Smartthings hub, Hubitat Hub, and Home Assistant

      Comment


      • #18
        Originally posted by cheeryfool View Post
        Admin is a user right to an account and this is managed in Tools -> Setup -> Network. I was just able to add and modify users in there when logged in with "normal" user rights. You are currently logged in as the user "default" which I would imagine probably has "normal" user rights unless you downgraded it to "guest" rights. Have you tried modifying or creating accounts with the "default" login that you are currently using? Worth a try if not
        How do you manage to ever log-in as anything other than the "default" user? I checked, and when I logout as the default user, it actually does log me out:

        Click image for larger version

Name:	logout.png
Views:	1
Size:	25.3 KB
ID:	1175423


        However, the redirecting part apparently immediately logs me back in again! So, how is it done?

        Comment


        • #19
          Originally posted by rmasonjr View Post
          You might have to assign a real password to the 'homeseer' user.
          Just SSH to the box as root and: passwd homeseer

          Then try that new password in the Linux Tools.
          I've done it that way and by now several other ways as well, and it doesn't seem to be the same password. Did it work for you?

          Comment


          • #20
            On the zee it works, but didn't appear to on a regular Linux install.

            Sent from my SCH-R970X using Tapatalk
            HS3Pro Running on a Raspberry Pi3
            64 Z-Wave Nodes, 168 Events, 280 Devices
            UPB modules via OMNI plugin/panel
            Plugins: Z-Wave, BLRF, OMNI, HSTouch, weatherXML, EasyTrigger
            HSTouch Clients: 3 Android, 1 Joggler

            Comment


            • #21
              Originally posted by NeverDie View Post
              I deleted the "HomeSeer" user and then manually readded it with a proper password.

              However, HS3 still doesn't allow me to change the system password (see below).

              [ATTACH]42733[/ATTACH]

              The error message itself seems rather peculiar. Why would it be trying to "change locale?"

              I can log-in now as HomeSeer over an ssh terminal (see below), whereas before I could not. However, as I demonstrate below, it doesn't have adequate authority to even reboot the system, whereas my regular pi account does. This is just a very wild guess, but could that be related to HS3's inability to let me change the HS3 system password? i.e. maybe HS3 lacks adequate authorization in some general sense?

              [ATTACH]42732[/ATTACH]
              Somewhere/somehow the Dutch language crept into the build. I was able to clear the warning message above by adding Dutch to the locale in raspi-config, although now one of the remaining error messages is in Dutch.

              Click image for larger version

Name:	dutch.png
Views:	1
Size:	109.1 KB
ID:	1175429

              So, that was that. I still don't know what the passwords are, though.

              Comment


              • #22
                I just installed HS3 on a brand new PC Debian 7.7 partition, and I'm getting essentially the same password error message (just no references to Dutch this time) in relation to Linux Tools. So, the flaw isn't specific to a Raspberry Pi. Instead, there's some fault in HS3 that's common to both the Pi and the PC.

                Comment


                • #23
                  Fixed the password in the Linux tools section tonight with Homeseer 3 running in Linux.

                  Current Homeseer 3 implementation is running on Ubuntu 14.04 64 bit.

                  Tonight updated Homeseer 3 to current .152 version. (I had left it running a .149 - didn't have any issues with it).

                  Rebooted and initial web page on reboot was the change the password for Linux tools page.

                  It errored out as earlier mentioned.

                  I created a user called homeseer in the user set up page of Homeseer and gave the user the default password.

                  Rebooted and it still did not work at the start up of HS3 change the password page.

                  Went then in via SSH and created a user named homeseer and the default password as mentioned on the change the password page.

                  Rebooted again and and again the initial change the password page came up.

                  Put in the default password and my new password and it was accepted and all is well now.

                  There is still another issue right now. None of the linux commands work. I do not see anything in the logs relating to any errors when typing in/executing the commands.
                  Attached Files
                  Last edited by Pete; March 22nd, 2015, 11:20 PM.
                  - Pete

                  Auto mator
                  Homeseer 3 Pro - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e 64 bit Intel Haswell CPU 16Gb- Mono 6.8X
                  Homeseer Zee2 (Lite) - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e - CherryTrail x5-Z8350 BeeLink 4Gb BT3 Pro - Mono 6.8X
                  HS4 Pro - V4.0.5.0 - Ubuntu 18.04/W7e 64 bit Intel Kaby Lake CPU - 32Gb - Mono 6.8X
                  HS4 Lite -

                  X10, UPB, Zigbee, ZWave and Wifi MQTT automation. OmniPro 2, Russound zoned audio, Smartthings hub, Hubitat Hub, and Home Assistant

                  Comment


                  • #24
                    Is anyone else seeing this?

                    I have created a linux user called homeseer with the default password and a user in homeseer itself. No matter what I do I get the "cannot execute binary file" upon attempting to change the password.
                    Attached Files

                    Comment


                    • #25
                      Yes. It doesn't work. You can just skip this and go straight to the other menu items. You can just ssh to the box and manually change it there.

                      Sent from my SCH-R970X using Tapatalk
                      HS3Pro Running on a Raspberry Pi3
                      64 Z-Wave Nodes, 168 Events, 280 Devices
                      UPB modules via OMNI plugin/panel
                      Plugins: Z-Wave, BLRF, OMNI, HSTouch, weatherXML, EasyTrigger
                      HSTouch Clients: 3 Android, 1 Joggler

                      Comment


                      • #26
                        Hi Pete - Thank you for posting your approach.

                        Now that you are able to access the Linux Tools option - are you now able to execute Linux commands successfully?

                        Thanks, Mike


                        Originally posted by Pete View Post
                        Fixed the password in the Linux tools section tonight with Homeseer 3 running in Linux.

                        Current Homeseer 3 implementation is running on Ubuntu 14.04 64 bit.

                        Tonight updated Homeseer 3 to current .152 version. (I had left it running a .149 - didn't have any issues with it).

                        Rebooted and initial web page on reboot was the change the password for Linux tools page.

                        It errored out as earlier mentioned.

                        I created a user called homeseer in the user set up page of Homeseer and gave the user the default password.

                        Rebooted and it still did not work at the start up of HS3 change the password page.

                        Went then in via SSH and created a user named homeseer and the default password as mentioned on the change the password page.

                        Rebooted again and and again the initial change the password page came up.

                        Put in the default password and my new password and it was accepted and all is well now.

                        There is still another issue right now. None of the linux commands work. I do not see anything in the logs relating to any errors when typing in/executing the commands.
                        Last edited by mstukel; November 3rd, 2015, 11:53 AM.

                        Comment


                        • #27
                          The page states that the command is executing but doesn't show anything. I haven't looked at it in a long time.

                          I mostly utilize SSH to do stuff with the Linux Homeseer 3 boxes.

                          I did install SSH terminal. It is just a link to a web page under the html directory. Easy to install and you can do anything in the terminal window.

                          SSHTerm
                          Attached Files
                          Last edited by Pete; November 6th, 2015, 11:19 PM.
                          - Pete

                          Auto mator
                          Homeseer 3 Pro - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e 64 bit Intel Haswell CPU 16Gb- Mono 6.8X
                          Homeseer Zee2 (Lite) - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e - CherryTrail x5-Z8350 BeeLink 4Gb BT3 Pro - Mono 6.8X
                          HS4 Pro - V4.0.5.0 - Ubuntu 18.04/W7e 64 bit Intel Kaby Lake CPU - 32Gb - Mono 6.8X
                          HS4 Lite -

                          X10, UPB, Zigbee, ZWave and Wifi MQTT automation. OmniPro 2, Russound zoned audio, Smartthings hub, Hubitat Hub, and Home Assistant

                          Comment


                          • #28
                            Originally posted by NeverDie View Post
                            Thanks for the idea. I don't yet see a way to confer special powers to a user named "admin", unless perhaps "admin" is a reserved word that gets special powers automatically. Maybe the power is part of "Linux Tools"?

                            [ATTACH]42727[/ATTACH]

                            In any case, it's moot, because I can't change/add/delete anything regarding web users without entering the system password. I'll try changing it tonight when I have more time.
                            This is showing up for me when I upgrade to HS3.293 on my Ubuntu 14.04 x86_64 system. And yes, it is looking for the password to the Linux user account "homeseer"; I am able to change the password once I set (and use as the old password) a password for this user account.

                            Note to Homeseer team: For security reasons, I disable interactive access to this account; there is no password - and that is good system practice. So you are essentially forcing me to reduce system security. If I want to access Linux shell commands, I won't do it on the web - I will use my personal account and the utility, "sudo". I'm retired from a very large computer manufacturer; your "Unix Tools" procedure violates that company's standards.

                            Comment


                            • #29
                              So if I've got this straight (and please correct me if I'm wrong),

                              The Linux version of HS3 expects to run as the Linux user 'homeseer'. It expects you to change this password on first start-up. If the user 'homeseer' doesn't exits on the Linux system, it pops up an error such as other here have reported.

                              Question? Is the 'homeseer' user is a superuser (root equivalent) or just a regular user?

                              In this same screen, it also wants you to create a HS3 user/password, which will become the default administrator for HS3. Additional HS3 users can be created in the 'Network' tab of 'Tools->Setup'. These users can be privileged or not and are separate and distinct from Linux users.

                              Now, I'm running HS3 (3.0.0.293) on OpenSuSE Leap 42.1, using my own Linux and HS3 user setup - no 'homeseer' user to be found. As such, I encountered the same error that others reported when trying to change the 'system' user password. HS Tech Support told me I could safely ignore the error, and bypass that section of the page.

                              When I got to the 'Tools->System->Linux Tools' page, I am presented with a username/password box. It asks for the system user (default is 'homeseer') and the system password to access Linux tools. As I've no Linux user 'homeseer' that won't work; however I can login with a regular (non-superuser) Linux user. At that point it presents a dialog to enter a command and execute it. Here I encounter the same results as Pete - it prints 'running command ...' and nothing else happens.

                              Poking around in the HS3 directory I came across two shell scripts - run_command.sh and run_command_raw.sh. It seems that HS3 is taking the command we enter and passing it to the run_command.sh script which prints out the 'running command...' and then executes the command. However, run_command.sh pipes the output of any commands it executes to something 'aha' - I don't know what that is in reference to, but removing it makes the whole thing work.

                              I replaced the existing run_command.sh script:
                              Code:
                              #!/bin/sh
                              echo running command $1
                              $! | aha
                              with
                              Code:
                              #!/bin/sh
                              echo running command $1
                              $1
                              And now I can login to the Linux tools page as a regular Linux user and execute commands. Not quite as nice as a SSH terminal, but handy for some things maybe.

                              I don't know what the run_command_raw.sh script is used for.

                              This seems like a good place to make a few notes about TTS (Text To Speech) in non Debian distros too. By default Linux HS3 makes use of the speak.sh script to speak alerts, etc.

                              Looking at speak.sh:
                              Code:
                              #!/bin/sh
                              #flite -voice kall16 -t "$1"
                              pico2wave -w=temp.wav "$1"
                              aplay temp.wave
                              We see that it uses pico2wave to generate a wave file of the text to be spoken. It then uses aplay for actual playing of the file. If pico2wave is not available for your distro (it was very difficult to find as a RPM) you can simply uncomment the second line and comment out the last two lines to change from pico2wave to flite as the speech engine.

                              Code:
                              #!/bin/sh
                              flite -voice kall16 -t "$1"
                              #pico2wave -w=temp.wav "$1"
                              #aplay temp.wave
                              This has some interesting possibilities - you should be able to use other TTS engines, like Festival, if you were so inclined. Also, it seems to indicate that flite is not actually required for HS3 to run.

                              Thanks for helping me figure this out,
                              -Alex

                              Comment


                              • #30
                                Nice job getting that Linux tools to work. I took the cowards approach and just made a homeseer user with a huge password that I never actually use so I could bypass the page.

                                Comment

                                Working...
                                X