No announcement yet.

HS3 .152 upgrades with port 80

  • Filter
  • Time
  • Show
Clear All
new posts

    Bug after all?

    Originally posted by Rupp View Post
    HomeSeer attempts to start the port listed in the ini settings. If this port is busy it bumps up to the next port. So something must have already been using the ini port setting. Is that possible?
    I checked once more: my HS runs on port 8080, I shut it down and started another program on port 8080, then restarted HS3: startup log says:

    1/01/2015 12:01:46 ~!~Web Server~!~Web Server started on port 8080
    31/01/2015 12:01:46 ~!~Warning~!~Error starting web server, port in use? Only one usage of each socket address (protocol/network address/port) is normally permitted
    31/01/2015 12:01:46 ~!~Warning~!~Web Server Stopped

    So HS3 detects correctly that port 8080 is in use but doesn't adapt accordingly.
    With previous releases HS3 changed to the next available port, like Rupp says. However I changed also my OS: I had Windows 7 32 bit, now I am running the 64 bit version so maybe that's something to consider.
    As this is reproducible I re-introduced it in Bugzilla as #2575


      Interesting. I accidentally let my hs3 vm run out of memory the other day, which really knacks things up.
      When I finally got it sorted. Same thing, Port in use. Had to do net stop also to change it back.


        Finally an answer from HomeSeer on Bugzilla:
        We removed that feature as there were cases where it would change the port when you did not want it to and the user would not know what port it was on.
        Seems strange to me: the port number was clearly stated during startup, and when a port was changed there was even a voice announcement and you can see it in the URL. Three announcements and there are people who still are confused?
        But I guess you cannot satisfy all of your customers all of the time


          I just recently updated my HS3 version and now it's giving me the port 80 error that it's in use. Has anyone figured out a solution to this? I've tried editing my config.ini file and also changing it to configold and making a new config.ini file with no luck. I also tried doing a repair from downloading the install file again. Maybe I need to do a complete re-install? But if so is there a way to save my nodes and settings? Or if I re-install will I need to redo all of that and will I be able to add the same devices again easily even though they were already added? I'm still new to all of this so I apologize for my noobness lol.