Announcement

Collapse
No announcement yet.

ERR_INVALID_HTTP_RESPONSE - Solution!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    ERR_INVALID_HTTP_RESPONSE - Solution!

    Hi,
    I just did the upgrade from HS3 to HS4. The startup gave no errors, but I cannot view the webpage. I get this error when trying to view it: ERR_INVALID_HTTP_RESPONSE

    What should I do?

    Troy

    #2
    So I rolled back to HS3 and changed the webport to 80, then went through the upgrade process. Once this was done I was able to change HS4 to my original port and it works. The issue that I am having now is that I cannot get Alexa to work. I tried forgetting all voice commands and changing my license on myhs. I also disabbled and re enabled both Homeseer skills as I am not sure which is the right one. When I try to import devices, Alexa finds nothing. I just rolled back to HS3 and Alexa discovered everything I had before. I am so confused.

    Comment


      #3
      Same issue here- above solution worked.
      Set web port to 80 first, then upgrade.
      Maybe over-riding in the settings.ini file post upgrade may work too. I guess at this point it wants to launch http://127.0.0.1/register.html for the first time using port 80

      Comment


        #4
        This is still happening in the release version. Unbelievable. Changing my port back to 80 in settings.ini after copying the files got me to the registration screen.

        Comment


          #5
          Which directory is that in on a SEL? I just ran into the same issue, the only settings.ini file for homeseer, I can find is in /media/homeseer and I can not do a sudo cd to that directory, nor can I authenticate with su. In addition, rollback is not an option on the 911 page. I did open a case with homeseer support.

          Comment


            #6
            I have this problem and I tried changing the port to 80 but I get this error:

            HomeSeer~!~Warning~!~Error starting web server, port in use? Are you running a web server on the designated port? Edit settings.ini in the Config folder and change gWebSvrPort=## to a different port #.

            As far as I know, or can tell, I don't have any web servers on my PC or LAN but I do have many IoT devices and Alexa and HomeKit running.

            Is there another way to register HS4 or a different workaround? Your help is appreciated.

            Comment


              #7
              Originally posted by diffusionLTD View Post
              I have this problem and I tried changing the port to 80 but I get this error:

              HomeSeer~!~Warning~!~Error starting web server, port in use? Are you running a web server on the designated port? Edit settings.ini in the Config folder and change gWebSvrPort=## to a different port #.

              As far as I know, or can tell, I don't have any web servers on my PC or LAN but I do have many IoT devices and Alexa and HomeKit running.

              Is there another way to register HS4 or a different workaround? Your help is appreciated.
              Ditto. I just upgraded from HS3 Pro to HS4 Pro and now have no working system due to this. Did you figure this out?

              Comment


                #8
                You can leave your custom port in place but when HS tries to load the register page it defaults to port 80. Edit the URL link that wasn't found (i.e http://192.168.1.100/register.html) and enter/add your custom port, i.e.. http://192.168.1.100:88/register.html (replace "88" with your custom port) and the register page should then load...

                Comment


                  #9
                  Originally posted by dbrunt View Post
                  You can leave your custom port in place but when HS tries to load the register page it defaults to port 80. Edit the URL link that wasn't found (i.e http://192.168.1.100/register.html) and enter/add your custom port, i.e.. http://192.168.1.100:88/register.html (replace "88" with your custom port) and the register page should then load...
                  Yep that worked, had to change the last three digits of the IP to match as well. Registered and now HS4 is up and running. Thanks so much!

                  Comment


                    #10
                    For mine, it kept trying to go to Http://192.168.xx.xx:85/devices.html and then failed.... I couldn't change to port 80 as I had other things using 80. But i just updated the URL to http://192.168.xx.xx:85/register.html and off we went... works fine now.

                    Comment


                      #11
                      Would welcome a procedure to make this fail, I have tried everything. Following the procedure here exactly. Only difference might be is that I am testing a clean install of HS3. I then set the port to 82, uninstall, then install HS4 over HS3. Always starts just fine on port 82. The Windows firewall is enabled and this is on WIndows 10. I even took a users HS3 install and tried it, worked fine on my systems here. Obviously missing something. The web server in HS4 is the same as HS3 and so are the settings. The error does not make any sense.
                      website | buy now | support | youtube

                      Comment


                        #12
                        Big change I see write off is that I run on a Server class machine. (Windows Server 2016 as I recall) and that might make a difference. Lots of overhead and various impediments when IIS is involved. Even if the web server is native hosted within HS4. For me the issue was the devices page was not allowed until registration was finished and somehow the link to the register page was not auto-forwarded to.

                        Comment

                        Working...
                        X