Announcement

Collapse
No announcement yet.

Script problems since 4.1.1.0

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • janjanssen
    replied
    Wow, that was fast. Problem solved. THANK YOU!

    Leave a comment:


  • jon00
    replied
    Looks like you have lost some of your references.

    Open up settings.ini found in your Config directory. You should see an entry called ScriptingReferences=xxxxxxxx under the [Settings] heading.

    If it is missing, check within a backup copy of settings.ini (you do make backups don't you? ).

    If found, you can probably just replace the settings.ini from the backup.

    if you don't have a backup, add the following under [Settings]:

    ScriptingReferences=System.Drawing;System.Drawing.dll

    It is important that changes to settings.ini can only be carried out when HS4 is shut-down.

    Restart HS4 and see if the Drawing.Graphics error is resolved.

    Leave a comment:


  • janjanssen
    started a topic Script problems since 4.1.1.0

    Script problems since 4.1.1.0

    Hi,

    Since updating to 4.1.1.0 I have two scripts that create errors now:

    ===
    Compiling script C:\Program Files (x86)\HomeSeer HS3\scripts\JOWI_PictureRandom.vb: Type 'Drawing.Graphics' is not defined.

    Compiling script C:\Program Files (x86)\HomeSeer HS3\scripts\JOWI_PictureRandom.vb: Type 'Drawing.Bitmap' is not defined.
    Compiling script C:\Program Files (x86)\HomeSeer HS3\scripts\JOWI_PictureRandom.vb: Type 'Drawing.Bitmap' is not defined.
    Compiling script C:\Program Files (x86)\HomeSeer HS3\scripts\JOWI_PictureRandom.vb: Namespace or type specified in the Imports 'System.Core' doesn't contain any public member or cannot be found. Make sure the namespace or the type is defined and contains at least one public member. Make sure the imported element name doesn't use any aliases.

    ===
    Compiling script C:\Program Files (x86)\HomeSeer HS3\scripts\Read_Fronius_Inverter.vb: Namespace or type specified in the Imports 'Newtonsoft.Json.Linq' doesn't contain any public member or cannot be found. Make sure the namespace or the type is defined and contains at least one public member. Make sure the imported element name doesn't use any aliases.

    Compiling script C:\Program Files (x86)\HomeSeer HS3\scripts\Read_Fronius_Inverter.vb: Namespace or type specified in the Imports 'Newtonsoft.Json' doesn't contain any public member or cannot be found. Make sure the namespace or the type is defined and contains at least one public member. Make sure the imported element name doesn't use any aliases.

    Compiling script C:\Program Files (x86)\HomeSeer HS3\scripts\Read_Fronius_Inverter.vb: Namespace or type specified in the Imports 'System.Core' doesn't contain any public member or cannot be found. Make sure the namespace or the type is defined and contains at least one public member. Make sure the imported element name doesn't use any aliases.

    ===

    Anyone a suggestion what the problem could be with the scripts? Or would it be due to a bug/change in 4.1.1.0?

    Thank you,
    Jan​​
Working...
X