Announcement

Collapse
No announcement yet.

HS4 Linux 4_1_1_0 to Linux 4_1_2_0 update-Date and time format defaults to US

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #16
    https://www.simplypsychology.org/preoperational.html

    we can’t help. This is pure egocentrism thinking

    Comment


      #17
      Originally posted by Tillsy View Post
      On the other hand, this is a cosmetic issue that has bugged me in both HS3 and HS4 because even though my Pi is set to correct timezone HS3 and HS4 both say 7th of the 25th 2020, so will look into the above suggestion(s).
      I’m not using a Pi, I use a Rock64 with Armbian Linux running on a kernel I built myself. I think I’ve solved the log problem and will forward the solution to HS tech support directly. Not much point posting the solution here for obvious reasons.

      Comment


        #18
        G14

        Comment


          #19
          Okay my go file had:
          export LANG=en_US.UTF-8

          However my Pi is set to:
          en_AU.UTF-8

          This made no difference because I fire off autostart_hs during Linux startup, so found same setting there too and sure enough I now have correct dates appearing everywhere - woohoo

          Curious why these needs manually setting though - does mono not provide access to it from the OS?

          Also concordeer I have one plugin that has had a big-*** crash in the log because of Aussie date format... your advice would be to ignore but I reckon I should reach out to the developer.

          What the actual?!? When I make a sarcastic remark or joke it is moderated/deleted.
          But you specifically go out of your way to label multiple HS4 issues that cause data loss/crash of HS4 to be "grumbles".
          I can't even begin to put into words how offensive this is.

          Comment


            #20
            FWIW, HS4 setup doesn't change when raspi-config locale is changed from US. Correct setup of the Pi is being altered by HS4.

            Click image for larger version

Name:	locale.png
Views:	39
Size:	46.5 KB
ID:	1405610
            Pretty annoying really, at least we are not stuck with Farenheit.

            Comment


              #21
              Originally posted by Tillsy View Post
              Okay my go file had:
              export LANG=en_US.UTF-8

              However my Pi is set to:
              en_AU.UTF-8

              This made no difference because I fire off autostart_hs during Linux startup, so found same setting there too and sure enough I now have correct dates appearing everywhere - woohoo

              Curious why these needs manually setting though - does mono not provide access to it from the OS?

              Also concordeer I have one plugin that has had a big-*** crash in the log because of Aussie date format... your advice would be to ignore but I reckon I should reach out to the developer.
              I outlined above how I resolved my Date/Time issue. That resolved all the Date/Time issues in HS4 with the exception of the log entries.

              As I run my setup via an SD card I generally have logging disabled to preserve the life of the SD card. I only enable it to troubleshoot my system.

              I use my own homeseer.service daemon so I don’t use any of the provided HS scripts so I can’t comment on ./go or autostart_hs.

              Yes I’d take up any issues I had with a plugin with the author particularly if you paid for it. If it’s now listed as legacy I’d also enquire if the author intended to develop a HS4 version of it.

              Comment


                #22
                Originally posted by Black Cat View Post
                FWIW, HS4 setup doesn't change when raspi-config locale is changed from US. Correct setup of the Pi is being altered by HS4.

                Click image for larger version

Name:	locale.png
Views:	39
Size:	46.5 KB
ID:	1405610
                Pretty annoying really, at least we are not stuck with Farenheit.
                Have you tried manually adjusting your locale file and default locale as I outlined above.

                Comment


                  #23
                  We added the timezone setting to setup for Zee (RPI), but that is not the same as the encoding. I have figured out how to set the encoding without using raspi-config so I will add that to setup in the next build. That will take care of the date/time formatting. I will leave it in for the standard Linux as it will probably work on most flavors of Linux.

                  website | buy now | support | youtube

                  Comment


                    #24
                    ^^^
                    Thanks for that, nice to see that you are on top of these minor bugs.

                    Comment


                      #25
                      Originally posted by rjh View Post
                      We added the timezone setting to setup for Zee (RPI), but that is not the same as the encoding. I have figured out how to set the encoding without using raspi-config so I will add that to setup in the next build. That will take care of the date/time formatting. I will leave it in for the standard Linux as it will probably work on most flavors of Linux.
                      Thanks Rich.

                      I think I’ve ironed out all the settings in the locale file I need now. Everything is running fine now. Armbian can be a little temperamental particularly after an OS update.

                      Comment

                      Working...
                      X