Announcement

Collapse
No announcement yet.

HS4 Alexa Discovery

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    HS4 Alexa Discovery

    Hi,
    I upgraded to HS4 and reconnected my Alexa service. I also ensured that the correct license for HS4 is entered into myhs. When I run discovery, all of my devices that I had configured previously on HS3 show up and I can control them. I cannot add new devices from HS4 though. I go to the device and check voice control. This saves, but the discover part of Alexa does not show the device. I have tried with and without device setting the voice command. Has anyone else had this issue?

    #2
    Is it a device that Alexa can handle? Alexa only accepts certain devices like on/off, dim, thermostats i believe, and maybe a couple others.

    Comment


      #3
      Originally posted by Peiloy View Post
      Hi,
      I upgraded to HS4 and reconnected my Alexa service. I also ensured that the correct license for HS4 is entered into myhs. When I run discovery, all of my devices that I had configured previously on HS3 show up and I can control them. I cannot add new devices from HS4 though. I go to the device and check voice control. This saves, but the discover part of Alexa does not show the device. I have tried with and without device setting the voice command. Has anyone else had this issue?
      Disable Alexa Skill
      Select/Convert MyHS license from HS3 to HS4
      Ensure MyHS works while not connected to LAN.
      Delete all Homeseer devices/scenes in Alexa
      Enable Alexa Skill
      If discovery fails, disable voice control on all devices and events and re-enable one-by-one or in batches to troubleshoot which one is causing discovery to puke. Or try the reverse and start disabling voice command on devices/events.
      Alexa is a little picky about the name/voice command string...

      Comment


        #4
        Originally posted by mulu View Post
        Is it a device that Alexa can handle? Alexa only accepts certain devices like on/off, dim, thermostats i believe, and maybe a couple others.
        Yes. These are homeseer dimmers.

        Comment


          #5
          Originally posted by dbrunt View Post

          Disable Alexa Skill
          Select/Convert MyHS license from HS3 to HS4
          Ensure MyHS works while not connected to LAN.
          Delete all Homeseer devices/scenes in Alexa
          Enable Alexa Skill
          If discovery fails, disable voice control on all devices and events and re-enable one-by-one or in batches to troubleshoot which one is causing discovery to puke. Or try the reverse and start disabling voice command on devices/events.
          Alexa is a little picky about the name/voice command string...
          Ill try this. Is there a way to disable voice on all devices as a batch?

          Comment


            #6
            Ok. So when I try to connect through myhs remotely/while not connected to LAN, no devices load. Myhs does work locally. What is the next step in troubleshooting this problem?

            Comment


              #7
              Is your myHS username & password entered as a local system user?

              Click image for larger version

Name:	mhHS User credentials.PNG
Views:	96
Size:	160.4 KB
ID:	1406501

              Comment


                #8
                I re-read your last post so I presume your myHS user IS entered correctly. Check your log to see if your HS system has connected to myHS...

                Click image for larger version

Name:	myHS connection.PNG
Views:	99
Size:	65.3 KB
ID:	1406507

                Comment


                  #9
                  On 2nd thought, verify both of the above!

                  Comment


                    #10
                    Originally posted by Peiloy View Post

                    Ill try this. Is there a way to disable voice on all devices as a batch?
                    Enable Bulk Edit and then Bulk Actions appears where you can Enable/Disable Voice on selected items. Disable voice on everything. Then create a category named Voice Enabled and assign that category to your devices you want to enable Voice Enabled for Alexa to discover. This is what I've done for quick and easy filtered device display and manipulation of the Voice Enabled option for my Alexa discovery. Just remember to add the new category to new devices when you enable Voice on it...
                    .
                    Click image for larger version  Name:	Bulk Edit.PNG Views:	0 Size:	254.7 KB ID:	1406515

                    Comment


                      #11
                      So I did not have my MyHS user name and password under users, which I added now and can connect through MyHS remotely. The log shows it connecting too. I still cannot discover any devices via Alexa though. The next step is to disable all voice control and enable one by one as you suggested. Ill keep you posted.

                      Comment


                        #12
                        I just finished removing all voice enabled devices and tried to add back just one. It does not work though and I cant get back the devices that were there before. Im not sure what to do now.

                        Comment


                          #13
                          Exactly the same issue with Google Home. I cannot see any devices.

                          Comment


                            #14
                            My Checklist:
                            Is your MyHS license converted/upgraded from HS3 to HS4 at myhs.homeseer.com?
                            Is your MyHS username/password listed under Setup, Users?
                            Is Enable Remote Access through MyHS Service enabled via Setup, Network?
                            Is Enable Control with JSON (Required for Alexa/Google Home/IFTTT/Etc.) enabled (also under Settings, Network)
                            Does your HS log show that it has successfully connected to MyHS?
                            Does the MyHS app work when it is connected remotely?
                            Disable and re-enable Alexa skill...
                            Contact HST Support to check your MyHS license with regards to Alexa integration...

                            Comment


                              #15
                              Originally posted by dbrunt View Post
                              My Checklist:
                              Yes. Is your MyHS license converted/upgraded from HS3 to HS4 at myhs.homeseer.com?
                              Yes. Is your MyHS username/password listed under Setup, Users?
                              Yes. Is Enable Remote Access through MyHS Service enabled via Setup, Network?
                              Yes. Is Enable Control with JSON (Required for Alexa/Google Home/IFTTT/Etc.) enabled (also under Settings, Network)
                              Yes. Does your HS log show that it has successfully connected to MyHS?
                              Yes. Does the MyHS app work when it is connected remotely?
                              Done. Disable and re-enable Alexa skill...
                              Just sent a ticket. Contact HST Support to check your MyHS license with regards to Alexa integration...
                              Thanks for your help! I sent in a ticket. Ill respond when I hear from them.

                              Comment

                              Working...
                              X