Announcement

Collapse
No announcement yet.

HS4 V4.1.2.0 Log times off

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    HS4 V4.1.2.0 Log times off

    Updated this morning to HS4 V4.1.2.0

    Times are way off in the logging. Also my clip and paste of logging from either Firefox or Chrome looks like this now.

    Bottom of log now is days in future which do not exist.


    7/27/2020 12:27:48 PM
    HomeSeer
    Startup
    ************************************************************ ********************


    7/27/2020 12:27:48 PM
    HomeSeer
    Startup
    HomeSeer version 4.1.2.0 Edition: HS4 Pro Starting Now


    7/27/2020 12:27:48 PM
    HomeSeer
    Startup
    ************************************************************ ********************


    7/27/2020 12:27:48 PM
    HomeSeer
    Startup



    7/27/2020 12:27:48 PM
    HomeSeer
    Startup
    Creating Class Objects...


    7/27/2020 12:27:48 PM
    HomeSeer
    Startup
    COM port classes started.


    7/27/2020 12:27:48 PM
    HomeSeer
    Startup
    Application interface class started.


    7/27/2020 12:27:48 PM
    HomeSeer
    Startup
    Web server class started.


    7/27/2020 12:27:48 PM
    HomeSeer
    Startup
    E-Mail SEND class started.


    7/27/2020 12:27:48 PM
    HomeSeer
    Startup
    E-Mail RECEIVE class started.


    7/27/2020 12:27:48 PM
    HomeSeer
    Startup
    Plug-In Interface class started.


    7/27/2020 12:27:48 PM
    HomeSeer
    Startup
    Local voice recognition class started.


    7/27/2020 12:27:48 PM
    HomeSeer
    Startup
    Loading configuration file ...


    7/27/2020 12:27:49 PM
    HomeSeer
    Info
    Loaded 10 Devices.


    7/27/2020 12:27:49 PM
    HomeSeer
    Info
    Loaded 5 Events.


    7/27/2020 12:27:49 PM
    HomeSeer
    Warning
    Unable to load counters config file, trying backup


    7/27/2020 12:27:49 PM
    HomeSeer
    Error
    Unable to load counters from normal or backup file!


    7/27/2020 12:27:49 PM
    HomeSeer
    Warning
    Unable to load timers config file, trying backup


    7/27/2020 12:27:49 PM
    HomeSeer
    Error
    Unable to load timers from normal or backup file!


    7/27/2020 12:27:49 PM
    HomeSeer
    Startup
    HomeSeer version is: 4.1.2.0


    7/27/2020 12:27:49 PM
    HomeSeer
    Startup
    Creating Speaker Client Interface Object...


    7/27/2020 12:27:49 PM
    HomeSeer
    Startup
    This version of HomeSeer is registered as a HS4PRO version.


    7/27/2020 12:27:49 PM
    HomeSeer
    Web Server
    Local IP address is: 192.168.244.172


    7/27/2020 12:27:49 PM
    HomeSeer
    Web Server
    Web Server started on port 9999


    7/27/2020 12:27:49 PM
    HomeSeer
    Startup
    Start automation engine...



    Back to the future logs:


    7/31/2020 3:00:00 AM
    HomeSeer
    Info
    Stopping the MyHS Service...


    7/31/2020 10:35:23 PM
    HomeSeer
    ASR
    Speaker Client speech recognition stopped

    Time on Ubuntu server is configured via NTP on the OS. It is correct.

    Top bar of HS4 indicates correct time. It is just the logs which are way off time wise.
    - Pete

    Auto mator
    Homeseer 3 Pro - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e 64 bit Intel Haswell CPU 16Gb- Mono 6.8X
    Homeseer Zee2 (Lite) - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e - CherryTrail x5-Z8350 BeeLink 4Gb BT3 Pro - Mono 6.8X
    HS4 Pro - V4.1.2.0 - Ubuntu 18.04/VB W7e 64 bit Intel Kaby Lake CPU - 32Gb - Mono 6.10.0.104
    HS4 Lite -

    X10, UPB, Zigbee, ZWave and Wifi MQTT automation. OmniPro 2, Russound zoned audio, Smartthings hub, Hubitat Hub, and Home Assistant

    #2
    Opened up a bug report titled: HS4 V4.1.2.0 Log times off

    Just noticed this:


    Location (Sunrise 5:39 AM Sunset 8:13 PM) Current Time: Monday, July 27, 2020 1:42 PM which is 5 hours ahead of current time.
    Looks to be GMT time in 12 hour format (AM/PM).

    Title bar time is correct:
    8:43:15 AM | 7/27/2020

    Thinking its been like this in the last couple of versions from looking at the logs. Only have looked at the time on top bar and not in the general / setup page.


    - Pete

    Auto mator
    Homeseer 3 Pro - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e 64 bit Intel Haswell CPU 16Gb- Mono 6.8X
    Homeseer Zee2 (Lite) - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e - CherryTrail x5-Z8350 BeeLink 4Gb BT3 Pro - Mono 6.8X
    HS4 Pro - V4.1.2.0 - Ubuntu 18.04/VB W7e 64 bit Intel Kaby Lake CPU - 32Gb - Mono 6.10.0.104
    HS4 Lite -

    X10, UPB, Zigbee, ZWave and Wifi MQTT automation. OmniPro 2, Russound zoned audio, Smartthings hub, Hubitat Hub, and Home Assistant

    Comment


      #3
      Originally posted by Pete View Post
      Opened up a bug report titled: HS4 V4.1.2.0 Log times off

      Just noticed this:


      Location (Sunrise 5:39 AM Sunset 8:13 PM) Current Time: Monday, July 27, 2020 1:42 PM which is 5 hours ahead of current time.
      Looks to be GMT time in 12 hour format (AM/PM).

      Title bar time is correct:
      8:43:15 AM | 7/27/2020

      Thinking its been like this in the last couple of versions from looking at the logs. Only have looked at the time on top bar and not in the general / setup page.

      Pete have you inspected the locales recently in Ubuntu 18.04. I was having strange moments in Armbian so I went in and manually adjusted my locales as per this https://www.google.ie/amp/s/lintut.c...ntu-18-04/amp/ and it seemed to have done the trick.

      The counters and timers issue is an easy enough fix as I imagine you have gathered by now.

      Comment


        #4
        Thank you concordseer

        Here have always been particular about time and never paid attention much to HS time settings in Linux.

        So a quickie review:


        locale
        LANG=en_US.UTF-8
        LANGUAGE=
        LC_CTYPE="en_US.UTF-8"
        LC_NUMERIC="en_US.UTF-8"
        LC_TIME="en_US.UTF-8"
        LC_COLLATE="en_US.UTF-8"
        LC_MONETARY="en_US.UTF-8"
        LC_MESSAGES="en_US.UTF-8"
        LC_PAPER="en_US.UTF-8"
        LC_NAME="en_US.UTF-8"
        LC_ADDRESS="en_US.UTF-8"
        LC_TELEPHONE="en_US.UTF-8"
        LC_MEASUREMENT="en_US.UTF-8"
        LC_IDENTIFICATION="en_US.UTF-8"
        LC_ALL=

        Ahh...just noticed this:

        root@ICS-HS4:~# date
        Mon Jul 27 19:02:02 CDT 2020

        Which is wrong.

        /etc# timedatectl
        Local time: Mon 2020-07-27 19:07:16 CDT
        Universal time: Tue 2020-07-28 00:07:16 UTC
        RTC time: Tue 2020-07-28 00:02:26
        Time zone: America/Chicago (CDT, -0500)
        System clock synchronized: yes
        systemd-timesyncd.service active: yes
        RTC in local TZ: no


        Which is also wrong.

        Doesn't make sense to me that these settings are off as I am using my NTP server on PFSense.

        So shut down HS4. Via command line did the following:

        service ntp stop
        root@ICS-HS4:/etc# ntpdate 192.168.244.129
        27 Jul 11:34:49 ntpdate[3502]: step time server 192.168.244.129 offset -28517.239031 sec
        root@ICS-HS4:/etc# date
        Mon Jul 27 11:35:04 CDT 2020

        Now time is correct.

        Before rebooting going to the NTP server and see it fine:

        ntpq -c clockvar
        associd=0 status=00f0 15 events, clk_unspec,
        device="NMEA GPS Clock",
        timecode="$GPGGA,164417.000,4133.3944,N,08746.9257,W,2,7,1.2 3,237.4,M,-34.0,M,0000,0000*68",
        poll=33705, noreply=0, badformat=0, baddata=0, fudgetime2=407.000,
        stratum=0, refid=GPS, flags=5

        Code:
        ntpq> lopeers
        remote local st t when poll reach delay offset disp
        ============================================================ ==================
        oGPS_NMEA(0) 127.0.0.1 0 l 5 16 377 0.000 +0.001 0.232
        0.0.0.0 0.0.0.0 16 p - 64 0 0.000 +0.000 16000.0
        0.0.0.0 0.0.0.0 16 p - 64 0 0.000 +0.000 16000.0
        -time1.google.co _14ff:fe9e:d7cf 1 u 26 64 377 38.924 -4.572 4.287
        +time2.google.co _14ff:fe9e:d7cf 1 u 46 64 377 20.564 +2.472 4.852
        *time3.google.co _14ff:fe9e:d7cf 1 u 30 64 377 20.705 +2.473 2.362
        +t2.time.gq1.yah 192.168.244.129 2 u 3 64 377 65.733 +1.819 2.088
        dns.phoenix591. 192.168.244.129 2 u 77h 512 0 34.593 +2.981 15937.5
        -nu.binary.net 192.168.244.129 2 u 38 64 21 23.855 +3.011 12.413
        -time.richiemcin 192.168.244.129 2 u 4 64 377 31.692 +2.388 3.525
        ntpq>

        so now rebooting server with HS4 autostarting to see if it is HS that is changing the time.

        Thinking that may be my issue as I do not have this issue with the two Ubuntu HS3 boxes running on Ubuntu 18.04.

        So here HS4 is not running yet. I put a delay on reboot.

        root@ICS-HS4:~# date
        Mon Jul 27 11:52:13 CDT 2020

        Time is correct.

        Homeseer is running now and time remained correct.

        root@ICS-HS4:~# date
        Mon Jul 27 11:56:46 CDT 2020

        So other than the old "back to the future" log entries I am OK with current log entries.



        - Pete

        Auto mator
        Homeseer 3 Pro - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e 64 bit Intel Haswell CPU 16Gb- Mono 6.8X
        Homeseer Zee2 (Lite) - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e - CherryTrail x5-Z8350 BeeLink 4Gb BT3 Pro - Mono 6.8X
        HS4 Pro - V4.1.2.0 - Ubuntu 18.04/VB W7e 64 bit Intel Kaby Lake CPU - 32Gb - Mono 6.10.0.104
        HS4 Lite -

        X10, UPB, Zigbee, ZWave and Wifi MQTT automation. OmniPro 2, Russound zoned audio, Smartthings hub, Hubitat Hub, and Home Assistant

        Comment


          #5
          Originally posted by Pete View Post
          Thank you concordseer

          Here have always been particular about time and never paid attention much to HS time settings in Linux.

          So a quickie review:


          locale
          LANG=en_US.UTF-8
          LANGUAGE=
          LC_CTYPE="en_US.UTF-8"
          LC_NUMERIC="en_US.UTF-8"
          LC_TIME="en_US.UTF-8"
          LC_COLLATE="en_US.UTF-8"
          LC_MONETARY="en_US.UTF-8"
          LC_MESSAGES="en_US.UTF-8"
          LC_PAPER="en_US.UTF-8"
          LC_NAME="en_US.UTF-8"
          LC_ADDRESS="en_US.UTF-8"
          LC_TELEPHONE="en_US.UTF-8"
          LC_MEASUREMENT="en_US.UTF-8"
          LC_IDENTIFICATION="en_US.UTF-8"
          LC_ALL=

          Ahh...just noticed this:

          root@ICS-HS4:~# date
          Mon Jul 27 19:02:02 CDT 2020

          Which is wrong.

          /etc# timedatectl
          Local time: Mon 2020-07-27 19:07:16 CDT
          Universal time: Tue 2020-07-28 00:07:16 UTC
          RTC time: Tue 2020-07-28 00:02:26
          Time zone: America/Chicago (CDT, -0500)
          System clock synchronized: yes
          systemd-timesyncd.service active: yes
          RTC in local TZ: no


          Which is also wrong.

          Doesn't make sense to me that these settings are off as I am using my NTP server on PFSense.

          So shut down HS4. Via command line did the following:

          service ntp stop
          root@ICS-HS4:/etc# ntpdate 192.168.244.129
          27 Jul 11:34:49 ntpdate[3502]: step time server 192.168.244.129 offset -28517.239031 sec
          root@ICS-HS4:/etc# date
          Mon Jul 27 11:35:04 CDT 2020

          Now time is correct.

          Before rebooting going to the NTP server and see it fine:

          ntpq -c clockvar
          associd=0 status=00f0 15 events, clk_unspec,
          device="NMEA GPS Clock",
          timecode="$GPGGA,164417.000,4133.3944,N,08746.9257,W,2,7,1.2 3,237.4,M,-34.0,M,0000,0000*68",
          poll=33705, noreply=0, badformat=0, baddata=0, fudgetime2=407.000,
          stratum=0, refid=GPS, flags=5

          Code:
          ntpq> lopeers
          remote local st t when poll reach delay offset disp
          ============================================================ ==================
          oGPS_NMEA(0) 127.0.0.1 0 l 5 16 377 0.000 +0.001 0.232
          0.0.0.0 0.0.0.0 16 p - 64 0 0.000 +0.000 16000.0
          0.0.0.0 0.0.0.0 16 p - 64 0 0.000 +0.000 16000.0
          -time1.google.co _14ff:fe9e:d7cf 1 u 26 64 377 38.924 -4.572 4.287
          +time2.google.co _14ff:fe9e:d7cf 1 u 46 64 377 20.564 +2.472 4.852
          *time3.google.co _14ff:fe9e:d7cf 1 u 30 64 377 20.705 +2.473 2.362
          +t2.time.gq1.yah 192.168.244.129 2 u 3 64 377 65.733 +1.819 2.088
          dns.phoenix591. 192.168.244.129 2 u 77h 512 0 34.593 +2.981 15937.5
          -nu.binary.net 192.168.244.129 2 u 38 64 21 23.855 +3.011 12.413
          -time.richiemcin 192.168.244.129 2 u 4 64 377 31.692 +2.388 3.525
          ntpq>

          so now rebooting server with HS4 autostarting to see if it is HS that is changing the time.

          Thinking that may be my issue as I do not have this issue with the two Ubuntu HS3 boxes running on Ubuntu 18.04.

          So here HS4 is not running yet. I put a delay on reboot.

          root@ICS-HS4:~# date
          Mon Jul 27 11:52:13 CDT 2020

          Time is correct.

          Homeseer is running now and time remained correct.

          root@ICS-HS4:~# date
          Mon Jul 27 11:56:46 CDT 2020

          So other than the old "back to the future" log entries I am OK with current log entries.


          Check out Step 3 in this link. This is the route I took purely for Systemd purposes https://www.google.ie/amp/s/www.digi...-debian-10.amp

          For someone who runs more than one Linux box you might want to experiment with Chrony https://opensource.com/article/18/12/manage-ntp-chrony
          Might be worth while having your own ntp server. Reckon it’s worth a spin.

          Comment


            #6
            Thank you concordseer

            Yes today the NTP server on PFSense is running on BSD and using a modded GPS with PPS on one of the 9 serial wires.

            The GPS antenna has a good view of 9 of 11 GPS satellites.

            Have around 8-9 Ubuntu servers running on Intel CPUs. I was running HS3 Lite on a TV Box with Armbian on an S912 chipset. Switched the box over to being a KODI box and went to using an Intel Beelink BT3 Pro now.
            - Pete

            Auto mator
            Homeseer 3 Pro - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e 64 bit Intel Haswell CPU 16Gb- Mono 6.8X
            Homeseer Zee2 (Lite) - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e - CherryTrail x5-Z8350 BeeLink 4Gb BT3 Pro - Mono 6.8X
            HS4 Pro - V4.1.2.0 - Ubuntu 18.04/VB W7e 64 bit Intel Kaby Lake CPU - 32Gb - Mono 6.10.0.104
            HS4 Lite -

            X10, UPB, Zigbee, ZWave and Wifi MQTT automation. OmniPro 2, Russound zoned audio, Smartthings hub, Hubitat Hub, and Home Assistant

            Comment


              #7
              Originally posted by Pete View Post
              Thank you concordseer

              Yes today the NTP server on PFSense is running on BSD and using a modded GPS with PPS on one of the 9 serial wires.

              The GPS antenna has a good view of 9 of 11 GPS satellites.

              Have around 8-9 Ubuntu servers running on Intel CPUs. I was running HS3 Lite on a TV Box with Armbian on an S912 chipset. Switched the box over to being a KODI box and went to using an Intel Beelink BT3 Pro now.
              Have the rogue time entries in your log disappeared.

              Alternatively you could wire up a good old fashioned grandfather clock to your system. Wind it once a day and you’re good to go 😂

              Comment


                #8
                I am in to antique clocks here. Also have 15 HSTouch screens that typically show a clock screen saver. Overdoing it a bit.

                Have 3 old table clocks which are about 150 years old (well not that old at 150 years) and hallway clock is a regulator pendulum clock that keeps time almost perfectly as I rarely touch it.

                Click image for larger version

Name:	wallclock.jpg
Views:	79
Size:	32.4 KB
ID:	1406476

                Have the rogue time entries in your log disappeared.

                No. Thinking I am just going to delete these logs. Do you know which file the logs resolve in?
                - Pete

                Auto mator
                Homeseer 3 Pro - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e 64 bit Intel Haswell CPU 16Gb- Mono 6.8X
                Homeseer Zee2 (Lite) - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e - CherryTrail x5-Z8350 BeeLink 4Gb BT3 Pro - Mono 6.8X
                HS4 Pro - V4.1.2.0 - Ubuntu 18.04/VB W7e 64 bit Intel Kaby Lake CPU - 32Gb - Mono 6.10.0.104
                HS4 Lite -

                X10, UPB, Zigbee, ZWave and Wifi MQTT automation. OmniPro 2, Russound zoned audio, Smartthings hub, Hubitat Hub, and Home Assistant

                Comment


                  #9
                  Originally posted by Pete View Post
                  Thank you concordseer
                  So other than the old "back to the future" log entries I am OK with current log entries.
                  Eventually, "back to the future" will become history...until you find another way to do a time warp!

                  Comment


                    #10
                    Originally posted by Pete View Post
                    Have the rogue time entries in your log disappeared.

                    No. Thinking I am just going to delete these logs. Do you know which file the logs resolve in?
                    SQLite db:

                    Click image for larger version  Name:	HomeSeerLog.PNG Views:	0 Size:	18.2 KB ID:	1406539

                    Comment


                      #11
                      Thank you @dbrunt.

                      Its been a while since I have tinkered with the HS4 build and for some odd reason thought that Rich had quit using SQLite for HS. That said I can just edit out the entries with a SQLite editor in Linux. The box isn't doing much these days.

                      Geez for whatever reason here went back to the future....logs are showing I am 5 hours ahead again...doesn't make any sense to me.

                      @ICS-HS4:~# date
                      Tue Jul 28 02:11:36 CDT 2020

                      I do not know what is changing the time other than maybe HS4 is doing this???

                      root@ICS-HS4:~# service ntp stop
                      root@ICS-HS4:~# ntpdate 192.168.244.129
                      27 Jul 21:46:21 ntpdate[2181]: step time server 192.168.244.129 offset -16312.811799 sec
                      root@ICS-HS4:~# service ntp restart
                      root@ICS-HS4:~# date
                      Mon Jul 27 21:46:57 CDT 2020

                      This is the second time I have had to do this today. Geez...

                      Ahh...see the hwclock 5 hours ahead.

                      ICS-HS4:~# hwclock --show
                      2020-07-28 02:17:18.495969-0500

                      fixed the hardware clock...

                      root@ICS-HS4:~# hwclock --systohc
                      root@ICS-HS4:~# date
                      Mon Jul 27 21:56:18 CDT 2020
                      root@ICS-HS4:~# hwclock
                      2020-07-27 21:56:21.931996-0500

                      So basically when I rebooted the computer it would read the time from the hardware clock and never get adjusted to the NTP server time...don't know why...

                      - Pete

                      Auto mator
                      Homeseer 3 Pro - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e 64 bit Intel Haswell CPU 16Gb- Mono 6.8X
                      Homeseer Zee2 (Lite) - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e - CherryTrail x5-Z8350 BeeLink 4Gb BT3 Pro - Mono 6.8X
                      HS4 Pro - V4.1.2.0 - Ubuntu 18.04/VB W7e 64 bit Intel Kaby Lake CPU - 32Gb - Mono 6.10.0.104
                      HS4 Lite -

                      X10, UPB, Zigbee, ZWave and Wifi MQTT automation. OmniPro 2, Russound zoned audio, Smartthings hub, Hubitat Hub, and Home Assistant

                      Comment


                        #12
                        Originally posted by Pete View Post
                        Thank you @dbrunt.
                        You're welcome sir!
                        Ahh...see the hwclock 5 hours ahead.

                        ICS-HS4:~# hwclock --show
                        2020-07-28 02:17:18.495969-0500

                        fixed the hardware clock...

                        root@ICS-HS4:~# hwclock --systohc
                        root@ICS-HS4:~# date
                        Mon Jul 27 21:56:18 CDT 2020
                        root@ICS-HS4:~# hwclock
                        2020-07-27 21:56:21.931996-0500

                        So basically when I rebooted the computer it would read the time from the hardware clock and never get adjusted to the NTP server time...don't know why...
                        I know how to fix that in Windows but have not had to do it in Linux yet...

                        Comment


                          #13
                          This is my fault here as I have installed NTP and NTPDate on all of my Ubuntu 18.04 servers. Looks like it is working this morning.
                          - Pete

                          Auto mator
                          Homeseer 3 Pro - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e 64 bit Intel Haswell CPU 16Gb- Mono 6.8X
                          Homeseer Zee2 (Lite) - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e - CherryTrail x5-Z8350 BeeLink 4Gb BT3 Pro - Mono 6.8X
                          HS4 Pro - V4.1.2.0 - Ubuntu 18.04/VB W7e 64 bit Intel Kaby Lake CPU - 32Gb - Mono 6.10.0.104
                          HS4 Lite -

                          X10, UPB, Zigbee, ZWave and Wifi MQTT automation. OmniPro 2, Russound zoned audio, Smartthings hub, Hubitat Hub, and Home Assistant

                          Comment


                            #14
                            Originally posted by Pete View Post
                            This is my fault here as I have installed NTP and NTPDate on all of my Ubuntu 18.04 servers. Looks like it is working this morning.
                            Sorry Pete. I was admiring your clock and didn’t see your question. Did you find the log files.

                            You can see a lot changed re network settings in Ubuntu 18.04.

                            There’s a load of questionable solutions out there. I just wish when people are posting their solutions they would link them to their sources. Still all good now with you.

                            Comment


                              #15
                              Still all good now with you?

                              No this morning noticed that I went back to the future with two different time syncs: System time was a day ahead by around 12 hours and HWClock was ahead by 5 hours.

                              Noticed that systemd-timesyncd.service active was off. Started the service and all is well at this time. Will check to make sure it does not get shut off.

                              ICS-HS4:~# timedatectl
                              Local time: Tue 2020-07-28 11:20:12 CDT
                              Universal time: Tue 2020-07-28 16:20:12 UTC
                              RTC time: Tue 2020-07-28 16:20:29
                              Time zone: America/Chicago (CDT, -0500)
                              System clock synchronized: yes
                              systemd-timesyncd.service active: yes
                              RTC in local TZ: no

                              Checked on start up and see that systemd-timesyncd.service is enabled but it appears to shut itself off when rebooting.
                              - Pete

                              Auto mator
                              Homeseer 3 Pro - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e 64 bit Intel Haswell CPU 16Gb- Mono 6.8X
                              Homeseer Zee2 (Lite) - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e - CherryTrail x5-Z8350 BeeLink 4Gb BT3 Pro - Mono 6.8X
                              HS4 Pro - V4.1.2.0 - Ubuntu 18.04/VB W7e 64 bit Intel Kaby Lake CPU - 32Gb - Mono 6.10.0.104
                              HS4 Lite -

                              X10, UPB, Zigbee, ZWave and Wifi MQTT automation. OmniPro 2, Russound zoned audio, Smartthings hub, Hubitat Hub, and Home Assistant

                              Comment

                              Working...
                              X