Announcement

Collapse
No announcement yet.

Can I Import Z-wave devices only from one installation to another?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Can I Import Z-wave devices only from one installation to another?

    Hi all,

    One of the worst things I did to date is to install W10 on a VM when I went from HS3 to HS4. The amount of updates, dirty shutdowns etc have taken a toll and the VM has become unstable which has now got me thinking, I want to start again with Homeseer but this time I'll install it on Windows Server.

    Part of this is due to the amount of installing/testing/uninstalling of plugins too but also I have no idea after the dirty restarts if there is any corruption to the HS4 files.

    What I would like to do and happy for someone to tell me it cannot be done...

    Install HS4
    Install Z-wave plugin
    Import the Z-wave devices already existing in my current HS4 installation

    I'll then re-create all the events and install the other plug-ins as required.

    Is this possible?
    Note, I dont want to start again with Z-wave because it is a pain in the rear end to put all the switches (some very hidden) into discover mode - everytime I have done a fresh start, I've had to hack walls out/remove switches, get to the modules and its just overly not a quick job.

    Thanks in advance

    Things to note:
    Z-wave controller is an Aoetec Gen 5 stick
    HS4 currently on the latest 4.11.0 however this was an over the top upgrade from HS3 once upon a time and so it sits in HS3 folder structure.
    I have numerous events - if they can be imported in too and stick with the same node numbers/devices, great but happy to re-write them


    #2
    ok I can answer my own question - everything is backed up so I thought I would install it fresh on my laptop, registered it and installed the same version z-wave plugin.
    Hit import, found 55 nodes - but then it starts going downhill in that all the battery devices it seems it cannot import

    For example:
    Warning: Failed to retrieve Z-Wave class information for node 26, device synchronization/creation will not continue for this node.

    This is a Fibaro motion sensor

    Warning: Failed to retrieve Z-Wave class information for node 29, device synchronization/creation will not continue for this node.
    This is a Aeotec motion sensor


    This would be more hassle than its worth given I would have to probably re-add these devices which means new node number, renaming, moving into their categories etc etc


    I'll just clean-up the folder and replace any non-critical files with the fresh installation files and hopefully there is no corruption to the main database files.


    Quite a bit of limitation in that you cannot renumber nodes and you cannot import battery powered nodes - nevermind

    Comment


      #3
      Have you tried to rescan the devices in question?

      On another note, you shouldn't have hidden switches as this violates electrical code and as you experienced not convenient in case there are issues.
      HS3PRO 3.0.0.500 as a Fire Daemon service, Windows 2016 Server Std Intel Core i5 PC HTPC Slim SFF 4GB, 120GB SSD drive, WLG800, RFXCom, TI103,NetCam, UltraNetcam3, BLBackup, CurrentCost 3P Rain8Net, MCsSprinker, HSTouch, Ademco Security plugin/AD2USB, JowiHue, various Oregon Scientific temp/humidity sensors, Z-Net, Zsmoke, Aeron Labs micro switches, Amazon Echo Dots, WS+, WD+ ... on and on.

      Comment


        #4
        Unfortunately when you do the import the battery devices have to be awake to be interrogated. You can individually wake the battery operated devices up and the do a rescan on the device to get it added back to HS.
        -Rupp
        sigpic

        Comment


          #5
          Thanks Rupp and Langenet - I think Rupp nailed it there - it's the waking up thats the issue. If it paused and said wake up node 29 or skip to next node, that would work well.
          I managed to get a fairly clean install albeit the nodes obviously remain as is but the main thing really was that any rubbish left over from shutdowns or uninstalled plugins etc are gone.

          Langenet - point noted although unsure if the UK have the same violations - A few are hidden away, some are behind blanking plates so I could still get to it but its in a cavity box, and then others are a pain like the gates which is housed/connected in the box housing the brain for the gates - this would involve going outside, opening the sealed box (screws) and then finally getting to the relay.
          Even those behind switches never work properly when attempting the on/off method via the switch although the push switch does work a lot better.

          Comment

          Working...
          X