No announcement yet.

Room/Floor device assignment in logs?

  • Filter
  • Time
  • Show
Clear All
new posts

    Room/Floor device assignment in logs?

    Anyone know if something changed in HS4 regarding logging of device or if I'm doing something wrong?

    I recently (since upgrade to HS4) added z-wave door locks. Everything works great. The only thing that I'm curious about is the way these devices log into the log file. Meaning...

    When I lock/unlock a lock I see this:
    2/4/2021 11:07:19 AM, Type=Z-Wave, Message=Device: <font color='#000080'>Node 38 Z-Wave Door Lock</font> Set to <font color='#008000'>Unlocked</font>

    When I open/close a door for a sensor I had added before to homeseer I see this:
    2/4/2021 11:13:37 AM, Type=Z-Wave, Message=Device: <font color='#000080'>1st Floor Mud Room Door Sensor</font> Set to <font color='#008000'>On/Open/Motion</font>

    Notice that the items in between the font color (the device name) is Node 38 Z-wave... vs. 1st Floor Mud Room...
    Meaning, the custom room and floor show for the door sensor but not the door lock. I renamed reassigned the door lock to the mud room, just like I had done with the door sensor but for some reason it keeps logging as "Node 38..."

    I use the logs in splunk and extract these values to having it log as room/floor is beneficial to me. Any thoughts on how to get it logging as the door sensor does? I assigned the root device, I did a mass bulk tag of the root plus the features, I see the features (i.e. the door lock) assigned to the room floor but none of it fixed it.

    I appreciate any thoughts.

    posted too soon... a restart of the services mostly fixed it. This is what it shows:
    2/4/2021 11:34:46 AM, Type=Z-Wave, Message=Device: <font color='#000080'>1st Floor Garage Door Lock</font> Set to <font color='#008000'>255</font>

    weirdly it shows 255 but that works for me.