Announcement

Collapse
No announcement yet.

nothing is triggered event system seems to be down

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    nothing is triggered event system seems to be down

    Last hs4 4.1.18.0 release version here.


    Anyone ever got this? This is pretty alarming.

    Homeseer process is using 100% cpu, nothing have triggered since one hour, and nothing works right now, except if I manually control an hs device. The hs event system seems to be down somehow.



    Code:
    Message
    
    
    7/19/2021 22:00:58
    HomeSeer
    Device Control
    Device: JowiHue JowiHue Office lamp (On/Off/Dim) to On (255) by/from: CAPI Control Handler
    
    7/19/2021 22:00:57
    HomeSeer
    Device Control
    Device: JowiHue JowiHue Office lamp (On/Off/Dim) to Off (0) by/from: CAPI Control Handler
    
    7/19/2021 21:48:29
    HomeSeer
    Device Control
    Device: Virtual Virtual Bathroom Group to On (100) by/from: CAPI Control Handler
    
    7/19/2021 21:03:39
    HomeSeer
    Device Control
    Device: JowiHue JowiHue Kitchen Group (On/Off/Dim) to Off (0) by/from: CAPI Control Handler
    
    7/19/2021 21:03:39
    HomeSeer
    Event
    Event Trigger "kitchen group (Nested) Kitchen ceiling"
    
    7/19/2021 21:03:39
    HomeSeer
    Event
    Event Trigger "kitchen group Kitchen (Nested)"
    
    7/19/2021 21:03:39
    HomeSeer
    Device Control
    Device: Virtual Virtual Kitchen group to Off (0)
    
    7/19/2021 21:03:39
    HomeSeer
    Event
    Event Trigger "Kitchen Sensors If NO MOTION in Kitchen set LIGHT TO OFF"
    
    7/19/2021 20:54:02
    HomeSeer
    Event
    Event Trigger "Hallway Sensors (Nested) Set hallway from 20 to off after sunset if motion etc"
    
    7/19/2021 20:54:02
    HomeSeer
    Event
    Deleting event after run: "Delayed Events (Nested) Set hallway from 20 to off after sunset if motion etc (Delayed Event)"
    
    7/19/2021 20:54:02
    HomeSeer
    Event
    Event Trigger "Delayed Events (Nested) Set hallway from 20 to off after sunset if motion etc (Delayed Event)"
    
    7/19/2021 20:52:01
    HomeSeer
    Event
    Delayed Trigger Event Removed: (Nested) Set hallway from 20 to off after sunset if motion etc (Delayed Event)
    
    7/19/2021 20:52:01
    HomeSeer
    Event
    Event Trigger "Hallway Sensors Set hallway to 21 after sunset if motion etc.(nested)"

    Nothing in syslog
    Attached Files

    #2
    Originally posted by MattL0 View Post
    Last hs4 4.1.18.0 release version here.

    I won't send this to hs support since I know I won't get much help.

    Anyone ever got this? This is pretty alarming.
    I am afraid I don't have an answer for the problem at hand but I feel your sentiment about not even bothering reporting the problem. I just did log into the support site using one of some 4 different usernames/password to use HS (site to log problems/suggestions, site to purchase stuff, myHS, plugin pwd, etc). Turns out most of my 4 pages of bugs and recommendations were closed. I didn't bother checking if HS actually did anything but the couple of closed entried were simply closed. No fix or improvement. Oh well...

    Comment


      #3
      That might be related to an MQTT plug-in even though I don't see anything mqtt in that log so I reserve judgement...


      Tip : If it turns out to be the problem, make sure to use an external Broker for your mqtt to avoid lock-ups or every time you do maintenance you make sure the client is connected before you leave the scene.



      Eman.
      TinkerLand : Life's Choices,"No One Size Fits All"

      Comment


        #4
        Since I have never seen this problem, its hard for me to troubleshoot. I really need you to disable all your plugins and then enable them one at a time to see which one is causing the issue. I will mention that there is a setting in setup labeled "Enabled Event System". If this is unchecked, events will not run. I suspect this is not your issue, but I have seen it trip up users in the past.
        website | buy now | support | youtube

        Comment


          #5
          Understood.

          I should have asked this question first . Do you think there was a change between hs4 v4.1.7.0 , and 4.1.8.0 that could explain the OP?

          I have deleted some non essential post on this topic.
          Thanks

          Comment


            #6
            I do not see any changes from .17 to .18 that would affect the events. If you restart HS does it work for a while then stop? Or does it never process any events? Go to the control panel off the tools menu and enable event debug mode by entering the following:

            hs.debugmode=2

            Now check the log and see if there are some debug messages related to the event logging, maybe create an event that should trigger at a specific time.
            website | buy now | support | youtube

            Comment


              #7
              Maybe i have found the culprit.

              I saw3 days ago that the zwave coreplugin was also a 100 cpu usage. So I deleted the zwave ui plugin since I do not use it.

              in my mind the hs issue I explained above comes from zwave … and the interaction of the two cause aomething bad on hs4 side.

              Since 3 days I am on hs4 v4.2.0.0, And I have not seen the op issue . Need to test longer but maybe that new info can help you to troubleshoot to problem. rjh

              Comment

              Working...
              X