No announcement yet.

Kwikset 916 z-Wave+ Deadbolt Not Adding Properly in HS4

  • Filter
  • Time
  • Show
Clear All
new posts

    Kwikset 916 z-Wave+ Deadbolt Not Adding Properly in HS4

    After I upgraded my HS3 to a new HomeTroller+ with HS4, my very old Kwikset Dead Bolts did not work properly.

    I bought and tried to install a Z-Wave Plus Kwikset 916 Dead Bolt
    It will not add properly, or do anything

    I tried multiple times to
    1. Remove the device, before then Add/Include
    2. I tried Factory Resetting the Lock, then Remove followed by Add/Include again
    3. Multiple Rescans of the created Device.

    All I ever see in My Log is
    (Last log entry on top)

    Enabling Lock status for Kwikset device node 159 Z
    Node 159 is a Z-Wave Plus node. Retrieving ZWPlus Info...
    Z-Wave manufacturer information for node 159, ID: 144=90H (Kwikset), Type: 3=3H, ID: 1602=642H
    If this is an import, you may need to remove and add the device as some devices cannot be added with an import.
    Failed to get a SECURITY SCHEME or verify the key from node 159. Device may not be added properly to HomeSeer.

    Adding using S0 Security, Negotiating or Verifying SECURITY SCHEME for node 159
    Synchronize nodes finished. Number of device nodes to be created/added = 1
    Z-NET Office: Controller firmware version: 4.31
    Z-NET Office: Controller Manufacturer: Express Controls, ID=0x2, Type=0x5
    Done. Node 159 Added.

    One Device with no controls or features is all that is created with the name Kwikset Entry Control.

    Any suggestions are greatly appreciated.

    Greetings clay2young,

    I had a similar problem adding my first 916 lock. The My lock was 10' from my Raspberry Pi and I just could not get it to do what I wanted.

    The fix in my case was to add another line powered device nearby. Once I did that all went smooth as silk.

    Which model 916 do you have? The one with the exterior keypad or with the deadbolt only outside.

    This is what one I have looks like. It's the model with the exterior keypad as well.

    Click image for larger version  Name:	New Bitmap Image.jpg Views:	0 Size:	64.1 KB ID:	1488781
    Click image for larger version  Name:	New Bitmap Image.jpg Views:	0 Size:	26.5 KB ID:	1488780

    Roger D


      Which Z-Wave Plug-in version do you have? If it isn't I would highly suggest you update it first.

      Roger D


        Thanks for input Roger D.
        I am using

        I'll try placing a couple HSM200's between HomeTroller and the Door Lock installed in door and try again. But I did remove the lock and reassembled it on a table top within 8 feet of my Z-Net interface. Removed, then Added and still got the same errors.


          Yep, that's the same way it worked for me. I tried everything. I have no idea why but when I put another repeating device nearby it suddenly started working. Are you able to post the Z-Wave information screen for the Lock?

          Roger D


            Good Morning Roger,

            How/where do you get that complete of a Z-Wave Node information screen under HS4 in your 1st Reply? I remember seeing such a screen with HS3, but can't find/get to it now for my Nodes in HS4.

            Kwikset told me to trying taking the lock out of the door again then reassemble it and place it within 12 inches of my Z-Net interface. Then try Remove followed by Add/Include. I probably won't try that again Saturday. It did not work when I did that about 8 feet from the Z-Net yesterday.

            I am also dealing with a lot of duplicated Devices in my HS4. My first node scan after restoring my HS3 data to HS4 duplicate all my devices, same node reference, but my names, floors, categories, replaces with names like: Cooper Wiring Light z30 Floor: Z-wave Room: Unknown. Both will control the light. My original HS3 device name is referenced in Events, the limited technical node information appears only with the added device name. Both names test and rescan, etc. under both old and new Z-wave plug-in functions.


              Good Morning Clay,

              There are multiple ways to get this info. One way is to go to [Plugins], then [Z-Wave], then [Node Information], like this...

              Click image for larger version

Name:	plugins.png
Views:	97
Size:	440.7 KB
ID:	1488891

              That will bring you to the "ZWAVEWHO" listing like this...

              Click image for larger version

Name:	zwwho.png
Views:	97
Size:	333.8 KB
ID:	1488892

              This list can be a little difficult to use at first. The Node number, in this case 82, which is on the left is in the middle of the information for the Node. So you will start at the Node number and then follow it up untill you get to Full Name:. That will be the beginning of the list for that Node.

              Another way to get this information will be to click on the Root of the device, then the [Z-Wave] tab, then [Manage]. From there just click on the dropdown symbol next to Information about Node... which will open up like this...

              Click image for larger version

Name:	dropdown.png
Views:	105
Size:	144.2 KB
ID:	1488890
              BTW, this is for the other style 916 that I have. It does not have the exterior keypad.

              Hope this helps,

              Roger D


                Thanks Roger D,

                That helped me get to the information...just missed some up/down symbols to click

                For the new 916 Lock there just is very little there. Only
                Network and Node ID
                Product Type
                Product ID
                Neighbor List

                No Command Classes, No Child Devices, No Settings, No Associations

                I appreciate your relies and assistance.
                I won't be trying anything more until Saturday and will post the results



                  A little late updating. Hectic week.
                  Results...Failure. I have tried factory resetting, Removing/Delete then trying to Add back with lock removed from door and sitting right beside my ZNet interface (it's the original ZNet and is Zwave Plus)
                  All attempts just result in 1 useless slave device added to new node number with the log entries

                  Failed to get a SECURITY SCHEME or verify the key from node 159. Device may not be added properly to HomeSeer.
                  Adding using S0 Security, Negotiating or Verifying SECURITY SCHEME for node 159.

                  Kwikset says the problem must be with my Zwave interface.


                    You didn't mention in your first post, but was the Kwikset lock brand new when you bought it?


                      New from Amazon


                        I only ask because I had a similar issue with a Kwikset 910 that was installed in the house we purchased last year. They support a Z-wave feature called "Antitheft" that prevents the lock from being added to another controller once paired. Factory reset, etc. won't fix it. You have to disable the feature from the original controller before exclusion and inclusion on a new controller. Doesn't sound like your issue though, even though the symptoms are the same.

                        In my experience I had to lay the lock on the Z-net before it would pair properly. As far as I understand locks use a low-power Z-wave mode during inclusion as part of their S0 security as that's when S0 devices are vulnerable to exposing their crypto keys.


                          Originally posted by mterry63 View Post
                          In my experience I had to lay the lock on the Z-net before it would pair properly.
                          Just in case you're still wrestling with it, mterry isn't joking about having to have the lock touching.


                            When I tried again, laying the Kwikset on top of my Z-Net. All Zwave controller functions failed and the Z-Net had locked up. Not controlling anything though green light showed it online. I unplugged the Z-Net, turned off the Hometroller.Then plugged Z-Net back in and rebooted HS4. Everything was back to normal. I then put the Z-Net on top of the Kwikset...same results.

                            I might order another Kwikset from Amazon. This time very carefully unpacking it, assemble it only beside my Z-Net. It it fails to properly add, then return it immediately to Amazon properly repacked so I can get a full refund.

                            At least my first Kwikset does function okay as a stand-alone non-zwave digital lock that its worth more than AMZ estimated they would refund me if I returned it in the condition it would have been in.

                            Anybody want to report which specific Kwikset model number lock they have successfully installed in HS4 with a V1 Z-Net controller?