Announcement

Collapse
No announcement yet.

Node-red homeseer webhook ssl fail.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Node-red homeseer webhook ssl fail.

    Helo all,

    I did install nodejs on my other server, but i can access it from https.
    Is there a way to solve this in homeseer ?
    Getting this error message and can't use it with node-red anymore.


    9-14-2021 18:36:32
    HomeSeer
    3
    Posting to webhook failed: The underlying connection was closed: Could not establish trust relationship for the SSL/TLS secure channel. URL: https://192.168.1.25:1880/homeseer/webhook


    regards





    Preferred -> Jon's Plugins, Pushover, Phlocation, Easy-trigger,
    Rfxcom, Blade Plugins, Pushbullet, homekit, Malosa Scripts




    HS3Pro 4.1.14.0 on windows 10 enterprise X64 on hp quadcore laptop 8 GB.

    #2
    Is your issue similar to this here? : https://jphuddlestone.co.uk/phlocati...ReadFirst.html

    Or this : https://docs.homeseer.com/display/HS4/Labs

    Else, SSL is not yet implemented for HS Nodes and as is with passwords because if you enable allow no passwords for local computers then their is no reason to use https on your LAN


    Eman.
    TinkerLand : Life's Choices,"No One Size Fits All"

    Comment


      #3
      Well yes,

      I have a little issue and don't know how to do it.
      I have node-red on my Homeassistant server, the thing is my Homeassistant server is on https.
      If i disable use ssl for Node-Red i can access it trough http, but than it ask a password for my Homeassistant server...

      how can i solve this? i don't want to run double node-red.


      regards



      Originally posted by Eman View Post
      Is your issue similar to this here? : https://jphuddlestone.co.uk/phlocati...ReadFirst.html

      Or this : https://docs.homeseer.com/display/HS4/Labs

      Else, SSL is not yet implemented for HS Nodes and as is with passwords because if you enable allow no passwords for local computers then their is no reason to use https on your LAN


      Eman.
      Preferred -> Jon's Plugins, Pushover, Phlocation, Easy-trigger,
      Rfxcom, Blade Plugins, Pushbullet, homekit, Malosa Scripts




      HS3Pro 4.1.14.0 on windows 10 enterprise X64 on hp quadcore laptop 8 GB.

      Comment


        #4
        Best choice is to get a Raspberry Pi connect that to HomeSeer then its (HA) Nodes to Home Assistant if they allow SSL
        • I don't like the idea of Node-RED on Windows (can be installed on the same server as Homeseer)

        I have 2 instances of Node-RED, no.1 on ioBroker and no. 2 is on a second Raspberry Pi. and in HomeSeer I have 2 Webhooks settings but http

        So in your setup the connection to HomeSeer will be the Raspberry Pi to HomeSeer then from Node-RED you connect to HA : https://community.home-assistant.io/...node-red/55023

        You then have two way communication. (the HS Nodes will trigger the HA Nodes and also HomeSeer Nodes will be triggered). No fancy gimmicks but automation.



        Eman.
        TinkerLand : Life's Choices,"No One Size Fits All"

        Comment


          #5
          Eman

          thanks, i did found 1 line in the documentation, i did add that and now i can access node-red without password.
          Because the home assistant version keeps asking for that password of home assistant
          it works great now

          Preferred -> Jon's Plugins, Pushover, Phlocation, Easy-trigger,
          Rfxcom, Blade Plugins, Pushbullet, homekit, Malosa Scripts




          HS3Pro 4.1.14.0 on windows 10 enterprise X64 on hp quadcore laptop 8 GB.

          Comment

          Working...
          X