Announcement

Collapse
No announcement yet.

Log empty - how can I see my log on 4.2.5.0

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Log empty - how can I see my log on 4.2.5.0

    I need to see my log to debug a script not working. I tried Tools - Log from the main menu. I made sure the filters are set to any. I get no entries at all. Then I tried the legacy view. MyIP/_eventlog.html. That only shows the top menu now, nothing else.
    Is there a but so you cannot see the logs any more ?
    Attached Files

    #2
    What are your log settings?

    Click image for larger version

Name:	Capture.PNG
Views:	330
Size:	26.0 KB
ID:	1501491
    Jon

    Comment


      #3
      You could also look at output to file directly.

      https://forums.homeseer.com/forum/ho...12#post1067412

      Comment


        #4
        Originally posted by jon00 View Post
        What are your log settings?

        Click image for larger version

Name:	Capture.PNG
Views:	330
Size:	26.0 KB
ID:	1501491
        The log settings are enabled

        Comment


          #5
          I have an idea what may cause me not to see any logs. In the HS4 startup screen I have a few errors

          07/10/2021 19:05:19 HomeSeer~!~Error~!~SQL Exception adding record(s) to the LOG database(0): database disk image is malformeddatabase disk image is malformed, Code=11 SQL=
          07/10/2021 19:05:22 HomeSeer~!~Error~!~SQL Exception adding record(s) to the LOG database(0): database disk image is malformeddatabase disk image is malformed, Code=11 SQL=

          I was not sure what they are, but maybe that is a hint of whats wrong ?

          I use Ultralog, but I just checked going to the PI the log there is empty too

          Comment


            #6
            Yes, your log file is corrupt.

            Delete the HomeSeerLog.hsd in your <Homeseer root>\Logs folder. You may need to shutdown HS first.

            The log file should then rebuild itself.
            Jon

            Comment


              #7
              Originally posted by jon00 View Post
              Yes, your log file is corrupt.

              Delete the HomeSeerLog.hsd in your <Homeseer root>\Logs folder. You may need to shutdown HS first.

              The log file should then rebuild itself.
              My log is back ! Problem solved.

              Comment


                #8
                I am having the same problem as mikee, no log file so I assume it is corrupt. So I'm not a Linux user (recall simple commands like ls and cd ) how do I specifically delete the file so it will rebuild? I go to the LInux tools and execture "ls" and I see what I believe is the Log subdirectory where the HomeSeerLog.hsd should be. I've even connected a keyboard and monitor to my HomeSeer HS4 Pi Hub. I can't seem to find that subdirectory that way either. Any help would be appreciated. Thanks.

                Comment


                  #9
                  Finally found the log file! I deleted the file and all is well. I now have log files again.

                  Comment


                    #10
                    Originally posted by jon00 View Post
                    Yes, your log file is corrupt.

                    Delete the HomeSeerLog.hsd in your <Homeseer root>\Logs folder. You may need to shutdown HS first.

                    The log file should then rebuild itself.
                    This worked for me thanks brother

                    Comment

                    Working...
                    X