Announcement

Collapse
No announcement yet.

Irretrievably Corrupted Database

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Irretrievably Corrupted Database

    Microsoft, in their infinite wisdom downloaded updates and rebooted the HS4 machine without asking. The HS4 device database is now corrupt. Devices are not visible to HS4. I rescan the devices (has to be done individually, and in the case of battery power device, frequently has to be dismounted and brought to the vicinity of my pc). After a devices rescan, it can now be seen and controlled by HS4. BUT, it leaves a phantom node without a name, just a node number. If I delete the phantom node, it disconnects the actual device, and I'm back to step one.

    And yes, backups were enabled, but not happening for some unknown reason. If I do a manual backup it works fine.

    It appears that my only option is to wipe the system and rebuild from scratch.

    #2
    I updated from HS3 to HS4 about 6 weeks ago, moving to a new computer at the same time. I never had any problems with data corruption using HS3, even though Microsoft likes to restart their computer (What? You thought the pc you paid for was yours?) any time they feel like it. I know that the database format changed in HS4. Perhaps it doesn't not have as robust a write mechanism.

    The solution for me seems to be:
    - delete the HS4 installation
    - Install HS4 as if I was migrating to the new machine again
    - Copy the data and config directories from my HS3 backups
    - install all my plugins
    - verify all configuration
    - verify backup of HS4 - not that I will trust that again.

    Comment


      #3
      FWIW, this is a known problem where the devices/events get lost on some reboots. The best option is to backup often.
      HS4Pro Running on a Raspberry Pi4
      67 Z-Wave Nodes, 111 Events, 422 Devices
      Z-Wave, UPB, WiFi
      Plugins: EasyTrigger, weatherXML, OMNI, Z-Wave, Tuya, Device History
      HSTouch Clients: 3 Android, 1 Joggler

      Comment


        #4
        I block the download of updates which keeps this from happening except on MY schedule. That being said, I also use active replication of the HS4 directory so I always have backups just in case.

        The root of the issue is that the OS pulls the rug out from under the applications that are running, not given them time to complete a save to disk before the OS shuts down.

        Comment


          #5
          https://superuser.com/questions/1110...alling-updates

          That and check the setting for AutoEndTasks

          https://www.tenforums.com/tutorials/...dows-10-a.html

          Code:
          Windows Registry Editor Version 5.00
          
          [HKEY_CURRENT_USER\Control Panel\Desktop]
          "AutoEndTasks"="0"
          ‚Äč

          Comment


            #6
            I think you can stop auto update by manually disabling the Local Windows Service "Windows Update". Seems to work on my Windows 10 based HomeSeer box /Marcus

            Comment


              #7
              I've never tried messing with processes to disable updates. I simply set the Ethernet connection to "metered" and Windows won't download updates over a metered connection without permission. It's the download that triggers the update and reboot. Once a week or so, I check for updates and allow them to be downloaded over the metered connection. Before I restart, I take down HS4, Deconz, and Node-RED and then click on Restart Now. I use "Startup Delayer" to bring everything back up after the reboot. I've been doing it this way for over 5 years and have never had any data corruption.

              Comment

              Working...
              X