Announcement

Collapse
No announcement yet.

HS4 Backup Location

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #16
    Again, that file name is being generated by HS during the backup operation. There are no files in that directory. I can copy and create files without issue in that directory.

    Comment


      #17
      Originally posted by pmendiuk View Post
      Again, that file name is being generated by HS during the backup operation. There are no files in that directory. I can copy and create files without issue in that directory.
      Does the username HS4 is logged in under have permissions on the destination. Since the file is not being created that would be suspect.

      HS4 Pro, Windows 10 pro

      Comment


        #18
        I'm sorry as I've stated before that file doesn't exist in that location. That directory is empty. I changed the security permissions for that directory to Full Access for Everyone and it still has the same error.

        Comment


          #19
          The HS service LogOn is the default, Local System account with allow service to interact with desktop enabled.

          Comment


            #20
            I also tried changing the HS service LogOn to another user with full access to the HS4 directories and the network share with the same error:

            Failed with error: Could not find a part of the path 'y:\Homeseer_Backup\12_16_2022-15_0_38.zip'.

            Comment


              #21
              I’m out of ideas. It looks like you are running HS as a service. That may make a difference.
              HS4 Pro, Windows 10 pro

              Comment


                #22
                Rather than start a new thread, I figured I would ask here - how are you folks setting the backup location? I am not able to click and type in the desired location.
                Thanks ahead of time for any info
                Dan-O
                HomeSeer contributor since summer 1999, yes 1999!

                Comment


                  #23
                  You can\try to set the path for backup and restore with the edit key in the bottom right corner.

                  Comment


                    #24
                    Originally posted by Dan-O View Post
                    Rather than start a new thread, I figured I would ask here - how are you folks setting the backup location? I am not able to click and type in the desired location.
                    Thanks ahead of time for any info
                    Yes, something strange. But if you initiate a backup 'backup now' and there after try a restore, it seems that HS finds the backup. For me, HS stored the backup in folder 'C:\Program Files (x86)\HomeSeer HS4\Data\HS3 CV config.json', where 'HS3 CV config.json' corresponds to the name I gave the config file.

                    P.S. I run HS4 as a service.

                    Comment


                      #25
                      Originally posted by Dan-O View Post
                      Rather than start a new thread, I figured I would ask here - how are you folks setting the backup location? I am not able to click and type in the desired location.
                      Thanks ahead of time for any info
                      Hi Randy,
                      Thanks for your patience. Yes I'm running HS as a service. I tried a number of combinations of HS as a service, as a regular app with a variety of users and permission types with the same result.

                      I then wrote a few lines of script and it finds and copies the new backup file to the network drive just fine. I would like to think there is an explanation for why I can't use a network location and I really can't come up with a satisfying one.

                      Comment


                        #26
                        Originally posted by Dan-O View Post
                        Rather than start a new thread, I figured I would ask here - how are you folks setting the backup location? I am not able to click and type in the desired location.
                        Thanks ahead of time for any info
                        It is under Tools>backup/restore -or- HomeSeer Settings>Edit Config>Backup/Restore. There you can edit backup settings. A direct path is <HomeSeer IP>backup.html

                        When you’re there you have to click on Edit before changing.
                        HS4 Pro, Windows 10 pro

                        Comment


                          #27
                          Originally posted by pmendiuk View Post
                          You can\try to set the path for backup and restore with the edit key in the bottom right corner.
                          That was it. I forgot to scroll down to see it.

                          Thanks everyone for the replies.
                          Dan-O
                          HomeSeer contributor since summer 1999, yes 1999!

                          Comment


                            #28
                            Like Dan-O, I'll keep my backup location question on this thread for compactness. I'm using HS4 Pro on WES7, which has been running reliably. I cannot get backups to work because although the webUI does accept and save the path of a mounted external drive (which has plenty of free GB), when I attempt a backup it fails for insufficient free space (as reported in the log). I'm pretty sure what's happening behind the scenes is the backup is attempting to write in the program install or %temp% directory then move file sets to the "backup directory". This fails on an embedded system because the OS volume (where Program Files\HS4 resides) is only 4GB, and after the OS, HS4 binaries and dotNET 4.x , there's not much space left (though plenty to operate with, as the device is fully dedicated to HS). Is there any way I can copy my rules and settings from within the file system if I want to migrate the deployment to another volume or perhaps a more spacious embedded device?

                            Comment

                            Working...
                            X