Announcement

Collapse
No announcement yet.

Pro-100 software update needs .NET

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Pro-100 software update needs .NET

    i recently attempted to upgrade one of my two pro-100's to the latest HomeSeer revision via the updater. After downloading and starting install it indicated that it would require me to install .NET. I started to do this via the link provided and it failed install, I'm guessing due to the flash protection.

    Is there a documented procedure for upgrading the PRO-100 operating system to support the newest release of the HSPro software? I'd like to keep them current but don't want to go experimenting with .NET blindly.

    thanks..

    #2
    I would recommend putting in a help request on this.
    -Rupp
    sigpic

    Comment


      #3
      Originally posted by heystew View Post
      i recently attempted to upgrade one of my two pro-100's to the latest HomeSeer revision via the updater. After downloading and starting install it indicated that it would require me to install .NET. I started to do this via the link provided and it failed install, I'm guessing due to the flash protection.

      Is there a documented procedure for upgrading the PRO-100 operating system to support the newest release of the HSPro software? I'd like to keep them current but don't want to go experimenting with .NET blindly.

      thanks..
      David - We're in Vegas for the week attending CES but we will have email/helpdesk support access. Create a helpdesk ticket to get the fastest response.
      Learn About HomeSeer

      Comment


        #4
        Was there any resolution on a .NET update? I have tried to install .NET 3.5 and receive failue (0x800c0005) "Windows Installer Patch Registration Fix for .NET Framework 3.5 (x86) :: Failed". The same failure if I install from internet or install from the 231M full .NET installer. I also tried to install it from the Visual Studio 2008 CD and also failed.

        Comment


          #5
          Yes, we have updated the OS. You need to order a flash restore driver. The latest drive has .NET 3.0. For some reason, XP Embedded would not allow .NET 3 to be installed manually, I had to add it to the OS when the OS is built.

          Originally posted by Michael McSharry View Post
          Was there any resolution on a .NET update? I have tried to install .NET 3.5 and receive failue (0x800c0005) "Windows Installer Patch Registration Fix for .NET Framework 3.5 (x86) :: Failed". The same failure if I install from internet or install from the 231M full .NET installer. I also tried to install it from the Visual Studio 2008 CD and also failed.
          website | buy now | support | youtube

          Comment


            #6
            I sent in an order request via email as I did not see it as a regular item on the storefront.

            Does this mean that the existing image will be overwritten and anything now stored will need to be reinstalled?

            Comment


              #7
              Michael,
              Here's the page that has the flash drives :
              http://store.homeseer.com/store/Cont...ries-C102.aspx
              -Rupp
              sigpic

              Comment


                #8
                Thanks Rupp, I just noticed that Rich indicated that the new flash supported .NET 3.0, but not the .NET 3.5 that is produced with Visual Studio 2008. So it looks as if the PRO100 will not be able to run software targeted to this framework.

                Comment


                  #9
                  Can we not update the .net 3.0 to 3.5 once we restore using the new flash drive? Has anyone tried this and sudceeded?

                  Comment


                    #10
                    I had a mcsSprinklers user that started with .NET 3.0 and installed .NET 3.5 SP1 on top of it using standard Microsoft update procedure. You cannot start with .NET 2.0 to get the .NET 3.x.

                    Comment


                      #11
                      Ok..thx Mike! Thats what we planned to do for George. Ive got a brand new DOM that im going to use to test on my own Pro-100. Hopefully the backup utilities from the HP Mediasmart homeserver will make quick work of bringing all the programming and plug-ins back after the completely blank overhaul.

                      Comment


                        #12
                        I received a new System Restore Flash Drive for the Pro-100 Series 2 a couple of minutes ago. It is marked as Version 1.4. Is this the version which includes the .NET upgrade or did I receive an older version. If I did receive the older version, what do I need to do to have it upgraded to the current version? Thanks. Peter Jackson

                        Comment


                          #13
                          Thats the latest version... you should be at .net 3.0 from the restore. Make sure you have all you HS stuff backed up before you reformat.
                          Once your done with the restore you can load the .net 3.5 sp1 install according to a 3rd party... Im going to be trying this myself with a completely separate DOM / hard drive in a my own pro100 to test.

                          Comment


                            #14
                            Thanks, Christopher. I'll give it a try tomorrow. Peter

                            Comment


                              #15
                              Bad news.... Seems that after installing a completely brand new version of HomeSeer on my PRO-100 from the new HS 1.4 USB stick I STILL cannot upgrade to .net 3.5

                              [07/25/10,14:29:03] Microsoft .NET Framework 2.0SP1 x86: [2] Error code 1603 for this component means "Fatal error during installation.
                              "
                              [07/25/10,14:29:04] Microsoft .NET Framework 2.0SP1 x86: [2] Setup Failed on component Microsoft .NET Framework 2.0SP1 x86
                              [07/25/10,14:29:10] WapUI: [2] DepCheck indicates Microsoft .NET Framework 2.0SP1 x86 is not installed.

                              This seems to be a common problem among embedded systems... is there no fix?

                              Looking around i found more of this among other XPe devices

                              Isnt the new 1.4 update stick supposed to bring us to .net 3.0?
                              I just ran a .NET version detector and it show the PRO-100 only at 2.0

                              2.0.50727.42
                              ->C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727
                              < Installed .NET Frameworks >
                              .NET FW 2.0

                              Something doesnt add up here.......

                              Comment

                              Working...
                              X