Announcement

Collapse
No announcement yet.

HS3 to Vera bridge plugin?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Just an update. I did start this this weekend, but I'm a bit behind. I was sick Friday night so didn't get to work on it. I have the plugin started and at the point where I need to hook up one of my Vera's and start making sure the communication works and I get updates correctly.

    I will hopefully be starting that testing tonight.
    Thanks,
    Frank

    Comment


    • #17
      Originally posted by sirmeili View Post
      Just an update. I did start this this weekend, but I'm a bit behind. I was sick Friday night so didn't get to work on it. I have the plugin started and at the point where I need to hook up one of my Vera's and start making sure the communication works and I get updates correctly.

      I will hopefully be starting that testing tonight.

      Comment


      • #18
        Originally posted by sirmeili View Post
        Just an update. I did start this this weekend, but I'm a bit behind. I was sick Friday night so didn't get to work on it. I have the plugin started and at the point where I need to hook up one of my Vera's and start making sure the communication works and I get updates correctly.

        I will hopefully be starting that testing tonight.
        I hope you feel better soon. Being sick is not fun.

        For your info, I did a little setup with MQTT as there's a somewhat stable MQTT app for Vera now and linked HS and Vera with MQTT and it works.. but it is slower than using Vera Scenes making HTTP calls to HS.

        Vera -> Scene (on/off 2 scenes) -> HS HTTP -> HS Event -> do_something

        Vera -> MQTT -> MQTT Broker -> HS MQTT -> HS Event -> do_something

        The scene with a direct HTTP call to a virtual device on/off with an event is much faster than going through MQTT.

        Granted this is for my specific testing of a VERY fast motion sensor where I'm timing in human perception.

        Comment


        • #19
          I got the connection up finally after rewriting a small bit of the above linked Vera .net library.

          I should hopefully soon have a quick demo of at least a switch working (in this case a virtual switch).

          After that I'll add a "security" sensor and release a quick beta for you to test if you want.

          Sent from my Pixel 2 XL using Tapatalk
          Thanks,
          Frank

          Comment


          • #20
            So this is going to take a bit longer than I thought. I'll have to add a z-wave switch or something to it. The issue is that the plugins don't (Virtual Switch and MultiSwitch) return a category Id of 0 so they don't show as switches (I kind of understand this for MultiSwitch).

            The virtual sensor one does in fact report as a security device, so I will start there to get a basic device working with 1 way communication (from vera -> HS).

            I'm wondering, and I know the answer to this if I had this plugin when I was migrating, would there be a desire to pull in the devices for MultiSwitch, VirtualSwitch and the like? Or should I just ignore them?

            For now I will ignore them, but if this plugin takes off it will be in important topic and the .net library I've found doesn't really deal with plugin devices unless they return the correct type (And even then, the virtual sensor I'm using returns light, humidity, and temp, but those won't be reported because they aren't part of the security sensor definition).

            I'll see about getting an early proof of concept out this week. Sorry it's taking longer than I thought, but I had forgotten a lot about the vera messages it sends out.

            The good thing, is that it is damn near, if not exactly real-time.

            At first I was getting a message every 5 seconds so I thought it was polling, but it turns out the Virtual Sensor plugin I'm using adjusts it's values every 5 seconds and that is what I was seeing.
            Thanks,
            Frank

            Comment


            • #21
              Originally posted by sirmeili View Post
              I got the connection up finally after rewriting a small bit of the above linked Vera .net library.

              I should hopefully soon have a quick demo of at least a switch working (in this case a virtual switch).

              After that I'll add a "security" sensor and release a quick beta for you to test if you want.

              Sent from my Pixel 2 XL using Tapatalk
              Sounds great to me. If you need any of the information about my sensors let me know. I doubt there's anything special in how Vera treats them though. I also have a dimmer plug still in vera if you need/want that info

              Comment


              • #22
                Originally posted by jeubanks View Post
                Sounds great to me. If you need any of the information about my sensors let me know. I doubt there's anything special in how Vera treats them though. I also have a dimmer plug still in vera if you need/want that info
                Yeah, so there are a set number of device "categories" that devices fall into. So, that will be pretty easy. All Dimmers should look the same. I'm curious to see how Hues look or RGB bulbs (I don't have any to test). It could be the API has been updated, but I can sniff out those differences as they come up (in the final version of the plugin, I'll try and add a way to see when an unknown device type shows up and to log them for inclusion by me later).

                For the basic devices though, once I get 1 working, they should all fall into place.
                Thanks,
                Frank

                Comment


                • #23
                  Originally posted by sirmeili View Post
                  Yeah, so there are a set number of device "categories" that devices fall into. So, that will be pretty easy. All Dimmers should look the same. I'm curious to see how Hues look or RGB bulbs (I don't have any to test). It could be the API has been updated, but I can sniff out those differences as they come up (in the final version of the plugin, I'll try and add a way to see when an unknown device type shows up and to log them for inclusion by me later).

                  For the basic devices though, once I get 1 working, they should all fall into place.
                  Unfortunately I don't have any RGB bulbs so I'm no help there. I do have a Hue bridge and I used to run the Hue plugin on Vera (until it crashed my system). There's a whole new AltHue plugin being developed by the AltUI developer which works really well though. I was recently using that before I turned my attention to HS.

                  Comment


                  • #24
                    Originally posted by sirmeili View Post
                    So this is going to take a bit longer than I thought. I'll have to add a z-wave switch or something to it. The issue is that the plugins don't (Virtual Switch and MultiSwitch) return a category Id of 0 so they don't show as switches (I kind of understand this for MultiSwitch).

                    The virtual sensor one does in fact report as a security device, so I will start there to get a basic device working with 1 way communication (from vera -> HS).

                    I'm wondering, and I know the answer to this if I had this plugin when I was migrating, would there be a desire to pull in the devices for MultiSwitch, VirtualSwitch and the like? Or should I just ignore them?

                    For now I will ignore them, but if this plugin takes off it will be in important topic and the .net library I've found doesn't really deal with plugin devices unless they return the correct type (And even then, the virtual sensor I'm using returns light, humidity, and temp, but those won't be reported because they aren't part of the security sensor definition).

                    I'll see about getting an early proof of concept out this week. Sorry it's taking longer than I thought, but I had forgotten a lot about the vera messages it sends out.

                    The good thing, is that it is damn near, if not exactly real-time.

                    At first I was getting a message every 5 seconds so I thought it was polling, but it turns out the Virtual Sensor plugin I'm using adjusts it's values every 5 seconds and that is what I was seeing.
                    I found this same thing with the pyvera component that home assistant uses. I did an update for a standard VSwitch but the virtual sensor and multiswitch I never found useful. The multiswitch plugin was always buggy and so I stopped using it and the working virtual sensor is a newer plugin that although is interesting for dev work not used much otherwise.

                    Sent from my SAMSUNG-SM-G890A using Tapatalk

                    Comment


                    • #25
                      Originally posted by jeubanks View Post
                      I found this same thing with the pyvera component that home assistant uses. I did an update for a standard VSwitch but the virtual sensor and multiswitch I never found useful. The multiswitch plugin was always buggy and so I stopped using it and the working virtual sensor is a newer plugin that although is interesting for dev work not used much otherwise.

                      Sent from my SAMSUNG-SM-G890A using Tapatalk
                      Yeah I was going to use them for testing. Odd about Multiswitch. I used to use it a lot when I was on Vera.

                      I think i actually figured out how it all works while I was sleeping last night. Lol. Sounds funny but I sometimes dream about this stuff...

                      I'm hoping tonight I'll have something.

                      Sent from my Pixel 2 XL using Tapatalk
                      Thanks,
                      Frank

                      Comment


                      • #26
                        Originally posted by sirmeili View Post
                        Yeah I was going to use them for testing. Odd about Multiswitch. I used to use it a lot when I was on Vera.

                        I think i actually figured out how it all works while I was sleeping last night. Lol. Sounds funny but I sometimes dream about this stuff...

                        I'm hoping tonight I'll have something.

                        Sent from my Pixel 2 XL using Tapatalk
                        Not odd at all.

                        Comment


                        • #27
                          Let me known when you're ready for me to do some testing.

                          Comment


                          • #28
                            Originally posted by jeubanks View Post
                            Let me known when you're ready for me to do some testing.
                            It's been hell week at work. A guy quit with short notice and somehow I got his work load and it's not in my area of expertise (he was a DevOp I'm. Developer). So I've been putting in crazy hours trying to fill both roles. I'm hoping it will calm down next week and I get into a better rythm.

                            Idid get to look at it for a short bit tonight and while my "dream idea" sort of worked I'm gonna have to rewrite a huge portion of that .net library to get it to work the way I want.

                            Sent from my Pixel 2 XL using Tapatalk
                            Thanks,
                            Frank

                            Comment


                            • #29
                              Originally posted by sirmeili View Post
                              It's been hell week at work. A guy quit with short notice and somehow I got his work load and it's not in my area of expertise (he was a DevOp I'm. Developer). So I've been putting in crazy hours trying to fill both roles. I'm hoping it will calm down next week and I get into a better rythm.

                              Idid get to look at it for a short bit tonight and while my "dream idea" sort of worked I'm gonna have to rewrite a huge portion of that .net library to get it to work the way I want.

                              Sent from my Pixel 2 XL using Tapatalk
                              Hey at least I'm not the only one having a fun week at work!

                              No worries, just popping the thread every now and again to see what's up. It's actually kinda funny. Half the people on the forum are in the tech industry in some way shape or form. Quite different than on the other forums.

                              Comment

                              Working...
                              X