Announcement

Collapse
No announcement yet.

Stopped Working

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Stopped Working

    I got two Harmony hubs set up and started testing one. I went to the device manager and clicked on an activity. It worked and the light on the remote came on and did everything it was supposed to. Power Off doesn't really seem to work. I turned things off with the remote. If I recall correctly I was once more to able to turn an activity on (from everything being off) but then everything broke down. Nothing worked anymore. I disabled the plugin and reenabled it but that didn't help. Below is the log. It is as if it doesn't see the activities anymore. Any input is appreciated.

    Click image for larger version

Name:	StoppedWorking.PNG
Views:	145
Size:	25.2 KB
ID:	1417057

    #2
    I tried this again. After power cycling the Harmony hub it kind of started working but only maybe 1/3 of the time. 2/3 of the time it's not doing anything. I have an event that does a bunch of other things like controlling lights. The lights work 100% of the time. Just changing the scene (PowerOff, Watch Netflix, etc) doesn't work most of the time. When I control scenes or turn off the system (TV, amp, AppleTV, etc) it works just fine. Hence, it seems this is an issue with the plugin. Has anybody else experienced anything like that?

    Comment


      #3
      Please install version 4.0.12 released as a beta version and test again.
      HS4 filters out most of the log lines because they are xml data. So please enable log to file and set the file log level to Trace, then post what you get in Data/HarmonyHub.txt

      Comment


        #4
        spud I just saw this response now. I downloaded 4.0.12 but it still doesn't work. When I use my remote it works just fine, just not when using HomeSeer with this plugin. I have an activity set up and I see that it is being triggered:

        Device: Plugin HarmonyHub Current Activity to Watch Netflix (37677819)

        However, nothing happens. I also don't see any other message in the log despite the fact that I set the log level to trace (without the option to write to a file).

        Edit: I also double-checked that the IP address is still correct.

        Comment


          #5
          spud Ok, I think I see what is happening. The plugin works if the remote is active by picking it up, i.e. the display on the remote is on. However, when the remote is not active then nothing works. Actually, it messes up the system so that when I use the remote the activities from the remote don't work until I click the off button on the remote and then activate the activity again on the remote. I need the activities from the plugin to work without having to pick up the remote because I am using voice control. If I need to pick up the remote there is no point of using voice control anymore.

          Comment


            #6
            What is the model of your Harmony Hub and your remote?
            Can you record and post a log file as explained in my post above?

            Comment


              #7
              The hub has PN 815-000118. I can't read the PN on the remote but it should be a Harmony Elite. I tried to generate the log file but it's not being generated. I also searched the entire HS4 folder but nothing. See these images:

              Plugin:
              Click image for larger version

Name:	HHPlugin.png
Views:	63
Size:	8.5 KB
ID:	1434012

              Plugin Setting:

              Click image for larger version  Name:	Setting.png Views:	0 Size:	20.2 KB ID:	1434009
              Data Folder:

              Click image for larger version  Name:	NoLog.png Views:	0 Size:	7.1 KB ID:	1434010

              Comment


                #8
                The log file is in Logs/HarmonyHub.txt

                Comment


                  #9
                  Ok, found it. Interestingly, the file only seems to have logs for the start up of the plugin. Everything else still goes into the log despite the fact that I have "Log To File" enabled.
                  Edit: Actually, it seems Info and debug goes into the file and Trace goes into the HS log.
                  Attached Files

                  Comment


                    #10
                    you need to set the "File Log level" to Trace from the settings page

                    Comment


                      #11
                      I had it set to Trace. In any case, here is what I just did in case it didn't save it correctly:
                      1) Change log level to Error and disable write log to file.
                      2) Save
                      3) Change log level to Trace and enable write log to file.
                      4) Save
                      5) Shut down HS
                      6) Restart HS
                      7) Activate the Watch Netflix activity

                      It still doesn't write the trace to the log file but only to the HS log. See all attachments. I just took those screenshots after step 7 above. Note that in the first screenshot of the HS log I filtered by "Trace" which is why I only saw the trace messages. In this screenshot I didn't filter for anything.
                      Click image for larger version

Name:	HormonySettings.png
Views:	59
Size:	65.6 KB
ID:	1435733
                      Click image for larger version

Name:	HarmonyLog2.png
Views:	53
Size:	220.9 KB
ID:	1435734

                      Comment


                        #12
                        Originally posted by mulu View Post
                        I had it set to Trace. In any case, here is what I just did in case it didn't save it correctly:
                        1) Change log level to Error and disable write log to file.
                        2) Save
                        3) Change log level to Trace and enable write log to file.
                        4) Save
                        5) Shut down HS
                        6) Restart HS
                        7) Activate the Watch Netflix activity

                        It still doesn't write the trace to the log file but only to the HS log. See all attachments. I just took those screenshots after step 7 above. Note that in the first screenshot of the HS log I filtered by "Trace" which is why I only saw the trace messages. In this screenshot I didn't filter for anything.
                        Click image for larger version

Name:	HormonySettings.png
Views:	59
Size:	65.6 KB
ID:	1435733
                        Click image for larger version

Name:	HarmonyLog2.png
Views:	53
Size:	220.9 KB
ID:	1435734
                        there is 2 log level settings:
                        one for the HS logs => "Log Level"
                        one for the log file => "File Log level"

                        on your screenshot I can see that "File Log level" is set to Debug.
                        Set it to Trace.

                        Comment


                          #13
                          Duh, I totally missed that "File Log Level". Here is the log file after the Netflix Activity.
                          Attached Files

                          Comment


                            #14
                            Here is the error returned from the start activity request
                            errorstring="RF link lost"
                            deviceId=60255344

                            how many devices are involved in this activity and which one is 60255344? Is it communicating with the harmony hub using RF?
                            does it work if you send a direct command to this device instead of starting an activity?


                            Comment


                              #15
                              For the Netflix activity there are 3 devices involved, i.e. a TV, an AVR and an AppleTV. How do I find out what device 60255344 is? I don't see any such number in the HS device information for the 3 involved devices. Regarding the communication it depends on the device:

                              1) The TV is controlled via IR through the remote
                              2) The AppleTV is controlled via IR through one of the two IR ports on the hub
                              3) The AVR is controlled with a direct/wired connection from the other IR port on the hub and an IR input on the AVR

                              As for controlling the components individually:
                              • I can turn the AVR on/off by going to the AVR device and click on the on/off action.
                              • I can control the AppleTV through the actions of the AppleTV device
                              • I cannot control the TV when through actions of the TV device when the remote is idle. Only when I pick up the remote and the display comes on then I can control the TV through the TV device in HS.
                              • When I use the Netflix activity nothing works. Well, maybe(!) the AppleTV works but I can't see that because neither the TV nor the AVR turns on. I suspect the AppleTV also fails.
                              Edit: Note that my Netflix activity starts with turning the TV on. Since that doesn't work (assuming the remote is not 'activated') then maybe everything else afterward isn't being done. That's pure speculation, though. The attached image shows the beginning of my activity as it is programmed in the Harmony interface. The rest is just navigating through the menu on the AppleTV.

                              Click image for larger version

Name:	NetflixActivity.png
Views:	56
Size:	70.9 KB
ID:	1436000

                              Comment

                              Working...
                              X