Announcement

Collapse
No announcement yet.

Authentication ptoblems

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Authentication ptoblems

    I have downloaded version 1.0.0.34 and I cannot get a pop up window for authentication. I am running a hometroller S6 windows 7 with framework.net version 4.8.1. When I started for the first time I did not get a pop up. I am using Chrome as the browser

    #2
    Just looked at the log but I don’t see you clicking on the “full authenticate client” button on the setting->generic screen. Did you click that? I know there was another user who had issues with Win7 but he solved it by installing the right .net version and he was using VMs. I seem to recall he did somethings else, like force tls version 1.2 or higher to be used .

    Comment


      #3
      See here https://forums.homeseer.com/forum/hs...79#post1601179

      Comment


        #4
        I will pm you an updated log. I do not understand what forcing version .2 to be used?

        Comment


          #5
          Just looked at the log, it is the exact same error that hidden72 had and solved by upgrading .net and change some settings to allow TLS1.2. hidden72 care to comment what exactly you had to change?

          I found this article: https://social.technet.microsoft.com...-settings.aspx

          Comment


            #6
            I have updated .net to 4.8.1 and have turned on TLS 1.1 and TLS 1.2. I rebooted the computer. I turned on the plugin and went to settings. I have username and password entered correctly. When I click on Reauthenticate or Fully Authenticate nothing happens

            Comment


              #7
              Originally posted by jquincy View Post
              I have updated .net to 4.8.1 and have turned on TLS 1.1 and TLS 1.2. I rebooted the computer. I turned on the plugin and went to settings. I have username and password entered correctly. When I click on Reauthenticate or Fully Authenticate nothing happens
              Did you take a new log? Looks the same as the old log?

              This entry suggests TLS1.2 is not enabled "and error = The request was aborted: Could not create SSL/TLS secure channel."

              Comment


                #8
                Just to double check, did you change this in the windows registry or just the browser? I would think it is the prior the needs to be done.


                Activate TLS protocol in Windows registry

                Important: Before you do any change on the Windows registry, it strongly recommended to back it up.
                Right-click Windows button and select Run Type "regedit", and click OK Then go to "Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control \SecurityProviders\SCHANNEL\Protocols", and create one key and two DWORD(32-bit) values, as the image below shows.
                Key/Key Values Name Value
                key TLS 1.2
                DWORD(32-bit) DisabledByDefault 0
                DWORD(32-bit) Enabled 1


                Now, you can exit the registry and restart your machine.​

                Comment


                  #9
                  I have updated the registry and still no way to authenticate

                  Comment


                    #10
                    Maybe hidden72 can weigh in what he changed so we can publish it for everyone who is still on Win7

                    Comment


                      #11
                      Did you check that you have the update installed , referred here (https://learn.microsoft.com/en-us/me...s-1-2-client)?

                      Earlier versions of Windows, such as Windows 7 or Windows Server 2012, don't enable TLS 1.1 or TLS 1.2 by default for secure communications using WinHTTP. For these earlier versions of Windows, install Update 3140245 to enable the registry value below, which can be set to add TLS 1.1 and TLS 1.2 to the default secure protocols list for WinHTTP. With the patch installed, create the following registry values:

                      Comment


                        #12
                        Or this video
                        https://video.search.yahoo.com/searc...d&action=click

                        Comment


                          #13
                          Thank you for your patience. I have authenticated the account and it is working. I did NOT have to follow this:

                          ​​​​​​Did you check that you have the update installed , referred here (https://learn.microsoft.com/en-us/me...s-1-2-client)?

                          Earlier versions of Windows, such as Windows 7 or Windows Server 2012, don't enable TLS 1.1 or TLS 1.2 by default for secure communications using WinHTTP. For these earlier versions of Windows, install Update 3140245 to enable the registry value below, which can be set to add TLS 1.1 and TLS 1.2 to the default secure protocols list for WinHTTP. With the patch installed, create the following registry values:​​

                          Comment


                            #14
                            jquincy would you be so kind to document what exactly you did to make it work, so your fellow users can use that info incase they run into the same issue.
                            Thanks and happy to read it works.
                            Dirk

                            Comment


                              #15
                              For any of those running an older Hometroller S6 with windows 7 there are a few things that need to be done in order to be able to authenticate the plugin.

                              1.https://social.technet.microsoft.com...-settings.aspx
                              2.You must then edit the registry. Back up registry before attempting to edit it
                              3. This video dcorsus posted is extremely self explanatory. https://video.search.yahoo.com/searc...d&action=click
                              The following steps are probably the same for everyone

                              4. Open ring app on phone and go to control center
                              5. Open Account Verification on ring app
                              6. Scroll down to Authorize a new device. This will generate a code to use in Homeseer Ring Plugin settings​

                              Comment

                              Working...
                              X