Announcement

Collapse
No announcement yet.

Calendars no longer showing up

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Calendars no longer showing up

    Hello!

    I'm not sure what happened, but the calendars are no longer showing up in HS4. They were working, but now they're gone! I went through the setup process again and checked the client_ID and secret_ID and they're both correct.

    I'm not 100% sure, but it looked to me like some of the options in the Google Cloud Platform have changed. Is this happening to anyone else?

    Thanks!

    #2
    Please check Logs, I need more info.

    I documented new Google procedure https://forums.homeseer.com/forum/hs...le-credentials

    Comment


      #3
      Are you talking about the HomeSeer Logs? The only information I have in there is the AK GoogleCalendar finished initializing. No other records. I have the switched to ON in the settings page.

      I did try uninstalling and reinstalling the plug-in, but same issue.
      I also disabled the Google Calendar API and went through the setup process again, but no luck.

      Sorry, I'm working remote at the moment and can't take screen shots.

      Comment


        #4
        If you are working remote - when you enter the credentials - the plugin should pop-up OAuth prompts and you probably are not seeing them?

        Are you on Windows or Linux? It's a good practice to try providing as much info as possible, i.e. OS, HS version, plugin version. Even better info from Tools => Help screen.

        Comment


          #5
          Sorry about that!

          Windows 10 Machine
          HS4 Pro 4.1.18
          AK GoogleCalendar 4.0.0.12

          Using Edge browser on that machine though AnyDesk remote software.

          That is correct that I am not getting a OAuth pop-up after hitting the save button on the settings page.
          Code:
          Date/time=8/4/2021 9:24:29 AM Central Daylight Time
          Version=HS4 Pro Edition 4.1.18.0 (Windows)
          License=Registered
          Confguration File=C:\Program Files (x86)\HomeSeer HS3\Data\HomeSeerData.json
          In Virtual Machine=No MFG: supermicro
          Antivirus=Windows Defender
          OS=Microsoft Windows 10 Pro - Work Station
          OS Version=10.0.19042
          Uptime=1 Day 4 Hours 30 Minutes 3 Seconds
          Lan IP=192.168.1.81 (ravenHS3)
          Device Count=553
          Event Count=27
          Processor:=Intel64 Family 6 Model 37 Stepping 5 at 2.98 GHz
          Modules/Threads=110 Modules, 118 Threads
          Available Threads=1023
          System Load=193 Processes, 9% Load
          Free/Total Memory=1.16 GBytes / 3.93 GBytes (30% free)
          Free/Total Virtual Memory=2.59 GBytes / 7.93 GBytes (33% free)
          HomeSeer Memory Used=99 Mbytes
          Plugin Memory Used=15 EXE Plug-Ins using 433 Mbytes
          Plugins Installed=AK GoogleCalendar 4.0.0.12,AK GoogleCast 4.0.0.36,BLAudioMatrix 2.0.1.0,BLBackup 2.0.61.0,BLPlex 2.0.20.0,BLRoombaWifi 2.0.37.0,Chromecast 3.0.0.44,Device History 1.4.0.4,EasyTrigger 3.0.0.71,FaceRecognition 3.0.1.0,HSBuddy 3.14.517.3,Insteon 3.0.7.1,JowiHue 2.1.0.10,Kinect 3.0.0.45,KMS 3.0.0.7,Kodi 3.0.1.14,mcsMQTT 5.17.3.2,Nest 3.0.0.34,Philips Hue 4.0.23.0,PHLocation 3.0.0.141,RainMachine 1.0.0.8,Random 3.0.0.2,Restart 1.0.0.7,rnbWeather 4.1.0.0,UltraGCIR3 3.0.6551.16959,UltraSighthoundVideo3 3.0.5960.36744,weatherXML 3.0.1.19,Z-Wave 3.0.7.0,Z-Wave UI 1.0.0.0

          Comment


            #6
            I just deleted the project in the Google Cloud system, uninstalled the plug-in and started over. (And rebooted the server)

            I also tried in both the Edge Browser and Firefox, but both times there is no OAuth pop-up after entering the credentials and pressing save. I think I broke something 😖

            Comment


              #7
              The credentials are stored in C:\Program Files (x86)\HomeSeer HS4\Config\AKGoogleCalendar.ini

              Uninstalling the plugin doesn't do anything. You need to delete KGoogleCalendar.ini and KGoogleCalendar.ini.back. - when HS is not running.

              Also, since it's Google issue - it's better if you set Chrome as default browser and login in Chrome with your Google account - before setting up the plugin.

              Comment


                #8
                Unrelated, you have only 4Gb memory, even if it says Free Memory=1.16 GB, it's using 5.39 GB of "Virtual Memory" - which is your hard disk, slowing down your PC. I suggest upgrading RAM to 8 GB if possible.

                Comment


                  #9
                  Ok, I shutdown HS4 and deleted those two files.

                  Installed Chrome, logged in, and tried again.

                  Same result so far. Here's my settings page at the moment:

                  Click image for larger version

Name:	GoogleCalendarSetup01.png
Views:	94
Size:	220.6 KB
ID:	1487961


                  Oh, and RAM has been ordered, it's on it's way! Thanks for that suggestion!

                  Comment


                    #10
                    Same result - you mean no OAuth pop-up? Anything in the Log?

                    Comment


                      #11
                      That's correct, no OAuth pop-up and nothing in the logs.

                      Here's the logs after I initialized the plug-in and then tried to save the client and secret IDs:

                      Click image for larger version

Name:	GoogleCalendarSetup02.png
Views:	86
Size:	152.5 KB
ID:	1487997

                      Comment


                        #12
                        Are you still remoting?

                        I'll try adding more logging.

                        Comment


                          #13
                          I'm at home now, but technically still remoting because the server is headless. I can hookup a monitor if I need to.

                          Comment


                            #14
                            Yes, I think monitor will help

                            Comment


                              #15
                              Monitor/keyboard/mouse is setup. I closed HS4, deleted the config files, tried again using Chrome. Same no O-Auth pop-up. What else should I try?

                              Thanks!

                              Comment

                              Working...
                              X