Announcement

Collapse
No announcement yet.

UDM Connection.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    UDM Connection.

    Hello,

    As indicated in the related thread, I would set up the UDM and when the plugin attempts to connect it is receiving the 405 Method Not Allowed. IIRCUDM may need to use root and I will look back at the previous posts for the MEIUnifi testing. I will follow up a little later today when time permits



    #2
    Thanks. I don't see any reason why it would require root. Let me know what you find out!
    stefxx

    Comment


      #3
      Originally posted by stefxx View Post
      Thanks. I don't see any reason why it would require root. Let me know what you find out!
      You are of course correct, as this is the connection method is being refused. I am out and will review when I get home. Is there a verbose logging option? I did turn on logging but is only returns the 405 error

      Comment


        #4
        he UDM error was a result of old firmware and once the UDM was upgraded to 1.8.5 it connected immediately.
        The only log entry displayed was "File does not exist: C:\Program Files (x86)\HomeSeer HS4\html\Unifi\Unknown.png

        Click image for larger version

Name:	Screen Shot 2021-01-22 at 2.16.35 pm.png
Views:	80
Size:	72.0 KB
ID:	1450148

        Comment


          #5
          Great, good to known. I will fix the "unknown" image in the next beta. I would like to see the hardware type for the UDM, so could you enable debug logging and restart the plugin? It should show up in the log at startup. Thanks again for your efforts!
          stefxx

          Comment


            #6
            Originally posted by stefxx View Post
            Great, good to known. I will fix the "unknown" image in the next beta. I would like to see the hardware type for the UDM, so could you enable debug logging and restart the plugin? It should show up in the log at startup. Thanks again for your efforts!
            I did enable debug logging and however, I neglect to add the entry below to my previous post.

            22/01/2021 12:09:23 PM US Unknown hardware type: 59921

            Comment


              #7
              Thanks!
              stefxx

              Comment


                #8
                You're welcome. There was also one error that I encountered and I need to report.
                Inconsistent but when I modified an existing UDM-Pro Controller, one of the times, it appears to corrupt the Unifi.ini file and the consequence in this sent the plugin into an infinite restart loop, start > disconnect > restarting > connected > disconnect....
                The only resolution was delete the Unifi.ini and reconfigure... A very quick work around to restore the service.
                When I am back home tomorrow, I will see if I can establish if I can repeat the behauvior or actions that resulted in this occurring or this may be a one off incident.

                Comment


                  #9
                  Interesting. I am already working on reducing the ini read/write actions to optimize performance. But the actual handling of the ini is done by HS4, so if it gets corrupted I am note sure how to resolve that... Let's hope is was a one-time incident.
                  stefxx

                  Comment


                    #10
                    I did see a similar error encountered with mbWeather when it was in its initial beta testing phase but once rectified it never repeated. So hopefully a one off occurrence.

                    Comment

                    Working...
                    X