Announcement

Collapse
No announcement yet.

Anyone willing to test?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #46
    Originally posted by stefxx View Post
    Ok, final beta 11. If this remains stable, I will release early next week.

    And I couldn't resist, so I added a camera snapshot feature.
    Should I start from scratch with this one also?
    RJ_Make On YouTube

    Comment


      #47
      Originally posted by ServiceXp View Post

      Should I start from scratch with this one also?
      No.
      stefxx

      Comment


        #48
        Possible Bug. Clients added that are currently offline: Only Connection State and Mac Address devices get created.
        RJ_Make On YouTube

        Comment


          #49
          Possible Bug: Update Notification: Events show a "Update available" option, but the devices are showing a number. Not sure if the event will still fire?

          Click image for larger version

Name:	2021-06-20_7-51-34.png
Views:	25
Size:	38.6 KB
ID:	1480269

          Click image for larger version

Name:	2021-06-20_7-51-20.png
Views:	24
Size:	53.6 KB
ID:	1480270

          Click image for larger version

Name:	2021-06-20_7-52-10.png
Views:	22
Size:	190.1 KB
ID:	1480271



          RJ_Make On YouTube

          Comment


            #50
            Originally posted by ServiceXp View Post
            Possible Bug: Update Notification: Events show a "Update available" option, but the devices are showing a number. Not sure if the event will still fire?
            If an update is available, it will be set to "Update available" with a value of 1. The Status/String will be set to the available version. So if you are checking in your event for "Update available", it will trigger just fine.
            stefxx

            Comment


              #51
              Originally posted by ServiceXp View Post
              Possible Bug. Clients added that are currently offline: Only Connection State and Mac Address devices get created.
              I will look into this.
              stefxx

              Comment


                #52
                I Just broke the PI on my system. Won't start so I can't active the log. You want me to grab the cli output?

                This started after I ran this event, which updated 3 devices with new firmware.


                Click image for larger version

Name:	2021-06-20_9-51-19.png
Views:	14
Size:	538.2 KB
ID:	1480292


                Click image for larger version

Name:	2021-06-20_9-47-31.png
Views:	17
Size:	23.4 KB
ID:	1480291


                Faulting application name: HSPI_Unifi.exe, version: 4.0.12.11, time stamp: 0xf5f2ab12
                Faulting module name: unknown, version: 0.0.0.0, time stamp: 0x00000000
                Exception code: 0xc0000005
                Fault offset: 0x06f7ea8f
                Faulting process id: 0x410c
                Faulting application start time: 0x01d765da6de1fefc
                Faulting application path: C:\Program Files (x86)\HomeSeer HS3\HSPI_Unifi.exe
                Faulting module path: unknown
                Report Id: cdf43419-8998-46eb-8652-691c0cef41bb
                Faulting package full name:
                Faulting package-relative application ID:


                RJ_Make On YouTube

                Comment


                  #53
                  I can't grab the cli output, as it drops too fast. I believe these are the log settings, so I'll try adding them to the .ini file.

                  LogDebug=True
                  LogDevUpd=True
                  LogSend=True
                  LogReceived=True
                  LogToFile=True
                  RJ_Make On YouTube

                  Comment


                    #54
                    Or just run the plugin from the command line. Go to your HomeSeer directory and start HSPI_Unifi.exe. When it crashes, it should keep the window open.
                    stefxx

                    Comment


                      #55
                      Originally posted by ServiceXp View Post
                      Possible Bug. Clients added that are currently offline: Only Connection State and Mac Address devices get created.
                      Works for me. However, when the features are removed manually (not by using the plugin setup or by deleting all devices/features at once) they will only be recreated until a valid value is seen.
                      stefxx

                      Comment


                        #56
                        Originally posted by stefxx View Post
                        Or just run the plugin from the command line. Go to your HomeSeer directory and start HSPI_Unifi.exe. When it crashes, it should keep the window open.
                        It does not, the cli window closes.
                        RJ_Make On YouTube

                        Comment


                          #57
                          Originally posted by stefxx View Post

                          Works for me. However, when the features are removed manually (not by using the plugin setup or by deleting all devices/features at once) they will only be recreated until a valid value is seen.
                          This was adding a new device (never before selected) but it did create the other devices when the computer turned on. Just wasn't sure if this observation was anticipated.
                          RJ_Make On YouTube

                          Comment


                            #58
                            Originally posted by ServiceXp View Post
                            I Just broke the PI on my system. Won't start so I can't active the log. You want me to grab the cli output?

                            This started after I ran this event, which updated 3 devices with new firmware.
                            I've seen the plugin crash when updating devices. Messing with the network configuration on a live system will always cause unpredictable results. However, it should restart and recover off course. If all devices completed the upgrade and the plugin still fails to start, something is really wrong!!
                            stefxx

                            Comment


                              #59
                              Originally posted by ServiceXp View Post

                              It does not, the cli window closes.
                              Just to be clear, open a "command prompt", "cd" into your HomeSeer directory and type "HSPI_Unifi.exe".

                              stefxx

                              Comment


                                #60
                                Originally posted by stefxx View Post

                                Just to be clear, open a "command prompt", "cd" into your HomeSeer directory and type "HSPI_Unifi.exe".
                                Ok, didn't do it that way, so I will try again. I also just sent you some logs.
                                RJ_Make On YouTube

                                Comment

                                Working...
                                X