Announcement

Collapse
No announcement yet.

State status not changing when device is disconnected.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • alphatech
    replied
    Thank you Stefan, it looks great. I will open another post for few simple questions soon but everything looks great.

    Sent from my SM-S906U using Tapatalk

    Leave a comment:


  • stefxx
    replied
    The existing, old device will continue to show (it might go away when you click "forget").

    You will have to look for a new device, since it has a new Mac address is will be considered a new devices.

    So you will have to disable the device with the old Mac address, and enable the device with the new Mac address.

    Leave a comment:


  • alphatech
    replied
    Thanks for the fast response. So I went in my Droid, changed the Mac to Mac phone, it reflect it in unifi but not in the Plugin. In the Plugin, I disabled the client and re enabled it again but the same old Mac shows. I will change it again this morning and I will keep you posted. Anything else I can do in the meantime? By the way, I m using the beta.

    Thanks

    Sent from my SM-S906U using Tapatalk

    Leave a comment:


  • stefxx
    replied
    Make sure to re-connect the device after changing the property on the Android device.

    The plugin should pick up the new Mac address soon. The old Mac address might also be there for days or weeks, that is normal and should disappear over time.

    Leave a comment:


  • alphatech
    replied
    Thanks Stephan. So far so good. I read the post about tracking the device referenced here. I changed the Android to phone MAC but the Unifi still shows the random Mac. How do I change your plugin client device to reflect the new mac? Would it automatically update after few minutes?

    Leave a comment:


  • stefxx
    replied
    Great! No special events for this, since using device status gives much more flexibility in my opinion.

    Read this first on how to track clients: https://forums.homeseer.com/forum/hs...atus-explained. That should get you started.

    Leave a comment:


  • alphatech
    replied
    I'm going to try your Plugin, I have noticed a very fast response and updates. I currently use the other one but going to test yours. With the previous Plugin I hade the same issue expecially when I have multiple access points. Do you have any special events to check whem the phone is actually out of range or just check for it via device?

    Sent from my SM-S906U using Tapatalk

    Leave a comment:


  • stefxx
    replied
    I have never seen that behavior. Most of my automaton depends on the (un)availability of our phones in our household (only Android) and it works perfectly.

    I hope someone can help you. You might also consider asking this on the UniFi community forums?

    Leave a comment:


  • Bruce
    replied
    Yes, I think in my case, the issue is not with the plug-in. My devices seem to be holding the connected status in the unifi controller for way too long. eg. they stay on all day even when the user has gone away.

    I was hoping someone else might have found an option within the unifi controller where this time setting can be adjusted.

    Leave a comment:


  • stefxx
    replied
    This is - from a Plugin perspective - not related. This is more how UniFi handles the connection/disconnection of clients, right?

    There are a few discussions here on clients - mainly phones - are disconnecting during idle/sleep time. I have never heard of clients that are always connected according to the UniFi network. Do know that if a client is getting out of reach of the WiFi network, it might take up to 10 minutes before the UniFi controller "gives up" and sets the client to disconnected.

    The Plugin is "simply" stating whatever the UniFi Network is telling it.

    Leave a comment:


  • Bruce
    replied
    I am having a similar problem. For me the problem seems to be with the Unifi controller my Wi-Fi devices (mostly phones) are staying "connected" to the Unifi controller all the time. Happening for Apple iPhones and Samsung Galaxy phones.

    Does anyone know if there are settings in Unifi that can be adjusted?

    Thanks

    Leave a comment:


  • stefxx
    replied
    Did you have a chance to test this version? Thanks!

    Leave a comment:


  • stefxx
    replied
    Can you please try beta 4.0.29.1? That should update the "State" value for UniFi Network devices much better than before.

    Thanks!

    Leave a comment:


  • cdobie
    replied
    Thanks! Yes the value is 1 ["state": 1,] Yes I am referring to the "State" feature of the device. My testing was unplugging the device and checking it after a period of time. The counters will stop updating such as client count and experience but the "State" will remain "Connected" Thanks for the help and the quick response!

    Leave a comment:


  • stefxx
    replied
    I will do some testing tomorrow to see if I can reproduce it. I assume you are referring to the HS4 "State" feature of the device, right?

    In the meantime, can you check the JSON at the time the UniFi device is offline? You can find the JSON by viewing any of the HS4 features, and select the "UniFi" tab.

    The "state" value of the JSON is normally 1 when Connected. Let me know if that changes when the device goes offline.

    Leave a comment:

Working...
X