Announcement

Collapse
No announcement yet.

not discovering ikea bridge tradfri

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    not discovering ikea bridge tradfri

    New installation of the Ikea blinds fyrtur. 3 blinds with gateway Tradfri installed and working via phone app and google home. Am excited to use the AK Ikea plug in to control via homeseer. I am not, however, able to discover the tradfri gateway on my hometrollerplus hs4 controller.

    It does not autodiscover and when I click on the "+" from the plugin config page to manually add - I get no response or place to add IP and code manually. Nothing in the logs. Any ideas?

    Thanks!

    #2
    I'll check manual add, haven't used it for long time.

    Regarding discovery, is hometrollerplus Windows or Linux?

    Please when asking for help - go to Tool -> Help and copy the info from there.

    Comment


      #3
      Sorry- windows 19.

      Here is the info


      Date/time=5/30/2021 2:37:41 AM Central Daylight Time
      Version=HS4 Standard Edition 4.1.16.0 (Windows)
      License=Registered
      Confguration File=C:\Program Files (x86)\HomeSeer HS4\Data\HomeSeerData.json
      In Virtual Machine=No MFG: besstar tech
      Antivirus=Windows Defender
      OS=Microsoft Windows 10 Pro - Work Station
      OS Version=10.0.18363
      Uptime=0 Days 3 Hours 10 Minutes 10 Seconds
      Lan IP=192.168 (HomeTrollerPlusG1)
      Device Count=601
      Event Count=87
      Processor:=Intel64 Family 6 Model 92 Stepping 10 at 1.03 GHz
      Modules/Threads=133 Modules, 59 Threads
      Available Threads=1023
      System Load=162 Processes, 10% Load
      Free/Total Memory=1.62 GBytes / 3.85 GBytes (42% free)
      Free/Total Virtual Memory=1.91 GBytes / 4.54 GBytes (42% free)
      HomeSeer Memory Used=63 Mbytes
      Plugin Memory Used=5 EXE Plug-Ins using 70 Mbytes
      Plugins Installed=EasyTrigger 3.0.0.74,HS MyQ 4.0.4.0,MagicHome 1.0.0.354,Philips Hue 4.0.22.0,Sonos 3.1.0.57,Zigbee 4.0.8.0,Z-Wave 3.0.2.0

      Comment


        #4
        Typo - Windows 10

        Comment


          #5
          Ok, on Windows I always suggest installing Bonjour Print Services for Windows - after restarting the plugin it should use Bonjour for discovery.

          If it doesn't help, please post screenshot of the plugin Settings page. And check logs.

          Do you have any special network configuration?

          Comment


            #6
            I will try bonjour. No special network - in fact the hometroller and tradfri are on the same switch

            Comment


              #7
              Strange. Anyways, Bonjour is much better option, as it's developed by Apple long time ago.
              And it's doing mDNS (Zeroconf) discovery in background - instead of each plugin sending broadcast separately.

              Comment


                #8
                The plug-in still does not discover the ikea gateway after installing the bonjour service

                Comment


                  #9
                  Can you please try attached Browser app [ATTACH]n1477119[/ATTACH]

                  It should find two entries for Ikea:


                  Click image for larger version

Name:	2021-05-31 (1).png
Views:	38
Size:	22.0 KB
ID:	1477120

                  Comment


                    #10
                    got some information - but does not seem complete


                    Click image for larger version

Name:	services.png
Views:	32
Size:	28.3 KB
ID:	1477223

                    Comment


                      #11
                      Looks strange. Do you also see _coap._udp?

                      Comment


                        #12
                        No coap was on the list

                        Comment


                          #13
                          Ok, looks like I have to check adding device manually.

                          It seems that you do have multiple network adapters in your server? Possibly this causes issues. I also know mDNS (Zeroconf) has issues with IPv6, may be try disabling. It's not my area of expertise...

                          Comment


                            #14
                            I agree that something is off - but it had no issues detecting the hue, google devices, and sonos speakers. The hometrollerplus is a compact pc - nuc style - with only one interface.

                            might be the gateway - but my android phone was able to find it. I have rebooted the gateway in adding bonjour with no change

                            Comment


                              #15
                              All other devices are connected via WiFi and your router. Since you also have Ethernet - yo have at least two network adapters. Obviously mDNS works over WiFi, but not Ethernet.

                              Can you try disabling IPv6 in Ethernet adapter setting? I will still fix manual adding devices, but sorting out mDNS is useful anyways.

                              Comment

                              Working...
                              X