Announcement

Collapse
No announcement yet.

Issue with HS4 running on non conventional 80 port

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Issue with HS4 running on non conventional 80 port

    Hi Alexey

    I have a problem with your plugin due to my setup

    Due to the install of new services in my home server, I have changed the HS4 from default port 80 to 8080.

    In my setup I have several shelly devices that have been running perfectly. In particular I have a shelly ix3 sensor switch attached to a physical switch that is configured to control another shelly device in the action section of the ix3 device as show in the picture.

    As you can see, your plugin configures automatically the first entry, and the second entry is the manual call I introduced to control manually the device from the physical switch.

    So, now that I have changed the HS4 port from 80 to 8080, every time I actuate on the physical switch these actions are called but now the first one is producing a timeout which is delaying the rest of actions and it's very annoying.

    If I add manually the port to the first call this is http://192.168.1.210:8080/json?request=controldevicebyvalue&ref=....., everything works again flawless.

    The problem here is that every time HS4 is restarted your plugin checks for the url, and makes 2 changes to my configuration that create problems again:
    1. Puts the original call to HS WITHOUT the 8080 port, this is, It thinks is on the port 80 again, which is not the case, so we have again the timeout
    2. Erases my manual call to control the device (the 2nd call in the picture)
    This is very frustrating as I cannot progress in my new setup now

    Is there any way to control this?

    Thanks in advance

    Best

    Juan

    Click image for larger version

Name:	Capto_Capture 2021-08-17_06-40-23_p. m..png
Views:	98
Size:	115.8 KB
ID:	1489856

    #2
    Thank you Juan for providing detailed description of your issue.

    I will add the port to the URL.

    Can you check if the port is set in gWebSvrPort (C:\Program Files (x86)\HomeSeer HS4\Config\settings.ini)?

    Regarding deleting the second URL - it's a known issue, may take a bit of work.

    Alex

    Comment


      #3
      Originally posted by alexbk66 View Post
      Thank you Juan for providing detailed description of your issue.

      I will add the port to the URL.

      Can you check if the port is set in gWebSvrPort (C:\Program Files (x86)\HomeSeer HS4\Config\settings.ini)?

      Regarding deleting the second URL - it's a known issue, may take a bit of work.

      Alex
      Hi Alex

      Yes, I confirm you that the port is set in the parameter you indicated

      best

      Juan

      Comment


        #4
        For second issue I created a separate thread

        https://forums.homeseer.com/forum/hs...es-action-urls

        Comment


          #5
          Ver 4.0.0.57 (in BETA) (PluginLib 4.0.1..54) - Append HSPort to GetCtrlJson

          Not tested since I'm away from home. Only port issue should be fixed.

          The second issue I will be able to fix/test only when I have access to my Shelly devices.

          Comment

          Working...
          X