Announcement

Collapse
No announcement yet.

Upgrade keeps failing - Only One Hub works

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Upgrade keeps failing - Only One Hub works

    I've tried several times to upgrade my plugin from 3 to 4. Unfortunately, even with the latest versions of everything, the upgrade only successfully pulls over one hub.

    Any way to get this to work properly and convert both hubs' devices?

    #2
    I'm going to have to revert back again. The plugin just keeps restarting:




    7/11/2020 12:58:13

    HomeSeer
    Warning
    I/O interface JowiHue is down, executable is not running, restarting ...

    7/11/2020 12:58:07

    HomeSeer
    Info
    Plugin JowiHue with ID: JowiHue and Instance: has disconnected

    7/11/2020 12:57:58

    JowiHue
    Info
    HTTPS access enabled on bridge sys.hue1

    7/11/2020 12:57:58

    JowiHue
    Info
    Started Philips bridge sys.hue1

    7/11/2020 12:57:56

    JowiHue
    Warning
    Warning: Or remove the devices belonging to this group


    ...
    Warning: Or remove the devices belonging to this light


    7/11/2020 12:47:32

    JowiHue
    Warning
    Warning: Did you remove a light from the bridge but did Not remove the device? Re-add the light to the bridge And your events are save

    7/11/2020 12:47:32

    JowiHue
    Warning
    Warning: Orphaned Light Hue color lamp 1 (Hue) found, Not found on any connected bridge

    7/11/2020 12:47:32

    JowiHue
    Info
    Unknown type of Feature (1.primary lighting (z) (s) (hue))

    7/11/2020 12:47:32

    JowiHue
    Info
    * Connected to bridge sys.hue1 at x.x.x.231:80

    7/11/2020 12:47:32

    JowiHue
    Info
    This error was caused by a device called sys.hue2. If this device is not a bridge, please remove it from the devices and let it recreate?

    7/11/2020 12:47:32

    JowiHue
    Error
    Error: (FindBridgesSelf)::Error in step adding a bridge device named sys.hue2 on IP x.x.x.234 : Index was out of range. Must be non-negative and less than the size of the collection. Parameter name: index

    Comment


      #3
      I am sorry to hear conversion is not going wel. I have been testing here with multiple bridges, but for me it goes well. Is it possible to perform a trace of the conversion?
      Set the detailed trace option and trace to file option in the HS3 version of the plugin (HS3!!). then stop the plugin and upgrade to HS4
      Depending on your method of upgrading you can start the old HS3 plugin in HS4 and check if it runs fine. If you run the alternate version of the upgrade you can install the HS4 version of the plugin directly.

      Then let the plugig run until the step 3 of conversion is finished. Let it run for a few more minutes. If it threw error I would like to know. In the \Logs\ directory you will find the file JowiHue.log. Can you send me this file? Send it to jowihue at ziggo dot nl
      -- Wim

      Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
      650 devices ---- 336 events ----- 40 scripts

      Comment


        #4
        How do I know what step the plugin upgrade is in? I went through and removed unused devices... removed a couple of HS orphaned Hue devices on the affected hub before trying the update again but to no avail.

        I'm able to get HS4 running with JowiHue v2, ut as soon as I install v4 on top, that's the end of it. The v4 plug in gets put into a constant end and restart loop If I try to add the second, missing hub, it won't let me add it (says it can't find a new hub, but I suspect that's because it's already connected).

        Is there a preferred way to update with these issues?

        I have it running again on HS4 with JowiHue 2.1.1.1. I'm at the point I would remove the second hub before upgrading and would consider re-adding it if I can the devices converted so that I don't have a bunch of duplicate or dead devices.

        Comment


          #5
          If you start the HS4 version of the plugin it will log the steps it is in in the HS4 log? It will go through all steps with the first run and log this in the HS4 log? I really would love to get the log as described in my last post so I could get to the bottom of it?
          -- Wim

          Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
          650 devices ---- 336 events ----- 40 scripts

          Comment


            #6
            I just wanted to close the loop on this one. I put the upgrade on hold for a bit (had my HVAC and TV go out within weeks of each other!)

            Wanted to share the good news: Upgrade went flawlessly this time.

            I don't know if it's an update you did or the process I did this time (or combo). But... I disabled the Z-Wave and ISY plugins before I did the upgrade. I have some events that keep the Hue lights synced with Z-Wave switches. Don't know if that had anything to do with it, but I waited for the upgrade to complete before reactivating them.

            Funnily enough, although I fully expected to have to redo the events, everything appears to have ported over flawlessly (including the events).

            Comment

            Working...
            X