No announcement yet.

Link not showing for Wall Plug (Router) but device works.

  • Filter
  • Time
  • Show
Clear All
new posts

    Link not showing for Wall Plug (Router) but device works.


    I have started my Zigbee install. So far, I have three devices. I started with two of the Sonoff wall plugs as they were recommended to start to build the backbone.
    Originally, when I added them they both had links to the controller and also to each other.

    After a day or so, I looked and the inter-links to each other went away.

    Then I added the Aqara Multi-Sensor with works great but instead of finding the wall plugs as the nearest routers, it connects to the Conbee II stick in the basement.

    Today when I looked, I noticed my Entertainment Center plug has no link or LQI listed. But when I control it from the UI or ZHome + the plug works perfectly and also responds with the correct ON/OFF status.

    I've looked for someway to re-force a scan to reestablish the mesh network but cannot find anywhere, short of deleting them all and starting all over again to tell deCONZ to rescan the entire network and create new optimal links.

    These are the wall plugs I bought based, I believe, on @TC1's recommendations from Amazon. I just noticed that they are the Lite version. Are the Lite's not routers?

    But when I originally added them they did show links between them.

    So two questions,

    1) Anyway to tell deCONZ to rescan and reform the mesh network?
    2) Should I return the Amazon S31's and buy ones that are not the Lite version? I really didn't need the power monitoring feature so that's why I got the Lite. Form what I've read, I think they both act as routers. Yes?

    Again, funny thing, all three devices work even though one of them shows no connection to either the Conbee II stick or any other device.

    Thanks in advance.
    Attached Files

    The hallway plug doesn't have a good LQI. When building out your Zigbee mesh it's the same as Z-wave: start adding devices that are closest to the controller and work your way out. Also, mounting your Conbee on a USB extension cable (mine is about a foot or two) away from the PC it's connected to can help with transmission, I hang mine on the wall in the closet where it is located.

    Another thing to check is WiFi interference, don't forget that Zigbee is the same spectrum as WiFi (2.4Ghz). I did a radio survey around my house and I had to move my Zigbee channel to improve connectivity/reliability.

    If you need a router closer to the ConBee to bridge the distance then head to a local Ikea and buy one of their $10 plugs or signal repeaters:

    Also, are you using the latest Conbee2 firmware and production version of deconz?

    Endpoint devices (battery powered) will always try to connect direct if possible. Here's a section of my network, notice my routers have multiple paths to get home:
    Click image for larger version

Name:	Capture.PNG
Views:	166
Size:	85.0 KB
ID:	1522508


      Another thought, when adding Zigbee devices and using deconz, the network information doesn't update instantaneously, the routes need time to work out, just like Z-wave. Since you have a small network right now that shouldn't take long.


        I moved the hallway one to directly over the conbee stick which is on a 12" USB3 extension cord hanging from the basement rafters. The Plug is now almost directly over it. Nothing has changed yet.

        But I still don't understand how the entertainment center shows 0 Zero link and LQI but still works fine. According to the node information, nothing sees it and it sees nothing but it works and it's about 40 feet from the stick and 20 from the hallway plug which is now only 4 feet vertical from the Conbee. ?????

        Being it's small, should I just delete everything, reset the devices to factory and just re-add everything over?


          I don't think that's necessary. I'd really encourage you to do a radio survey, because the major WiFi channels of 1, 6 and 11 were saturated in my area, I had to move my zigbee network to zigbee channel 20 in order to get signal reliability. Both my wifi access point and zigbee controller are in the same closet and were beating each other up, lol.

          This article explains the issue well.



            I am not sure, but the missing lines you are seeing might very well come from the latest deCONZ changes in the map of deCONZ. There is new functionality that has been partly set as default (check the below image) . You can now filter out the weaker connections in the map by setting a so called "minimum LQI setting" This setting will filter out all lines lower then the set LQI quality. Especially on larger networks this enables easier spotting weak areas (as there is no line visible anymore. But those weaker lines are not saying the device is not reachable at all, but it does have a higher chance of missing signals, especially when interference is involved (WIFI/Microwave is on/ Zwave stick on the same device... etc.). If this is the case, dresden electronics is suggestin to put the conbee on a USB extender cable, so you can move it around to an area of less possible interference.

            A maximum of 7 meters between two routers (21 feet) is what I normally advise for deCONZ. It can have a larger distance, but it all depends on walls, material and interference. I have a concrete house and have sensors at around 15 meters away from the Conbee and even these battery devices are connecting direct into the Conbee. So it is hard to predict where a device has a good signal. The gateway takes care about that.

            One extra new functionality that has been added in the latest version of deCONZ is source routing. In the below image you can find the source routers by following the thicker blue lines in the map (when enabled)
            Especially when the network grows a bit larger, this new function wil address certain routers on preference to access other devices. Enabling this option does help stability of the gateway (at least that is my impression, not proofed yet) You can see this option in the same image below.
            To get to the window shown, select panels, enable the source routing panel and select it by clicking on tab button on the left bottom part in the window.

            Click image for larger version  Name:	2022-01-23 13_28_41- (phoscon) - VNC Viewer.png Views:	0 Size:	372.2 KB ID:	1522559
            -- Wim

            Plugins: JowiHue, RFXCOM, Sonos4, Jon00's Perfmon and Network monitor, EasyTrigger, Pushover 3P, rnbWeather, BLBackup, AK SmartDevice, Pushover, PHLocation, Zwave, GCalseer, SDJ-Health, Device History, BLGData

            1210 devices/features ---- 392 events ----- 40 scripts


              Thanks Wim,

              I've set the option and also set my minimum LQI to 30 to just make sure and enabled source routing. I've already placed the Conbee on a USB extender and it's 5 feet from, and above, the PC and ZWave stick.
              I took the opportunity to remove all the devices yesterday and manually re-add them. They are back online and showing, but the funny thing is that two of them (see attached) seem to be communicating with each other but no link from them to the stick. Yet all 3 devices work and report back.

              I've placed an order for two more routing wall plugs (as the Conbee is in the basement and everything else is on the 1st floor). I'll install one of them in the basement across from the Conbee stick and see if it's better.

              The stick seems to have picked Channel 15 as the optimal channel. Do you think that I should also enable some of the other channels (22,26,etc.)? Or will multiple channels just complicate things further?

              I should be getting the two new wall plugs in a day and I'll install them. I assume that once installed the network will self optimize around them or do I need to do something special to force an re-optimization?

              Click image for larger version

Name:	Zigbee Channels.jpg
Views:	132
Size:	51.5 KB
ID:	1522644


                deCONZ will only use one channel. Selecting multiple channels will not change anything really. Like TC1 was mentioning, use a radio survey to see if anything is causing interference with the Conbee. Then choose one channel on deConz accordingly so it saves communication issues if there are any. I think you do not need to worry to much on the lines here, especially when things actually work. The Zigbee channels tend to maintain their connections quite well, without the need for us mingling in. this is why you will not find optimizing tools, it is very different from Z-Wave from that perspective.
                There is not even method to re-optimize the network, the gateway will take care of that overtime...
                -- Wim

                Plugins: JowiHue, RFXCOM, Sonos4, Jon00's Perfmon and Network monitor, EasyTrigger, Pushover 3P, rnbWeather, BLBackup, AK SmartDevice, Pushover, PHLocation, Zwave, GCalseer, SDJ-Health, Device History, BLGData

                1210 devices/features ---- 392 events ----- 40 scripts


                  Thanks, I'm already seeing it optimizing once I added the Sengled LED candelabra bulbs. Now most everything has a link to it. It should get better once I get the two new wall plugs.