Announcement

Collapse
No announcement yet.

Minor issue: Gap in status range for Aqara multi-sensor

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Minor issue: Gap in status range for Aqara multi-sensor

    When JowiHue adds a new Aqara multi-sensor, it creates status value ranges (humidity) between 0-50 and between 51-100. I just noticed that the humidity value was 50.1 so the displayed status was empty.

    #2
    Mike,

    Please check the settings with the value ranges, here you find the decimal places setting, it should be set to 0 decimals normally?

    Click image for larger version

Name:	2022-09-13 21_34_34-Device Settings.png
Views:	57
Size:	34.8 KB
ID:	1566086
    -- Wim

    Plugins: JowiHue, RFXCOM, Sonos4, Jon00's Perfmon and Network monitor, EasyTrigger, Pushover 3P, rnbWeather, BLBackup, AK SmartDevice, Pushover, PHLocation, Zwave, GCalseer, SDJ-Health, Device History, BLGData

    1210 devices/features ---- 392 events ----- 40 scripts

    Comment


      #3
      Yes, the decimal setting is 0. My observation seems to mean that HS first compares the value with Start and End, and does the decimal rounding afterward. So a gap in end to start (50 to 51 here) which is larger than the precision, would not show a status value.
      The settings for temperature seem fine, as the end-to-start is 0.01.
      Not a big deal: I just changed my humidity start value from 51 to 50.001.

      Comment


        #4
        The weird part is is that for me it works fine... I have a displayed value of 51 when the humidity value on the device is 50,67... Wondering if somehow this has to do with decimal point differences. Will check on this...
        -- Wim

        Plugins: JowiHue, RFXCOM, Sonos4, Jon00's Perfmon and Network monitor, EasyTrigger, Pushover 3P, rnbWeather, BLBackup, AK SmartDevice, Pushover, PHLocation, Zwave, GCalseer, SDJ-Health, Device History, BLGData

        1210 devices/features ---- 392 events ----- 40 scripts

        Comment

        Working...
        X