Announcement

Collapse
No announcement yet.

Error when connecting to Hue Bridge

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Error when connecting to Hue Bridge

    I get this error when I try and connect to the hue bridge.

    error Could not resolve field token 0x04000077, due to: Could not load type of field 'HSPI_JowiHue.ApiV2.ClipApiV2Client:_httpClient' (0) due to: Could not load file or assembly 'System.Net.Http, Version=4.2.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' or one of its dependencies. assembly:/usr/local/HomeSeer/HSPI_JowiHue.exe type:ClipApiV2Client membernull)

    Any help would be appreciated.

    #2
    The mono installation seems to be incomplete, it is missing the library mentioned here: System.Net.Http. You need to find that module and update the mono installation to add it. I remember other users updating their mono installation complete to solve it. I do not know Linux very well, so I hope you know how to do this, or that others with knowledge of Linux can chime in for that?

    Wim
    -- Wim

    Plugins: JowiHue, RFXCOM, Sonos4, Jon00's Perfmon and Network monitor, EasyTrigger, Pushover 3P, rnbWeather, BLBackup, AK SmartDevice, Pushover, PHLocation, Zwave, GCalseer, SDJ-Health, Device History, BLGData

    1210 devices/features ---- 392 events ----- 40 scripts

    Comment


      #3
      I was able to upgrade Mono and things work now. Thank you!

      Comment


        #4
        Great!
        -- Wim

        Plugins: JowiHue, RFXCOM, Sonos4, Jon00's Perfmon and Network monitor, EasyTrigger, Pushover 3P, rnbWeather, BLBackup, AK SmartDevice, Pushover, PHLocation, Zwave, GCalseer, SDJ-Health, Device History, BLGData

        1210 devices/features ---- 392 events ----- 40 scripts

        Comment

        Working...
        X