Announcement

Collapse
No announcement yet.

Found in DeConz but no device created

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Found in DeConz but no device created

    Click image for larger version  Name:	Sans titre-4.png Views:	15 Size:	203.9 KB ID:	1576145 Hi all,
    Just got a cheepo temperature sensor from china ...
    It was detected in DeConz, but no devices where created in HS.
    Plugin was restarted, HS was restarted, system and Conbee2 was restarted, what more can I do ?
    Cheers

    Visit zee e-maison : http://www.e-maison.com

    #2
    What I've found is "detected" does not mean "supported" in DeConz. The "unknown" for Manufacturer and Model Identifier is a good indicator that it isn't supported. Only devices that are supported are made available to the REST API which is what Wim uses for his plugin. I stick with Aqara as they are well supported in DeConz.

    Comment


      #3
      Look here before purchasing Zigbee devices to see if they are supported. httxx://zigbee.blakadder.com/deconz.html.

      I run both DeConz and zigbee2mqtt and there are some devices that can be seen in one or the other but if not supported by the controller then no data most likely.

      Comment


        #4
        Can you get a value of the model from read the Basic Cluster? Maybe with the appropriate DDF file you can add it to deCONZ.

        Comment


          #5
          Thank you all, I did not even know what a cluster was 10 minutes ago, I never had a look at DeCONZ.
          The model appears as:
          Manufacturer: _TZE200_znbl8dj5
          Model identifier: TS0601​
          and there are some other topics about it.... Guess I will have to practice in DeCONZ to have it set.
          Thanks
          Visit zee e-maison : http://www.e-maison.com

          Comment


            #6
            Thanks to all, that was a cat-ham​mock detection project that ​went very​ fast, cheap and easy 😺
            Click image for larger version

Name:	2022-11-18 10.22.15.jpg
Views:	90
Size:	96.7 KB
ID:	1576316

            Click image for larger version

Name:	2022-11-18 10.27.51.jpg
Views:	87
Size:	66.4 KB
ID:	1576315
            Attached Files
            Visit zee e-maison : http://www.e-maison.com

            Comment


              #7
              Hahahaha great idea!

              Edit:
              Regard your issue, i found this in Github https://github.com/dresden-elektroni...in/issues/6063

              Maybe Ltek can help you more...but, if it was me, i'll try this DDF (just change manufacturename and modelid)


              {
              "schema": "devcap1.schema.json",
              "manufacturername": "_TZE200_qoy0ekbd",
              "modelid": "TS0601",
              "vendor": "Tuya",
              "product": "Temperature and humidity sensor",
              "sleeper": true,
              "status": "Gold",
              "path": "/devices/tuya/_TZE200_qoy0ekbd_temp_hum_sensor.json",
              "subdevices": [
              {
              "type": "$TYPE_TEMPERATURE_SENSOR",
              "restapi": "/sensors",
              "uuid": [
              "$address.ext",
              "0x01",
              "0x0402"
              ],
              "items": [
              {
              "name": "attr/id"
              },
              {
              "name": "attr/lastannounced"
              },
              {
              "name": "attr/lastseen"
              },
              {
              "name": "attr/manufacturername"
              },
              {
              "name": "attr/modelid"
              },
              {
              "name": "attr/name"
              },
              {
              "name": "attr/swversion"
              },
              {
              "name": "attr/type"
              },
              {
              "name": "attr/uniqueid"
              },
              {
              "name": "config/battery",
              "awake": true,
              "parse": {
              "at": "0x0021",
              "cl": "0x0001",
              "ep": 1,
              "eval": "Item.val = Attr.val / 2;",
              "fn": "zcl"
              },
              "default": 0
              },
              {
              "name": "config/offset",
              "default": 0
              },
              {
              "name": "config/on"
              },
              {
              "name": "config/reachable"
              },
              {
              "name": "state/lastupdated"
              },
              {
              "name": "state/temperature",
              "parse": {"fn": "tuya", "dpid": 1, "eval": "Item.val = 10 * Attr.val;" },
              "read": {"fn": "none"},
              "default": 0
              }
              ]
              },
              {
              "type": "$TYPE_HUMIDITY_SENSOR",
              "restapi": "/sensors",
              "uuid": [
              "$address.ext",
              "0x01",
              "0x0405"
              ],
              "items": [
              {
              "name": "attr/id"
              },
              {
              "name": "attr/lastannounced"
              },
              {
              "name": "attr/lastseen"
              },
              {
              "name": "attr/manufacturername"
              },
              {
              "name": "attr/modelid"
              },
              {
              "name": "attr/name"
              },
              {
              "name": "attr/swversion"
              },
              {
              "name": "attr/type"
              },
              {
              "name": "attr/uniqueid"
              },
              {
              "name": "config/battery",
              "awake": true,
              "parse": {
              "at": "0x0021",
              "cl": "0x0001",
              "ep": 1,
              "eval": "Item.val = Attr.val / 2;",
              "fn": "zcl"
              },
              "default": 0
              },
              {
              "name": "config/offset",
              "default": 0
              },
              {
              "name": "config/on"
              },
              {
              "name": "config/reachable"
              },
              {
              "name": "state/humidity",
              "parse": {"fn": "tuya", "dpid": 2, "eval": "Item.val = 10 * Attr.val;" },
              "read": {"fn": "tuya"},
              "default": 0
              },
              {
              "name": "state/lastupdated"
              }
              ]
              }
              ],
              "bindings": [
              {
              "bind": "unicast",
              "src.ep": 1,
              "cl": "0x0001",
              "report": [
              {
              "at": "0x0021",
              "dt": "0x20",
              "min": 60,
              "max": 3600,
              "change": "0x00000001"
              }
              ]
              }
              ]
              }​

              Comment


                #8
                Originally posted by Bigstevep View Post
                Look here before purchasing Zigbee devices to see if they are supported. httxx://zigbee.blakadder.com/deconz.html.

                I run both DeConz and zigbee2mqtt and there are some devices that can be seen in one or the other but if not supported by the controller then no data most likely.
                Can I run deConz (howihue plugin) and zigbee2mqtt off of the same conbee II device or do I need separate paths to the zigbee network?

                Comment


                  #9
                  Originally posted by nunoary View Post
                  Hahahaha great idea!
                  Regard your issue, i found this in Github https://github.com/dresden-elektroni...in/issues/6063
                  Thanks Nunoary, I found a suiting DDF for _TZE200_znbl8dj5 on Github, and it works great, after learning how it had to be set...
                  Visit zee e-maison : http://www.e-maison.com

                  Comment


                    #10
                    Originally posted by RRR View Post

                    Can I run deConz (howihue plugin) and zigbee2mqtt off of the same conbee II device or do I need separate paths to the zigbee network?
                    I never tried it so I don't know. You can use the DeConz dongle (or Raspi 2 GPIO hat) to run zigbee2mqtt but I use the SonOff dongle for my zigbee2mqtt devices. I use DeConz and the Jowihue plugin for all of my Hue devices and one Aqara FP1 sensor.

                    Comment


                      #11
                      Originally posted by Pierre View Post

                      Thanks Nunoary, I found a suiting DDF for _TZE200_znbl8dj5 on Github, and it works great, after learning how it had to be set...
                      vasrc What a creative idea! hahaha But doe the cat not bother the bump in its but? LOL

                      Glad you got it working
                      -- Wim

                      Plugins: JowiHue, RFXCOM, Sonos4, Jon00's Perfmon and Network monitor, EasyTrigger, Pushover 3P, rnbWeather, BLBackup, AK SmartDevice, Pushover, PHLocation, Zwave, GCalseer, SDJ-Health, Device History, BLGData

                      1210 devices/features ---- 392 events ----- 40 scripts

                      Comment


                        #12
                        Before going crazy, try restarting HS. It happens to me fairly often.

                        Comment

                        Working...
                        X