Announcement

Collapse
No announcement yet.

Beginner

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Beginner

    I have a Pi running zigbee2mqtt along with HS4 and the mcsMQTT plugin. I have a motion sensor paired and have created a device by checking the A column for the particular topics. My problem is a Gledopto Zigbee LED controller that appears to be paired in zigbee2mqtt but I am not seeing it show up in the associations table.

    TYIA
    Rob

    #2
    Suggest using Homeassistant Discovery protocol so mcsMQTT will be able to auto-create devices produced by zigbee2mqtt. This is the homeassistant key set to true in the zigbee2mqtt config file. This in itself likely will not solve this problem but will make future integration easier.

    The association table will show all topics being delivered by the broker as long as the General tab setting for inbound messages has Topic discovery selected tor all topic. This is the default. The MQTT page of mcsMQTT should also be refreshed after the LED controlled sends a message to assure it is not just a browser update issue.

    zigbee2mqtt can also produce a log which includes the MQTT messages that have been sent. It will also show the recognition of the zigbee device.

    The objective is to see where in the chain the expected result is not being obtained.

    Comment


      #3
      Now I am having a problem paging through the associations. This is what I get when I click Next
      Click image for larger version

Name:	mcsMQTT Paging Issue.jpg
Views:	148
Size:	26.6 KB
ID:	1434721

      Comment


        #4
        I have never seen error messages like these. There are filter selectors on the Association tab to reducing the paging requirements. For example, if only zigbee2mqtt topics are to be viewed then the first selector will pick zigbee2mqtt. The second selector will show the next level in the hierarchy so if just looking to see if some topic has been received then looking at only the selectors will help zero-in. There is a Rebuild button on the selectors to assure that they are fresh.

        Comment


          #5
          Not sure what was happening. I had uninstalled/reinstalled mcsMQTT/zigbee2mqtt and that error started after that. I have since reset everything along with turning on homeassistant discovery am now able to see a device in HS. I see my Smarthings motion sensor but I still don't see the light controller. Using MSQTT Explorer, I can see that there a home assistant topic in addition to the zigbee2mqtt topic. Also fired up, Zigbee2MqttAssistant and can see both devices. In the HS Associations filters, I see zigbee2mqtt topic but not the homeassistant topic

          Comment


            #6
            What I think you are indicating is that zigbee2mqtt is not publishing light controller information. Why do you think the light controller is paired to the zigbee coordinator and zigbee2mqtt is able to decode it? Guidance on debug on the zigbee2mqtt side is covered pretty well in the zigbee2mqtt wiki.

            Comment


              #7
              It appears that the light controller is supposed to work with zigbee2mqtt but from looking at the issues board it appears to be a little flaky. Because of this, I changed to trying to add an EcoSmart bulb which is also listed as a supported device. I am having the same problem. I can see that the device is connecting to the controller but what isn't happening is that there aren't any topics being created for the device. I see that there are topics under homeassistant but none under zigbee2mqtt. i have confirmed this by looking at both the logs and with MQTT Explorer.

              Comment


                #8
                Confirm that the expected topics are missing from Association tab of mcsMQTT.
                Post the homeassistant/.../config message that describes the bulb.
                Post the message that shows the state that the bulb is reporting.

                Comment


                  #9
                  On the Association tab, there are no topics like this, zigbee2mqtt/0x000d6f0011159f32, for the device that I am trying to add.

                  Zigbee2MQTT:info 2020-11-25 12:05:19: Device '0xccccccfffe8a9c1b' joined
                  Zigbee2MQTT:info 2020-11-25 12:05:19: Starting interview of '0xccccccfffe8a9c1b'
                  Zigbee2MQTT:info 2020-11-25 12:05:19: MQTT publish: topic 'zigbee2mqtt/bridge/log', payload '{"message":{"friendly_name":"0xccccccfffe8a9c1b"},"type": "d evice_connected"}'
                  Zigbee2MQTT:info 2020-11-25 12:05:19: MQTT publish: topic 'zigbee2mqtt/bridge/log', payload '{"message":"interview_started","meta":{"friendly_name":"0 xc cccccfffe8a9c1b"},"type":"pairing"}'
                  Zigbee2MQTT:info 2020-11-25 12:05:25: Successfully interviewed '0xccccccfffe8a9c1b', device has successfully been paired
                  Zigbee2MQTT:info 2020-11-25 12:05:25: Device '0xccccccfffe8a9c1b' is supported, identified as: EcoSmart Tuneable white (A19) (A9A19A60WESDZ02)
                  Zigbee2MQTT:info 2020-11-25 12:05:25: MQTT publish: topic 'zigbee2mqtt/bridge/log', payload '{"message":"interview_successful","meta":{"description":" Tu neable white (A19)","friendly_name":"0xccccccfffe8a9c1b","model":"A9A19A6 0WESDZ02","supported":true,"vendor":"EcoSmart"},"type":"pair ing"}'
                  Zigbee2MQTT:info 2020-11-25 12:05:25: MQTT publish: topic 'homeassistant/light/0xccccccfffe8a9c1b/light/config', payload '{"availability":[{"topic":"zigbee2mqtt/bridge/state"},{"topic":"zigbee2mqtt/0xccccccfffe8a9c1b/availability"}],"brightness":true,"brightness_scale":254,"color_temp":tr ue, "command_topic":"zigbee2mqtt/0xccccccfffe8a9c1b/set","device":{"identifiers":["zigbee2mqtt_0xccccccfffe8a9c1b"],"manufacturer":"EcoSmart","model":"Tuneable white (A19) (A9A19A60WESDZ02)","name":"0xccccccfffe8a9c1b","sw_version": "Zigbee2MQTT 1.16.1"},"effect":true,"effect_list":["blink","breathe","okay","channel_change","finish_effect ","s top_effect"],"hs":false,"json_attributes_topic":"zigbee2mqtt/0xccccccfffe8a9c1b","name":"0xccccccfffe8a9c1b_light","schem a":"json","state_topic":"zigbee2mqtt/0xccccccfffe8a9c1b","unique_id":"0xccccccfffe8a9c1b_light_zi gbee2mqtt","xy":false}'
                  Zigbee2MQTT:info 2020-11-25 12:05:25: MQTT publish: topic 'homeassistant/sensor/0xccccccfffe8a9c1b/linkquality/config', payload '{"availability":[{"topic":"zigbee2mqtt/bridge/state"},{"topic":"zigbee2mqtt/0xccccccfffe8a9c1b/availability"}],"device":{"identifiers":["zigbee2mqtt_0xccccccfffe8a9c1b"],"manufacturer":"EcoSmart","model":"Tuneable white (A19) (A9A19A60WESDZ02)","name":"0xccccccfffe8a9c1b","sw_version": "Zigbee2MQTT 1.16.1"},"icon":"mdi:signal","json_attributes_topic":"zigbee 2mqtt/0xccccccfffe8a9c1b","name":"0xccccccfffe8a9c1b_linkquality", "state_topic":"zigbee2mqtt/0xccccccfffe8a9c1b","unique_id":"0xccccccfffe8a9c1b_linkqual ity_zigbee2mqtt","unit_of_measurement":"lqi","value_template ":"{{ value_json.linkquality }}"}'

                  Comment


                    #10
                    This is the homeassistant discovery topic
                    Code:
                    MQTT publish: topic 'homeassistant/light/0xccccccfffe8a9c1b/light/config', payload '{"availability":[{"topic":"zigbee2mqtt/bridge/state"},{"topic":"zigbee2mqtt/0xccccccfffe8a9c1b/availability"}],"brightness":true,"brightness_scale":254,"color_temp":tr ue, "command_topic":"zigbee2mqtt/0xccccccfffe8a9c1b/set","device":{"identifiers":["zigbee2mqtt_0xccccccfffe8a9c1b"],"manufacturer":"EcoSmart","model":"Tuneable white (A19) (A9A19A60WESDZ02)","name":"0xccccccfffe8a9c1b","sw_version": "Zigbee2MQTT 1.16.1"},"effect":true,"effect_list":["blink","breathe","okay","channel_change","finish_effect ","s top_effect"],"hs":false,"json_attributes_topic":"zigbee2mqtt/0xccccccfffe8a9c1b","name":"0xccccccfffe8a9c1b_light","schem a":"json","state_topic":"zigbee2mqtt/0xccccccfffe8a9c1b","unique_id":"0xccccccfffe8a9c1b_light_zi gbee2mqtt","xy":false}'
                    Zigbee2MQTT:info 2020-11-25 12:05:25: MQTT publish: topic 'homeassistant/sensor/0xccccccfffe8a9c1b/linkquality/config', payload '{"availability":[{"topic":"zigbee2mqtt/bridge/state"},{"topic":"zigbee2mqtt/0xccccccfffe8a9c1b/availability"}],"device":{"identifiers":["zigbee2mqtt_0xccccccfffe8a9c1b"],"manufacturer":"EcoSmart","model":"Tuneable white (A19) (A9A19A60WESDZ02)","name":"0xccccccfffe8a9c1b","sw_version": "Zigbee2MQTT 1.16.1"},"icon":"mdi:signal","json_attributes_topic":"zigbee 2mqtt/0xccccccfffe8a9c1b","name":"0xccccccfffe8a9c1b_linkquality", "state_topic":"zigbee2mqtt/0xccccccfffe8a9c1b","unique_id":"0xccccccfffe8a9c1b_linkqual ity_zigbee2mqtt","unit_of_measurement":"lqi","value_template ":"{{ value_json.linkquality }}"}'
                    There was no subsequent topic reported by the bulb for any type of state or change. The discovery protocol identified the expected topic that mcsMQTT is looking to receive to be
                    "zigbee2mqtt/0xccccccfffe8a9c1b" based upon the declaration "state_topic":"zigbee2mqtt/0xccccccfffe8a9c1b"

                    I would think as a minimum that the bulb would report state when it is powered up.

                    Comment


                      #11
                      I don't see any messages that appear to be reporting state. I did pull out another image that uses Phoscon and everything works there. So it appears to me that zigbee2mqtt is having difficulties with the Conbee II device.

                      Comment


                        #12
                        The zigbee2mqtt forum would be the best place to continue. When I was just getting started with zigbee2mqtt I found the communications to be responsive.

                        Comment


                          #13
                          So I posted much of this on the zigbee2mqtt forum and discord with now response yet.

                          In the mean time, I decided to see how things would work in HASS. No surprise, they worked perfectly. So from my perspective, it looks like zigbee2mqtt is just not creating the proper topics for mcsMQTT.

                          Comment


                            #14
                            From what you posted there we no additional topics after the homeassistant/.../config topics. This would be true for HASS as well if the same test was conducted. Both mcsMQTT and HASS can subscribed to the same broker as zigbee2mqtt so they will both get the same information. If you are using the built in broker in either HASS or mcsMQTT for this then select one or the other as the broker and let the other connect to it. If they are both running on the same computer then setup mcsMQTT to use localhost as the broker. Enable mcsMQTT Debug and collect data in \data\mcsMQTT\mcsMQTT Debug.txt. Control the device via HASS if HASS is able to communicate and see what appears in the Association tab for mcsMQTT. Post the debug file when the test is over.

                            Comment


                              #15
                              Sorry to be a PITA but I have still not gotten this working. I started looking at what happens when using HASS vs Homeseer.

                              I did the following:
                              0. Reset everything
                              1. Started Mosquitto
                              2. $SYS topic was creatred
                              3. Started ZigBee2MQTT
                              4. zigbee2mqtt topic was created
                              5. Turned on a new ZigBee bulb
                              6. zigbee2mqtt went through its process of adding the bulb
                              7. Saw that homeassistant topics were created in the broker
                              8. Started HASS and added mscMQTT
                              9. Device for bulb was created in HASS
                              10. Bullb topic created when I turned the light on/off

                              I did the same steps using Homeseer. At step 8, I see the LWT topic being added to the broker and mcsMQTT picking up the appropriate zigbe2mqtt topics, When I repair the bulb, I see that mscMQTT sees the homeassistant topics but it does not create the associated device.

                              Attached is the mcsMQTT log
                              Attached Files

                              Comment

                              Working...
                              X