Announcement

Collapse
No announcement yet.

HS is recording the value and the status OK, but the device cannot be controlled

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    HS is recording the value and the status OK, but the device cannot be controlled

    Receiving values OK from the device, but I cannot control the device from HS. See details in attachment.
    I would appreciate help!
    Attached Files

    #2
    I believe the Pub topic is zigbee2mqtt/0xa4c138533ddc9cfa/set. I also believe the data is published in JSON format so you will need to setup the pub template as well. While I did some initial testing a few years back with lights and zigbee, the only thing I use zigbee is for sensors that have no control so I would need to research to confirm my beliefs.

    When using zigbee2MQTT I suggest that you set the homeassistant key in the zigbee2mqtt config file to true. It is false by default. This is the first key in the template file provided for configuration for zigbee2MQTT. When set true then zigbee2mqtt will send information on how to setup a device in the automation system. It was designed for HomeAssistant, but I incorporated the same for HomeSeer. This way you will have all the setup done for you automatically, including the desired pub topic.

    The second thing I suggest is that you also edit the zigbee2MQTT config file to give a more friendly name for the zigbee devices. It is hard for a human to understand 0xa4c138533ddc9cfa. Giving it a friendly name will result in topics like zigbee2mqtt/KitchenLight rather than zigbee2mqtt/0xa4c138533ddc9cfa

    In general mcsMQTT creates HS devices when it first see the MQTT topic. If you want the plugin to see a received message as being new then you will want to tell it the the prior observances are now obsolete. This is done from the General tab of the MQTT page or selectively on Association tab. If you are just starting out and have nothing invested in prior zigbee2MQTT setup in HS, then from the General tab enter zigbee2mqtt/# in the text box on the obsolete row. This will give you a clean start with interfacing zigbee2MQTT with HS.

    If you continue to have problems then post again and I will take a deeper look

    Comment


      #3
      Try:

      zigbee2mqtt/FRIENDLY_NAME/set

      or

      zigbee2mqtt/0xa4c138533ddc9cfa/set


      as the publish topic



      https://www.zigbee2mqtt.io/devices/ZB-SW01.html


      To control this switch publish a message to topic zigbee2mqtt/FRIENDLY_NAME/set with payload {"state": "ON"}, {"state": "OFF"} or {"state": "TOGGLE"}.

      To read the current state of this switch publish a message to topic zigbee2mqtt/FRIENDLY_NAME/get with payload {"state": ""}
      HS4, HSTouch Designer, ESP based devices and sensors, Tasmota, OpenMQTTGateway, RTL433, DIY ground plane antenna, BlueIris + LAN cams, USB-UIRT, ATON DLA amp, WACUP, Multiple Android tablets for control.
      Plug-Ins Enabled: Restart:,EnvCan:,EasyTrigger:,CM15A:,BLUSBUIRT:, BLLAN:,BLBackup:,Pushover 3P:,mcsMQTT + multiple Jon00 tools

      Comment


        #4
        Turning on the HomeAssistant did the trick. Thanks!

        Comment

        Working...
        X