No announcement yet.

Hide features on thermostats?

  • Filter
  • Time
  • Show
Clear All
new posts

    Hide features on thermostats?

    Not sure it its the PI or HS causing my issue is, but I have some thermostats integrated with mcsMQTT (via Zigbe2mqtt) that shows all hidden features on the device top bar in grid view (and on HSMobile). On other normal devices (via Z-wave or mcsMQTT) the hidden features is not shown. Is it something special with thermostats?

    Is it PI bug or could it be a general HS issue?

    You are describing a HS4 display design decision. Don't know if intentional or oversight. Seems like HS4 has hard-coded the thermostat type grid view and not honored the hide property.


      I don't know. According to support Z-wave thermostats behave as expected hiding the fatures as requested. Hence they point to the PI I use. I don't have any Z-wave thermostats myself to compare with.

      Note that my units wasn't automatically recognised (HA discovery) as thermostats. I have manually converted them.

      Sent from my SM-G991B using Tapatalk


        Can you post what zigbee2mqtt provides in the homeassistant/.../config messages for the thermostat? These will be in the mcsMQTT Debug log on each restart of the plugin so if you have debug enabled they should already be in \data\mcsMQTT\mcsMQTT Debug.txt

        How did you manually set the DeviceAPI and DeviceType properties to characterize the associated Features as having thermostat properties?

        While I want to create the thermostat from Homeassistant Discovery messages, I do not understand how the Hide property of the Feature(s) are a function anything the plugin does.


          I only find the messages for some of the features eks. load:
          11.07.2022 20:36:02 27396 | ProcessMessage homeassistant/sensor/0x680ae2fffe6ba475/load/config
          11.07.2022 20:36:02 27397 | ActOnMessageForTrigger QueueSize=45 ,Topic homeassistant/sensor/0x680ae2fffe6ba475/load/config,Payload {"availability":[{"topic":"zigbee2mqtt/bridge/state"}],"device":{"identifiers":["zigbee2mqtt_0x680ae2fffe6ba475"],"manufacturer":"ELKO","model":"ESH Plus Super TR RF PH (4523430)","name":"Floorheat_bathroom","sw_version":"4.0"}," enabled_by_default":false,"json_attributes_topic":"zigbee2mq tt/Floorheat_bathroom","name":"Floorheat_bathroom_load","state_ topic":"zigbee2mqtt/Floorheat_bathroom","unique_id":"0x680ae2fffe6ba475_load_zig bee2mqtt","unit_of_measurement":"W","value_template":"{{ value_json.load }}"}
          I change at least the device using a script. The features I believe I change in the device properties in mcsMQTT.