Announcement

Collapse
No announcement yet.

Requirements to STOP auto creating new devices for topics?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Requirements to STOP auto creating new devices for topics?

    I have 4 Intesis devices added, every so often I find TempSetPoint2, TempSetPoint3, TempSetPoint4 have been re-added as devices.

    How do I Stop these from being recreated?

    #2
    There are four setpoints implemented in the plugin so there must be some models that have this capability.

    I believe all you need to do is from the MQTT Page, Association Tab, using the Topic Filter T1 selected Daikin to make only the unit's visible in the table. Click on Show Selected Associations to view them. Find the three items in the table and uncheck the "a" column checkbox. This will remove the association with HS and delete the previously created HS devices.

    Comment


      #3
      Originally posted by Michael McSharry View Post
      There are four setpoints implemented in the plugin so there must be some models that have this capability.

      I believe all you need to do is from the MQTT Page, Association Tab, using the Topic Filter T1 selected Daikin to make only the unit's visible in the table. Click on Show Selected Associations to view them. Find the three items in the table and uncheck the "a" column checkbox. This will remove the association with HS and delete the previously created HS devices.
      I have to Uncheck the 'A' column multiple times. they only get re-added after a couple of days / system restart.

      Comment


        #4
        I believe what is happening is that the General tab setting to remove unassociated topics on shutdown is enabled so on the next start these topics no longer exists, so they are created. What I did was update the plugin to also look at the reject checkbox on association table and not remove the record on shutdown if reject has been set. This update is 5.26.6.6 at mcsMQTT Change Log (HS4 & HS3) - HomeSeer Message Board. Unzip into the \bin\mcsMQTT folder.

        With the update you will check the "r" column checkbox and uncheck the "a" column one. Another approach is to remove the capability to remove the unassociated topics on shutdown which is done on the General tab. If you have modest amount of new MQTT traffic, then this will be fine as well. No plugin update is needed for this second approach.‚Äč

        Comment


          #5
          I've unchecked the remove unassociated topics and will see how that works :-)

          Thanks

          Comment

          Working...
          X