Announcement

Collapse
No announcement yet.

Browser unresponsive.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Browser unresponsive.

    Hi Michael.

    I hope your doing well.

    Over time Associations window has become really slow, chocking and timeout-ing the browser when using dropdowns, clear, rebuild filters. It freezes the browser for about 30sec for each step. It's really hard to work with it.

    Click image for larger version

Name:	mqtt1.jpg
Views:	59
Size:	22.2 KB
ID:	1573977

    Also, I have created a new virtual device and add it to a new Floor, but it would fail to show the floor and also the device, even though I rebuild the filters. Is there any specific setting I need to apply to the device to show up in here?

    Click image for larger version

Name:	mgtt2.jpg
Views:	45
Size:	28.3 KB
ID:	1573978

    Thank you

    Br,
    Dali



    #2
    My best guess is that you are accumulating new topics and letting the Association table become so big that it is cumbersome to manage. You can look at CPU statistics on Task Manager / HTOP or look at the CPU use from the Association table to the HS topic.

    Another issue that is known is the MQTT Internal Broker will get into a high CPU use state under certain conditions. This was addressed with version 6.x.x.x of the plugin.

    In the setttings for MQTT Page, General Tab I have couple suggestions
    1. use checkbox to delete unassociated topics on shutdown. This will remove things that are not of interest and reduce the processing burden
    2. The Topic Discovery setting default is to discover all new topics. This is good for initial setup, but should be change to the second radio position to only listen to associated topics. You can go back and forth between the two settings when you have a new device introduced into your system.
    3. Bluetooth, unless filtered, introduces heavy burden. If you are using Bluetooth then the same guidance as item 2 should be used, but with settings on the Local Page, Bluetooth settings.

    Comment


      #3
      Thank you for reply, Michael.

      I did 1,2. I don't use any Bluetooth. You say 6.x.x.x version? The one I have is 5.26.5.4 and HS4 Plugin Manager it will show no updates available.

      Click image for larger version

Name:	mgtt3.jpg
Views:	46
Size:	14.2 KB
ID:	1574011

      Br,
      Dali

      Comment


        #4
        Yes, I found version 6.0.0.1

        http://mcssprinklers.com/HSPI_mcsMQTT_6_0_0_1.zip.

        I did install it successfully by the instructions here:
        https://forums.homeseer.com/forum/hs...ge-log-hs4-hs3

        What I got was version 6.0.0.0 with an update option.

        Click image for larger version

Name:	mgtt4.jpg
Views:	45
Size:	16.8 KB
ID:	1574013

        but when I update it seems it works but I get the same 6.0.0.0 version

        Click image for larger version

Name:	mqtt5.jpg
Views:	38
Size:	31.3 KB
ID:	1574014



        Click image for larger version

Name:	mgtt4.jpg
Views:	38
Size:	16.8 KB
ID:	1574015

        Click image for larger version

Name:	mqtt6.jpg
Views:	37
Size:	66.4 KB
ID:	1574016



        Comment


          #5
          I made certain the updater override file in the zip was for 6.0.0.1 and confirmed the install using this extracted file. I suspect the link to the 6.0.0.1 file is actually to the 6.0.0.0 file as I just edited the name when I changed from 6.0.0.0 to 6.0.0.1. I recreated the link so you can try again.

          Click image for larger version

Name:	Capture.jpg
Views:	39
Size:	9.6 KB
ID:	1574088

          Comment


            #6
            Now it works! Perfect.

            It's also very smooth. No browser chocking anymore.

            Thank you

            Br,
            Dali

            Comment

            Working...
            X