Announcement

Collapse
No announcement yet.

MNS Insteon Beta 4.0.4.10

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    MNS Insteon Beta 4.0.4.10

    Changes
    • Fixed MS II programming messages (4.0.4.1)
    • Revised Ballast Dimmer support (4.0.4.1)
    • Added status/graphics for Smoke Bridge (4.0.4.2)
    • Improve insteon.ini stability (4.0.4.2)
    • Added local port list to Interface Port field (4.0.4.2)
    • Fixed issue when deleting a group that affected the display of the Group controller (4.0.4.4)
    • Changed Group Number display to match Group:# address on HS device (4.0.4.4)
    • Changed group cleanup option to a per group setting (4.0.4.6)
    • Revised Groups management page to include sorting and separate Location value (4.0.4.6)
    • Changed Remotelinc2 configuration to support dimming triggers (4.0.4.7)
    • Fixed Group selection UI feature (4.0.4.7)
    • Fixed Ramp Down trigger configuration (4.0.4.8)
    • Revised Ramps trigger device list(4.0.4.9)
    • Revised Interface Port available ports display (4.0.4.9)
    • Moved the statistics to a new insteon_stats.ini file (4.0.4.10)
    • Improved insteon.ini stability and reliability (4.0.4.10)

    To Install a Beta
    1. Backup your current setup. see the HS Tools/Backup page
    2. Disable the current plugin on the Plugins/Manage page
    3. Go to the HS Plugins/Add page
    4. Enable the Show Beta Plugins option
    5. Search for Insteon
    6. Select the MNS Insteon Beta, then click Install
    7. if you get an error, restart HS4 first and then try again
    Note: you may install the beta over the existing version.
    Mark

    HS3 Pro 3.0.0.534
    Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
    Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
    Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

    #2
    Mark,

    I installed the beta and reinstalled all my devices. So far it seems to be good. I've had to reboot my HomeTroller several times (for unrelated reasons) and all my devices seem to be holding steady.

    Bill

    Comment


      #3
      Originally posted by xlucent View Post
      Mark,

      I installed the beta and reinstalled all my devices. So far it seems to be good. I've had to reboot my HomeTroller several times (for unrelated reasons) and all my devices seem to be holding steady.

      Bill
      Hey Bill,

      after a backup, would you be willing to just pull the power plug on the hometroller and see if everything is still working after a restart?

      also, i would recommend the following event to help make backups after config changes. these are both insteon options

      Click image for larger version  Name:	backup event.png Views:	0 Size:	7.4 KB ID:	1559600
      Mark

      HS3 Pro 3.0.0.534
      Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
      Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
      Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

      Comment


        #4
        Originally posted by mnsandler View Post

        Hey Bill,

        after a backup, would you be willing to just pull the power plug on the hometroller and see if everything is still working after a restart?

        also, i would recommend the following event to help make backups after config changes. these are both insteon options

        Click image for larger version Name:	backup event.png Views:	0 Size:	7.4 KB ID:	1559600
        Hi Mark,

        I unplugged the HomeTroller, waited 30 seconds and plugged it back in. Once it rebooted, I checked the MNSInsteon plugin and everything is fine. Did some comm tests to be sure and they were all 100%.

        I created that event the other day when I did the last reinstall of the HomeTroller system and it's been working great.

        Thanks for all your help with this, Mark.

        Bill

        Comment


          #5
          Originally posted by xlucent View Post

          Hi Mark,

          I unplugged the HomeTroller, waited 30 seconds and plugged it back in. Once it rebooted, I checked the MNSInsteon plugin and everything is fine. Did some comm tests to be sure and they were all 100%.

          I created that event the other day when I did the last reinstall of the HomeTroller system and it's been working great.

          Thanks for all your help with this, Mark.

          Bill
          You are welcome. thanks for testing, and reporting back. you can confirm the insteonX.ini backup files in the hs config folder at somepoint
          Mark

          HS3 Pro 3.0.0.534
          Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
          Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
          Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

          Comment


            #6
            Originally posted by mnsandler View Post

            You are welcome. thanks for testing, and reporting back. you can confirm the insteonX.ini backup files in the hs config folder at somepoint
            Mark,

            Just checked and all the InsteonX.ini backups are in the HomeSeer/config folder.

            Bill

            Comment


              #7
              Mark - I like your "backup event" suggestion- seems like a good idea. Thanks for posting.

              Comment


                #8
                mrceolla, I changed the 'group cleanup' global Setting to a per group option/checkbox on the plugin Groups page. I would appreciate your feedback.
                Mark

                HS3 Pro 3.0.0.534
                Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
                Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
                Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

                Comment


                  #9
                  Originally posted by mnsandler View Post
                  mrceolla, I changed the 'group cleanup' global Setting to a per group option/checkbox on the plugin Groups page. I would appreciate your feedback.
                  That is awesome! Thank you very much! Unfortunately I am not on the HS4 version of your plugin yet. Summer has been busy so I was planning to make that switch in the fall. My apologies.

                  I think Burrington expressed interest in this too. Are you on the HS4 version yet?
                  HS4, Insteon, Z-wave, USB-UIRT, Google Hub/Chromecasts/Speakers, Foscam & Amcrest cameras, RCA HSDB2a doorbell
                  Plugins: BLLAN, BLOccupied, BLUSBUIRT, Chromecast, Harmony Hub, Insteon, Jon00 Homeseer/Echo Skill Helper, Jon00 DB Charting, MediaController, NetCAM, PHLocation2, Pushover 3P, weatherXML, Z-wave

                  Comment


                    #10
                    Mark-can you clarify exactly what the Group cleanup option does, or more specifically why it would best be turned on or off?

                    From the existing documentation:
                    Perform group clean-ups when transmitting group commands After a group message is sent from the plugin, individual message are sent to each member of the group to ensure they heard the group message.

                    What happens after the ’individual’ message is sent? Does MNS attempt to correct the issue if a Device did not hear the Group message?

                    What are pros and cons of having this enabled for all/some Groups?

                    Is this a Insteon supported feature (developer notes), or something programmed specifically for MNS?

                    Comment


                      #11
                      the group clean is an protocol feature but must be initiated via code so it can be optional.

                      its to help update the hs devices with the correct status based on if the device responded to the initial group cmd. you can see the various messages in the log.

                      the con is its puts a burden on the network with all the extra traffic; hence the new ability to turn it off for some groups (maybe ones with a lot of participants)
                      Mark

                      HS3 Pro 3.0.0.534
                      Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
                      Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
                      Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

                      Comment


                        #12
                        Originally posted by mnsandler View Post
                        the group clean is an protocol feature but must be initiated via code so it can be optional.

                        its to help update the hs devices with the correct status based on if the device responded to the initial group cmd. you can see the various messages in the log.

                        the con is its puts a burden on the network with all the extra traffic; hence the new ability to turn it off for some groups (maybe ones with a lot of participants)
                        Thank you for the clarification, helpful. I haven't specifically noticed any Insteon concerns that I would definitely attribute to excess traffic, but that's good to know.

                        4.0.4.6 is running well for me, no issues thus far. Would be nice to have consistency by adding the Location column to the MNS Devices page, and remove the location prepended to the Device Name.

                        Comment


                          #13
                          Originally posted by Steveo369 View Post

                          Thank you for the clarification, helpful. I haven't specifically noticed any Insteon concerns that I would definitely attribute to excess traffic, but that's good to know.

                          4.0.4.6 is running well for me, no issues thus far. Would be nice to have consistency by adding the Location column to the MNS Devices page, and remove the location prepended to the Device Name.
                          thanks for the feedback. I will put the device Location column on the list.
                          Mark

                          HS3 Pro 3.0.0.534
                          Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
                          Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
                          Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

                          Comment


                            #14
                            In an effort to improve the reliability of the insteon.ini, I moved saving the device stats to a new insteon_stats.ini file.

                            i had to make a lot of underlying changes to support two different ini files.

                            please make sure you make a backup before installing the beta so you can roll back if necessary.
                            Mark

                            HS3 Pro 3.0.0.534
                            Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
                            Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
                            Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

                            Comment


                              #15
                              please keep tabs of the following
                              the stats continue to get saved to the new file
                              if you add or delete a device via the plugin pages, the existing devices aren't affected.
                              Mark

                              HS3 Pro 3.0.0.534
                              Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
                              Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
                              Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

                              Comment

                              Working...
                              X