No announcement yet.

HS4 Doesn't Allow for SmartThings Button Button Push Events

  • Filter
  • Time
  • Show
Clear All
new posts

    HS4 Doesn't Allow for SmartThings Button Button Push Events

    Today, I upgraded to HS4 because I have some SmartThings devices that I want to incorporate into my home automation processes. I was able to add a SmartThings Button and a SmartThings Multipurpose Sensor. Both of these sensors report battery level and temperature, and the Button reports three types of button pushes (press, double press, and long press) and the Multipurpose sensor reports door open and close. Everything on the Multipurpose sensor worked great, but only battery and temperature are supported in the Zigbee plugin for the Button. So I can use my Button as a temperature reporting device, but I can't use it as a button. Does anyone have a solution for this (I presume the device states are defined in a configuration file somewhere).

    Thanks very much!



    First, from the Zigbee > Settings page enable "ZigbeeNet Logging", "Log To File", and set "File Log Level" to Trace then save
    Then from Zigbee > Manage devices page click on each device and delete them. Then re-add them.
    Then please send me the file Logs/Zigbee.txt as well as the directory Data/ZigbeeData.json


      Yesterday, I installed the latest beta (I don't remember what it was), and my Zigbee-related events went nuts. Lights were switching on and off and back on again, seemingly out of control. I was forced to disable these events and restart my hub.

      Today, I installed, and my Zigbee-related events now seem to work. However, I still have two problems:
      1. I still cannot process Button Push events for my SmartThings Button
      2. This error was logged: Error during the notification of commandListeners. "System.NullReferenceException: Object reference not set to an instance of an object. at HSPI_Zigbee.ClusterMapping.PowerConfigurationClusterMapping. AttributeUpdated (ZigBeeNet.ZCL.ZclAttribute attribute, System.Object value) [0x0004e] in :0 at ZigBeeNet.ZCL.ZclCluster.NotifyAttributeListener (ZigBeeNet.ZCL.ZclAttribute attribute, System.Object value) [0x00015] in :0 at ZigBeeNet.ZCL.ZclCluster.UpdateAttribute (System.UInt16 attributeId, System.Object attributeValue) [0x00072] in :0 at ZigBeeNet.ZCL.ZclCluster.HandleAttributeReport (System.Collections.Generic.List`1[T] reports) [0x0001e] in :0 at ZigBeeNet.ZigBeeEndpoint.CommandReceived (ZigBeeNet.ZCL.ZclCommand command) [0x000a7] in :0 at ZigBeeNet.ZigBeeNode.CommandReceived (ZigBeeNet.ZigBeeCommand command) [0x00045] in :0 at ZigBeeNet.Internal.ZigBeeCommandNotifier+<>c__DisplayClass5_ 1.b__0 () [0x00000] in :0 "
      I'd REALLY like to be able to use my SmartThings Buttons. Please? I've been really patient!



        I have several Zigbee Samsung Smartthings devices that I am trying to pair with the Zigbee plugin ( for HS4 without success. I have tried a button and an outlet (square type).
        Neither one will pair with the plugin. I have tried each about 12 times with no luck. I have several other zigbee (not Samsung) devices that are working fine. Are these Samsung Zigbee devices compatible? Has anyone got these to work? I also tried a Samsung arrival sensor with no luck. Are their some Zigbee devices that are compatible and some that are NOT? It would be helpful to know what spec's to look for when purchasing new Zigbee devices.
        Any feedback would be helpful.



          I have a bunch of smartthings buttons and water sensors. I use the jowihue plugin though for zigbee. They work great with hs4