Announcement

Collapse
No announcement yet.

Update to 4.2.1.0 failed

Collapse
This topic is closed.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Update to 4.2.1.0 failed

    Tried to upgrade from v4.2.0.10 to v4.2.1.0 this evening and it failed:

    "Installation of package Honeywell WiFi Thermostat failed. Try disabling the plugin first, then re-try the update."

    Click image for larger version

Name:	image.png
Views:	129
Size:	29.7 KB
ID:	1585082

    The problem is, the plugin no longer appears on my Homeseer Plugins page (under Manage). And if I try to install the plugin from the store I get the same error.

    #2
    Found this in my log:

    HomeSeer Updater: Package file not found: /usr/local/HomeSeer/Updates4/Honeywell WiFi Thermostat4.2.1.0/debug-list.html

    Comment


      #3
      Same here... Good thing I snapshotted the VM first...

      Comment


        #4
        Looks like the file is named debug_list.html and something is looking for debug-list.html (underscore vs. dash).

        Comment


          #5
          Looks like install.txt is the culprit. I tried fixing it but don't know how to get HS to use the locally installed update instead of downloading it again from the store with the bad file.

          Comment


            #6
            Originally posted by windracer View Post
            Looks like install.txt is the culprit. I tried fixing it but don't know how to get HS to use the locally installed update instead of downloading it again from the store with the bad file.
            I had the same error, I just restarted HS and the update was installed and working

            Comment


              #7
              Originally posted by windracer View Post
              Tried to upgrade from v4.2.0.10 to v4.2.1.0 this evening and it failed:

              "Installation of package Honeywell WiFi Thermostat failed. Try disabling the plugin first, then re-try the update."

              Click image for larger version

Name:	image.png
Views:	129
Size:	29.7 KB
ID:	1585082

              The problem is, the plugin no longer appears on my Homeseer Plugins page (under Manage). And if I try to install the plugin from the store I get the same error.
              That's a strange behavior because one HTML file was named wrong - sorry about the typo, though!

              4.2.1.1 has been submitted to correct that issue.

              Comment


                #8
                Originally posted by goldriver View Post
                I had the same error, I just restarted HS and the update was installed and working
                Ha, thanks. I rebooted my Homeseer Pi and sure enough the new plug-in was installed and working. Should have thought to try that.

                Comment


                  #9
                  Closing this issue as resolved.

                  Comment

                  Working...
                  X