No announcement yet.

Can't get House Designer step to work

  • Filter
  • Time
  • Show
Clear All
new posts

    Can't get House Designer step to work

    Had no problem uploading images and starting plugin, but when I get to House Designer step, the floorplan selected (8 bit PNG, 56kb) doesn't show up on the screen below the dropdowns. Suggestion?


    That's curious. Here's a couple of things to try:
    - Try a different image
    - Try a different web browser.

    That being said: Would you mind sending me this image plus the type and version of the web browser you're using? In addition, it would be super interesting for me to see your browser javascript console log (Right click page -> inspect -> Console on Google Chrome).

    It's in everybody's best interest that this works on as many platforms as possible, so ironing out these interoperability problems is very nice


      Yes, I can share those things. Will do so shortly.

      I tried to save image as jpeg as well, but that made it bigger and HS would not upload it. I tried in both Chrome and Edge browser. Might the dimensions of image matter? It's currently saved as same screen resolution as ipad. I could make smaller to test out if that works?


        Here is from Edge:

        house-designer.html:578 Uncaught TypeError: Cannot read property 'FileName' of undefined
        at imageForName (house-designer.html:578)
        at loadConfig (house-designer.html:625)
        at house-designer.html:631
        DevTools failed to load SourceMap: Could not parse content for http://MYIP/Simmap/ Unexpected token < in JSON at position 0
        DevTools failed to load SourceMap: Could not parse content for http://MYIP/bootstrap/js/ Unexpected token < in JSON at position 0
        DevTools failed to load SourceMap: Could not parse content for http://MYIP/sm/b0ce608ffc029736e9ac8...92043deb2214aa Unexpected token < in JSON at position 0
        DevTools failed to load SourceMap: Could not parse content for http://MYIP/bootstrap/js/ Unexpected token < in JSON at position 0
        DevTools failed to load SourceMap: Could not parse content for http://MYIP/bootstrap/css/ Unexpected token < in JSON at position 0


          Thank you very much! I see the problem. I will get right on patching that. It's a pretty dumb mistake on my part (I have not tested the plugin without any pre-existing setup for some time)

          Now, since the approval process for a new plugin version will take some time (a day or three); Would you be interested in receiving a patched file to insert into a particular place (HomeSeer\html\Simmap\house-designer.html) to get rid of the issue the moment I have a working patch?

          EDIT: After reproducing the bug on my side I've patched the issue, verified that the designer works as intended and uploaded a new plugin version.


            Downloaded the update, and designer now shows the floorplan images and I can add icons. When I add an icon, nothing populates in the "View" or "Control" dropdowns. I'm able to save and see the icon on the map in "Controller" page, and a slider pops up, but the light is not controlled.


              Great! That's progress.

              The view and control selectors are only populated with the features belonging to the chosen device. That means you probably want to select a device first (topmost unlabeled dropdown).


                Right. It doesn't matter what device I choose, nothing shows up in View or Control drop downs.

                Another note, the device list on icon selection pop up on designer page is not seemingly organized for me, alphabetically or otherwise.

                Otherwise, nice work thus far! It's a perfect implementation for setting up a screen for wife, kids, & guests who might just need to control a couple things and can just click a picture. Planned on doing something like this in HStouch at some point but just haven't gotten around to it.


                  Good point about that ordering. The ordering right now (I think) is the order the devices was added to HS. I'll sort them for you in the next version. As a developer, it is quite hard to see flaws with your own stuff, so feedback like this is great!

                  I need more information about your setup to fix the issue you are seeing. Right click the page and select "Show source". Halfway down the page source, you'll see your HS configuration. It looks like this:
                  HTML Code:
                  <script type="module">
                  import {addIcon, makeInteractable, setImageOnElement} from './editor.js'
                  var floorPlanImage;
                  var config = { ... };
                  var knownDevices = {...};
                  var savedImages = [....];
                  var imageTable = {};
                  What I'm interested in is that line named knownDevices. It contains all the devices known by HS, plus all the features of aformentioned devices. If the list of everything connected to your HS is something you're not comfortable in sharing, that's fine, but I'd really like to know if the data inside there contains features. The structure should be a repeating pattern of:
                  HTML Code:
                  "<number>":{"DeviceName":"<Some name>","Features":{"<number>":"<Name>", ...}}
                  If there is nothing inside that "Features" bracket for every one of your devices, we have a problem, and I need to bug some HS developers for help regarding why their software does not yield any info back to us. If there is something inside the Features brackets, I have a bug to fix, and if so it would be super helpful to receive at least one sample feature list from you. Additionally, if you upgraded from HS3 to HS4, it might help to delete and re-add a device. Feel free to try that if you'd like.

                  In addition, that javascript log you sent last time was such great help that I would really appreciate receiving it again, if there are any errors in it (red lines)

                  Thank you for sticking with me thus far!


                    I restarted and now I do see some devices control available. Some are not. I will look through and see if some pattern of ones that don't show Control options.

                    I did upgrade from HS3 to HS4 so will see if that might be something.


                      Ok, the majority of devices not showing features are light switches from Lutron Caseta plugin (However, the "home / away" feature of the Caseta plugin DOES have features). Additionally, in the HTML script, the "Features" are missing for these lights. I think it has to do with the way Caseta plugin added to HS4, before the new device setup in HS4, because if I choose an individual light switch, under the features tab in HS4, it shows "
                      No extra features for this device"

                      Another device not showing options is a door lock, and I know for sure I added it early on. I don't want to delete and re-add today though, because it can be a pain to re-pair w/ z-wave since I may have to take off the lock from the door to do so.

                      One more note, I notice a couple devices aren't listed at all. All have to do w my garage.

                      **Edit: In Caseta plugin, I re-grouped all the devices and now the lights show as a feature. The control part doesn't work yet, however.


                        To supply an update of what I've learned recently:

                        Your first issue is probably a case of the HS devs removing functionality in the migration from HS3 to HS4. In HS4, devices without features are no longer an acceptable way of doing things (as a plugin author), and hence support for it in the official SDK is removed. I will keep looking into a workaround; sounds like something that will be commonly encountered by people. For reference, a post I made in another part of the forum regarding this:

                        The second issue is most definitely the same issue encountered by brientim here:
                        I patched the issue where the plugin failed to start when it encountered these invalid devices by making it ignore them instead. The issue is cleared by deleting and re-creating the devices for now, but the root cause is tracked here:

                        TL;DR: Both issues have root causes in the fact that HS4 doesn't seem to be very stable yet. Will keep on looking for a workaround.