Announcement

Collapse
No announcement yet.

New to this and trying out plugin

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #31
    Tried it out today on new version, i was able to delet old icons and upload new ones to the image uploader, and I added them to the designer and save each time. When I go to the controller now its blank and does not show the icon I added.

    Click image for larger version

Name:	image uploader 9 3 2021.PNG
Views:	60
Size:	67.8 KB
ID:	1493342Click image for larger version

Name:	House designer 9 3 2021.PNG
Views:	53
Size:	297.5 KB
ID:	1493343Click image for larger version

Name:	House controller blank 9 3 2021.PNG
Views:	52
Size:	310.4 KB
ID:	1493344

    Comment


      #32
      If something is not shown, the best bet is to have a look at that console we found so helpful before. Mind bringing it back up and sending a screenshot my way?

      I am stunned by how many bugs you have found in a row though. I have been using this stuff for the better part of a year without finding anything. Have you considered a career in software QA? 😀

      Comment


        #33
        Why me, oh well there was over 700 lines in the script I dont know if you wanted it all or just from the loader. I have attached a screen shot and a pdf of the lines of info.

        [ATTACH]n1493661[/ATTACH]

        Click image for larger version

Name:	house-controller debug.PNG
Views:	43
Size:	407.9 KB
ID:	1493662

        Comment


          #34
          The console is different from the network tab. You can get to the console by doing:

          Command+Option+J (Mac) or Control+Shift+J (Windows, Linux, Chrome OS)

          That being said, I can venture a guess as to what is wrong: are any of the icons added missing the "view" or the "control" feature when they were created using the house designer?

          Comment


            #35
            no they are there here are the screens.

            Click image for larger version

Name:	Control consol empty.PNG
Views:	45
Size:	385.7 KB
ID:	1493688

            Click image for larger version

Name:	House design 9 5 2021.PNG
Views:	48
Size:	326.9 KB
ID:	1493689Click image for larger version

Name:	image uploader 9 5 2021.PNG
Views:	47
Size:	220.4 KB
ID:	1493690

            Comment


              #36
              Hello, I downloaded the new update and things seem to be much better. The only problem I have is that I cannot get anything to turn on or off after adding the icon. Both the view and control are blank. I found out the reason some of my stuff wont work, any Zwave devices I try to use will not let me select the view or control they are blank. The TP link devices and other devices seem to work it seems to be the Zwave that has a problem. It is starting to look good with the floor layout now, just wish I could get lights and switches to work with zwave devices, any more ideas? Also is there anyway to make it if you hoover over the icon it tells you what it is? maybe can add later on.
              Thank You for all the hard work.

              Comment


                #37
                I had things working and after I added another icon for lights it stopped showing the correct status in the House controller page. It only shows all the lights on and they never turn off. Any ideas what happened?

                Comment


                  #38
                  Well, if something broke, I bet the console can tell :-)

                  Regarding the z-wave devices: I had to do quite a bit of reloading of those to get them to work, since their setup was migrated from HS3. Some of them I even had to delete from HS and re-add, some got fixed just by clicking randomly in the z-wave controller screen to retrieve the device settings once more and so on. I do know for sure that pretty much all z-wave devices should work with this plugin though, but migrating stuff from HS3 makes life difficult

                  Comment


                    #39
                    All of my zwaves are new with this HS4 unit. I will play with them and redo my lights. Thanks Here is a copy of the error after I removed my switches and should have a clean floorplan, but Red X are in all old locations. Click image for larger version

Name:	Controller after lights removed 9 14 2021.PNG
Views:	24
Size:	291.4 KB
ID:	1495919

                    Comment


                      #40
                      Got past the previous error and deleted the ini files and restarted. The Home controller worked ok for one day showing the status and turning lights off/on from controller then it stopped. It now changes and toggles the icons betwee two different screens. Any ideas

                      Click image for larger version  Name:	9 16 2021 controller status off.PNG Views:	0 Size:	345.8 KB ID:	1496356
                      Click image for larger version  Name:	9 16 2021 controller status after clicking on switch.PNG Views:	0 Size:	327.4 KB ID:	1496357
                      Click image for larger version

Name:	9 16 2021 designer.PNG
Views:	29
Size:	431.6 KB
ID:	1496358

                      Comment


                        #41
                        Havent heard from you but what I found out is that if you put an icon on the designer and it is wrong or wont work, then it messes up all the working icons. I still have not been able to display values or zwave. Here is my latest floorplan. Click image for larger version

Name:	Simmap floorplan 9 25 2021.PNG
Views:	26
Size:	337.5 KB
ID:	1498641

                        Comment


                          #42
                          Sorry for going dark for a week

                          I finally found some time to play with this plugin, so I just submitted a new version. While the release notes are in the update, the new version should:
                          - Ensure that icons added in the designer get automatically removed when you delete the image associated with the icon
                          - Adds the option to add status text to your icons. I use it for my thermostats in my floor plan, but it can probably also be used for sensors and so on as well.
                          - Slight performance increase. I noticed that the controller did way too much polling of the server, so that is throttled significantly in this release.

                          Comment


                            #43
                            Great news to hear. I will be waiting for the update, I have been creating icons with my own text so being able to add the text will save a bunch of time that will be a great help. Really likeing the plugnin. Thanks for your help.

                            Comment


                              #44
                              Great update, things do operate much quicker when pressed. I also found a couple of things that could be revised. 1)The text size and color would be great. 2) There is no place to select text on the right side. When using status text all icons on page shift to the right left or top or bottom even though they may not have any text. The text boxes dont always show up locally in chrome or Microsoft edge but do in Firefox.

                              Click image for larger version  Name:	Controller update 3 0 icons no text shift 9 29 21.PNG Views:	0 Size:	438.2 KB ID:	1499503
                              Click image for larger version  Name:	Controller update 3 0 icons shift 9 29 21.PNG Views:	0 Size:	314.5 KB ID:	1499504

                              Comment

                              Working...
                              X