Announcement

Collapse
No announcement yet.

Canadian Weather - Environment Canada

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • alexbk66
    replied
    Originally posted by MikeO3 View Post
    Ok, I will do that. These changes survive future updates to the PI?
    Sure, unless you delete the device - it will then be recreated

    Leave a comment:


  • MikeO3
    replied
    Originally posted by alexbk66 View Post
    You can change the text yourself if you click on the device, select Status/Graphics, then click Edit for "Unknown" row
    Ok, I will do that. These changes survive future updates to the PI?

    Leave a comment:


  • alexbk66
    replied
    You can change the text yourself if you click on the device, select Status/Graphics, then click Edit for "Unknown" row

    Click image for larger version

Name:	2021-09-29 (4).png
Views:	23
Size:	60.3 KB
ID:	1499451

    Leave a comment:


  • MikeO3
    replied
    Frequently Precipitation or other values come back as Unknown from EnvCan. It appears to be a response to NIL, 0 or negative values. In any case is it possible to replace the string Unknown with NA (as in not available)? The image can stay the same as ? as the value is unknown.

    The following is common in the log and possibly be related to the unknown value condition?
    9-28-2021 16:35:15 AK Weather Warning [1106] Ajax-EnvCan: findd(pcpn_amt_pst24hrs) 'MSNG': Input string was not in a correct format.
    9-28-2021 16:35:15 AK Weather Warning [1106] Ajax-EnvCan: findd(max_wnd_gst_spd_10m_pst10mts) 'MSNG': Input string was not in a correct format.

    Click image for larger version

Name:	Capture - Copy.PNG
Views:	55
Size:	46.9 KB
ID:	1499299


    Source:
    https://weather.gc.ca/city/pages/on-117_metric_e.html


    Version=HS4 Standard Edition 4.2.0.0 (Windows)
    Plugins Installed=AK Weather 4.0.1.31,HS MyQ 4.0.7.0,Z-Wave 3.0.7.0,Z-Wave UI 1.0.0.0

    Leave a comment:


  • alexbk66
    replied
    Originally posted by cd36 View Post
    I just installed this plugin to test out. Looks great, two small quirks though:

    I don't seem to be able to get the drop down list of locations that you guys are showing. Mine just says "Station list is empty" then underneath it I have a Can_Weather Station field where I can manually enter in a station. For example if I enter CPOY-AUTO, it does pull up Cypress River for me, but your previous screenshots are showing a drop down list, which I seem to be missing.

    It seems hit or miss with the ° symbol. For instance:

    12°C - 23 ??C, Sunny. Becoming a mix of sun and cloud this afternoon. High 23. UV index 6 or high.

    23$%0$ Mostly Cloudy (33 m ago)

    Both of those are taken from a device created by the plugin. Sometimes it properly shows the ° symbol, but more often then not it does not.

    Is it possible to add multiple locations to grab weather from? When I select the "Add new location" slider, then hit save, it just overwrote my first location. Is that intended or should it be creating a second location for me?
    It's three separate issues in your question, so I created three separate topics for them, otherwise it will be total mess discussing them in single thread:

    https://forums.homeseer.com/forum/hs...t-of-locations
    https://forums.homeseer.com/forum/hs...-%C2%B0-symbol
    https://forums.homeseer.com/forum/hs...b-weather-from

    Leave a comment:


  • cd36
    replied
    I just installed this plugin to test out. Looks great, two small quirks though:

    I don't seem to be able to get the drop down list of locations that you guys are showing. Mine just says "Station list is empty" then underneath it I have a Can_Weather Station field where I can manually enter in a station. For example if I enter CPOY-AUTO, it does pull up Cypress River for me, but your previous screenshots are showing a drop down list, which I seem to be missing.

    It seems hit or miss with the ° symbol. For instance:

    12°C - 23 ??C, Sunny. Becoming a mix of sun and cloud this afternoon. High 23. UV index 6 or high.

    23$%0$ Mostly Cloudy (33 m ago)

    Both of those are taken from a device created by the plugin. Sometimes it properly shows the ° symbol, but more often then not it does not.


    Is it possible to add multiple locations to grab weather from? When I select the "Add new location" slider, then hit save, it just overwrote my first location. Is that intended or should it be creating a second location for me?

    Leave a comment:


  • alexbk66
    replied
    Yeah, both CWZT and CYDN use forecast site s0000508, and similar distance from your location 5564 and 5659 m.

    Click image for larger version  Name:	Screenshot 2021-06-06 130255.jpg Views:	0 Size:	33.4 KB ID:	1478170

    Leave a comment:


  • mbdirtfarmer
    replied
    BTW, tested going back to CWZT-AUTO and forecast station ID stayed same and timestamp updated on forecast devices. All seems fine.

    Leave a comment:


  • mbdirtfarmer
    replied
    Updated to 4.0.0.55

    Initially after update, no Forecast Devices when station was CWZT-AUTO. I changed the Can_Weather station to CYDN-AUTO and Alerts and Forecast all populated.

    Looks real good! Good work. I bet that was a bit of a challenge.

    Leave a comment:


  • alexbk66
    replied
    Ver 4.0.0.55 - install updated stations mapping file

    Should show the correct forecast site id. Note that the second distance (5 km) is from the observations station, not the current location. In some remote areas it can be quite big.

    Click image for larger version

Name:	Screenshot 2021-06-06 102536.jpg
Views:	45
Size:	18.4 KB
ID:	1478123

    Leave a comment:


  • alexbk66
    replied
    hmm, I'll check. It doesn't seen to find forecast station...

    Leave a comment:


  • mbdirtfarmer
    replied
    Click image for larger version

Name:	image_102290.png
Views:	48
Size:	223.2 KB
ID:	1478037



    Click image for larger version  Name:	2021-06-05 13_00_35-Devices.png Views:	0 Size:	394.6 KB ID:	1478038

    Leave a comment:


  • mbdirtfarmer
    replied
    Deleted my Location.
    Updated plugin
    Added Provider Saved
    It only created the current condition devices - no alerts or forecast
    I went back in and adjusted forecast from 2 days to 3 and enabled log and saved
    still no forecast and no warnings regarding device creation in the logs


    Last edited by mbdirtfarmer; June 5, 2021, 01:13 PM. Reason: -edited to delete attachments

    Leave a comment:


  • mbdirtfarmer
    replied
    Thanks Alex. I will delete location then update and test.

    I will be in Air Conditioned comfort cause its a crazy early HEAT WAVE here in the great white north eh.

    Leave a comment:


  • alexbk66
    replied
    Please also note, the forecast has short and long strings, to select which one is used I added "Use abbreviated forecast string" setting (default Off)

    Also, I added language selection setting (En/Fr)

    Leave a comment:

Working...
X