Announcement

Collapse
No announcement yet.

Double Child Devices

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • alexbk66
    replied
    We are going in circles

    1. The warning is normal, it's just an info to show what station is selected
    2. The Alarm devices are created dynamically when Alert happens, except for one main Alert device. I'm not sure how to improve it, I don't want to create too many devices, for some providers Alerts are not even available. Probably the best option is to have config switch to force creating Alert devices
    3. The problem you had before (with duplicated Alert devices) - was caused exactly by dynamic nature, you had some new alert and plugin tried to create new devices, and half way there was some HS exception, so device creation wasn't completed properly. It's hard to catch it, I'll try to reproduce it.

    Every HS update adds more exceptions which causes more problems

    Leave a comment:


  • cowinger
    replied
    Originally posted by alexbk66 View Post
    I mean - what HS version? Is it happening after update to 4.1.17.0?

    Any errors in the log?

    [EDIT]

    From the screenshot it looks like it only happens for Alert devices? I think you had some issue with Alert devices before?

    I need to know the Addresses of these devices. Can you please enable "Show Device Address on Device List Page" on Setup => Custom.
    Yes I am on HS 4.1.17.0 and 4.0.0.61 of your PI. I deleted the plugin and all devices. Re-installed plugin and filled in all info and everything seems to have come in correctly. Not sure what happened.

    EDIT: There used to be a second set of child devices that was like this 3109ef952c.Alert.0.alert but now I only have 1 set of child devices that have 3109ef952c.alert. No Alert Info and others.

    Click image for larger version  Name:	pic1.png Views:	0 Size:	456.5 KB ID:	1480350

    No errors in the log just a warning , but seen it before

    Code:
    6/20/2021 9:44:50 AM 
    AK Weather 
    Warning 
    [4448] Home: Zone (3x.96243,-1xx.806036): 'KFTG', forecast zone 'COZ040' (North Douglas County Below 6000 Feet/Denver/West Adams and Arapahoe Counties/East Broomfield County) (KAPA,KBJC,KBKF,KCFO,KCOS,KFNL,KGJT,KGXY,KPUB) 
    Here is the event I had last night that worked fine. But the addresses used the Alert.0.xxx

    Click image for larger version  Name:	pic2.png Views:	0 Size:	77.5 KB ID:	1480354

    Leave a comment:


  • alexbk66
    replied
    I mean - what HS version? Is it happening after update to 4.1.17.0?

    Any errors in the log?

    [EDIT]

    From the screenshot it looks like it only happens for Alert devices? I think you had some issue with Alert devices before?

    I need to know the Addresses of these devices. Can you please enable "Show Device Address on Device List Page" on Setup => Custom.

    Leave a comment:


  • cowinger
    replied
    Originally posted by alexbk66 View Post
    What HS version?
    What "A lot of Errors"?
    I am on 4.0.0.61 and what I mean by a lot of errors is that every child device has a icon that represents an error. It takes a long time for the child devices to show something other than an error. This messes up events. What about the double devices?

    Leave a comment:


  • alexbk66
    replied
    What HS version?
    What "A lot of Errors"?

    Leave a comment:


  • cowinger
    started a topic Double Child Devices

    Double Child Devices

    There seems to be doubles to some of the child devices in 4.0.0.61. See pics

    Click image for larger version  Name:	pic1.png Views:	0 Size:	17.4 KB ID:	1480220
    Click image for larger version  Name:	pic2.png Views:	0 Size:	10.1 KB ID:	1480221

    Here is what the child devices show. A lot of Errors according to the graphics pages.

    Click image for larger version

Name:	pic3.png
Views:	60
Size:	107.0 KB
ID:	1480223
Working...
X