Announcement

Collapse
No announcement yet.

AmbientWeather and Ecowitt - Local protocol (no Cloud)

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Originally posted by alexbk66 View Post
    [EDIT]

    I just don't like multiplying devices unnecessary. So we want 4 devices for Min/Max (today and yesterday), also another 4 for the min/max time?

    I could show the time together with the temperature (i.e. 15C 01:00 AM)

    But I guess with the new feature Selecting devices to display it shouldn't be too much of a problem?
    I don't think you need time. If you really want the time of the min/max then you can use Jon00 Database and Charting utility to track the temps.

    Comment


      Ver 4.0.2.20 (BETA) - Added Min/Max temperatures

      Notes:

      1. Some providers have Min/Max temperatures already, then use it
      2. Only for today (will add "yesterday" later)
      3. Min/Max reset at 00:01 (may make configurable)
      4. If plugin is restarted - Min/Max reset (may save min/max for restart later)
      5. Not really tested, please verify.

      [UPDATE]

      Ver 4.0.2.23 (BETA) - Keep Min/Max temperatures for plugin restart

      Comment


        Hey alexbk66 I have your latest beta installed. Doesn't seem like the max temperature (for PWS) is working properly. See attached photos. One is my HomeSeer weather station device min/max values and the other is a picture of my Ambient Weather Station (2000) console. The max should be close to the current weather condition. These were both taken at around 8:50am. The Max is still reading yesterday's high.
        Click image for larger version  Name:	image_109875.png Views:	9 Size:	30.0 KB ID:	1527472
        Click image for larger version  Name:	image_109876.jpg Views:	9 Size:	62.4 KB ID:	1527473

        Comment


          Originally posted by begunfx View Post
          Doesn't seem like the max temperature (for PWS) is working properly. The max should be close to the current weather condition. These were both taken at around 8:50am. The Max is still reading yesterday's high.
          Do you see in log "Resetting Min/Max temperatures" message? (Log should be enabled)

          Comment


            Originally posted by alexbk66 View Post

            Do you see in log "Resetting Min/Max temperatures" message? (Log should be enabled)
            I didn't have log enabled. I'll enable it and check it tomorrow AM. Sorry, was in the process of migrating my system today.

            Comment


              I started a new thread as it's not Ecowitt specific https://forums.homeseer.com/forum/hs...rking-properly

              Comment


                Originally posted by alexbk66 View Post
                I started a new thread as it's not Ecowitt specific https://forums.homeseer.com/forum/hs...rking-properly
                Okay. I'll post there. Thanks!

                Comment


                  I have set up my Ambient 2000 weather station with your plugin and everything is working great, except it's not creating a device for the soil moisture. I selected the Ambient Weather Local as the device. I see the reading for soilhum1 coming in on the HS log. I have tried deleting the PWS and recreating it several times, but it doesn't help. I'm running version 4.0.2.37.

                  [1531] Back Yard: (AmbientWeatherLocal) soilhum1 = 7

                  Comment


                    Originally posted by Bruceg View Post
                    I have set up my Ambient 2000 weather station with your plugin and everything is working great, except it's not creating a device for the soil moisture. I selected the Ambient Weather Local as the device. I see the reading for soilhum1 coming in on the HS log. I have tried deleting the PWS and recreating it several times, but it doesn't help. I'm running version 4.0.2.37.

                    [1531] Back Yard: (AmbientWeatherLocal) soilhum1 = 7
                    Ver 4.0.2.44 (BETA) - AmbientWeather Local added "soilhum"

                    It's using different keyword, normally it's "soilmoisture"

                    Comment


                      Originally posted by alexbk66 View Post

                      Ver 4.0.2.44 (BETA) - AmbientWeather Local added "soilhum"

                      It's using different keyword, normally it's "soilmoisture"
                      Thanks, that fixed it! I now have my soil moisture device.

                      Comment


                        Hey alexbk66 I was working with my Local PWS instance and noticed that Precipitation hourly was missing from my device list. I checked in the log and confirmed that the local console is sending hourly (see attached). Can you please take a look when you have a moment?

                        Click image for larger version

Name:	image_110647.png
Views:	166
Size:	314.4 KB
ID:	1533023

                        Comment


                          Originally posted by alexbk66

                          As I said before, I create HS features (for which data is not always available) only when data is available from the provider. In your case hourlyrainin is 0, so the Precipitation hourly device will be created when it starts raining.

                          I know it may be inconvenient sometimes, but I don't want to create HS devices unnecessary, because not every Ecowitt reports hourlyrainin.
                          I understand the issue with creating all the devices regardless if they are being used. The problem I'm running into is I've had about 14 inches of rain since October and have yet to see the hourly device be created. We don't get a lot of rain in Los Angeles, and I now might have to wait up to a year before I have another chance. Would it be possible to list all the devices that don't automatically get created and have the option to select them and have them manually created? Perhaps in each location's setting page?

                          As always thanks for your time and consideration.

                          Comment


                            Originally posted by begunfx View Post

                            I understand the issue with creating all the devices regardless if they are being used. The problem I'm running into is I've had about 14 inches of rain since October and have yet to see the hourly device be created. We don't get a lot of rain in Los Angeles, and I now might have to wait up to a year before I have another chance. Would it be possible to list all the devices that don't automatically get created and have the option to select them and have them manually created? Perhaps in each location's setting page?

                            As always thanks for your time and consideration.
                            I have 122 features which can be created

                            Can you just poor some water on the sensor?

                            Comment


                              Originally posted by alexbk66 View Post

                              I have 122 features which can be created

                              Can you just poor some water on the sensor?
                              Unfortunately, the sensor is my weather station which is about 20ft in the air. Not really accessible.

                              Comment


                                Originally posted by alexbk66 View Post

                                I have 122 features which can be created

                                Can you just poor some water on the sensor?
                                That's why I suggested just having a list that users can go through and select to add themselves.

                                Comment

                                Working...
                                X