Announcement

Collapse
No announcement yet.

AmbientWeather and Ecowitt - Local protocol (no Cloud)

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #16
    Originally posted by alexbk66 View Post

    "Wind Direction Avg 10min" is called Winddir
    "Wind Speed Avg 10min" - Wind Speed
    "Maximum Daily Gust" - Wind Gust
    "Hourly Rain" - Precipitation
    "Monthly Rain" and "Yearly Rain" - I don't think is useful, especially if GW1000 doesn't keep the values after reboot. Daily and Weekly should be sufficient
    "Solar Radiation" - I need to add
    "pm25", etc. - I have the external sensor, so there's "Air Quality PM25", I need to add internal as well

    "dewpoint", "feelslike", "Illuminance" - are not present in the data stream, wold be created if were present. I have function for "feelslike" calculation, but prefer to rely on what's available

    "Pressure" is relative
    ​​​​​​​
    Alex, I beg to differ with your evaluation of the missing fields.

    I had a Precipitation Event, Precipitation Day and Precipitation Week created but no Precipitation Hour and no just plan Precipitation

    The AmbientWeather WS-2000 console sends both

    winddir and windwinddir_avg10m
    windspeedmph and windspdmph_avg10m
    windgustmph and maxdailygustmph
    dailyrainin and hourlyrainin
    Monthly Rain and Yearly Rain are kept by the GW1000 after reboot but we are talking about the AmbientWeather Consoles which also keep the data. It is Lightning that is not stored

    You are correct about dewpoint, feelslike, Illuminace I was looking at the wrong data stream when I added those to the list

    Below are the devices in the data stream from my console. I removed some of the formatting and put each on it's on line for clarity.

    tempinf=75.6
    battin=1
    humidityin=40
    baromrelin=28.736
    baromabsin=28.736
    tempf=78.4
    battout=1
    humidity=78
    winddir=148
    winddir_avg10m=140
    windspeedmph=0.0
    windspdmph_avg10m=0.2
    windgustmph=1.1
    maxdailygust=12.5
    hourlyrainin=0.000
    eventrainin=0.110
    dailyrainin=0.449
    weeklyrainin=0.839
    monthlyrainin=2.630
    yearlyrainin=31.177
    lightning_day=0
    batt_lightning=0
    solarradiation=0.85
    uv=0
    temp2f=88.2
    humidity2=55
    temp3f=85.5
    humidity3=60
    temp4f=73.4
    humidity4=48
    temp5f=92.3
    humidity5=37
    batt2=1
    batt3=1
    batt4=1
    batt5=1
    pm25_in=5.0
    pm25_in_24h=4.5
    aqi_pm25_in=21
    aqi_pm25_in_24h=19
    batt_25in=1



    Comment


      #17
      hourlyrainin = Precipitation, and all devices are created only when data is available, i.e. not 0

      What's eventrainin? Where do you get dewpoint, feelslike, Illuminace from?

      Comment


        #18
        Originally posted by alexbk66 View Post
        hourlyrainin = Precipitation, and all devices are created only when data is available, i.e. not 0

        What's eventrainin? Where do you get dewpoint, feelslike, Illuminace from?
        A Device of Precipitation (Hourlyrainin) was not created but Precipitation Event was created and does match up with eventrainin from the data stream. Eventrainin is how much rain has fallen in one period before it stops, so it can last several hours.

        As for dewpoint, feelslike and Illuminance like I said I grabbed those by mistake. Those are found in the datastream coming out of my application and are calculated values.

        Also, I did have Lightning events over night but those Devices were not created.

        &lightning_day=8&lightning_time=1624796059&lightning_distanc e=17&batt_lightning=0

        Also I can confirm distance is sent by EcoWitt and AmbientWeather in units of km.

        Comment


          #19
          Originally posted by jim@beersman.com View Post
          As for dewpoint, feelslike and Illuminance like I said I grabbed those by mistake. Those are found in the datastream coming out of my application and are calculated values.
          If you want, you can provide the calculations for these values and I can add them to the plugin.

          As I said, I do have feelslike calculation, but there's a lot of different views on feelslike.

          Comment


            #20
            My feelslike calculation uses 2 different formulas depending on the temperature. When it's cold it's actually computing Wind Chill (https://www.weather.gov/media/epz/wxcalc/windChill.pdf) and in the Summer is using the Heat Index formula (https://www.wpc.ncep.noaa.gov/html/h...equation.shtml)

            Comment


              #21
              I actually use "apparent temperature".

              What about dewpoint? You also calculate it?

              Code:
              protected double AppTempC(double temp_c, double humidity, double wind_speed_ms)
              {
                  double e = (humidity / 100) * 6.105;
                  e = Math.Pow(e, ((17.27 * temp_c) / (237.7 + temp_c)));
              
                  double q = 93.021511; // net radiation absorbed per unit area of body surface (W/m2)
              
                 return temp_c + (0.348 * e) - 0.7 * wind_speed_ms + (0.7 * (q / (wind_speed_ms + 10))) - 4.25;
              }

              Comment


                #22
                Yes, my app calculates Dewpoint, FeelsLike, Relative Barometric Pressure (Absolute pressure, Temperature and Altitude), AQI if you have a PM25 and Illuminance. I don't like that the GW1000 just allows for an offset for Relative Barometric Pressure and does not use the correct formula to calculate it.

                Comment


                  #23
                  Jim, if you want these calculations included in the plugi feel free to PM me
                  Alex

                  Comment


                    #24
                    Ver 4.0.0.69 - AmbientWeather: rain and lightning devices fixes

                    Comment


                      #25
                      I will try to get time to take a look at it tonight to make sure all the values are populating. As for adding the calculations that is up to you. I think users would like the option of being able to enable or disable that option. Just depends on the person

                      Comment


                        #26
                        I'm stuck on adding the port number on the plugin setup page. Entering 7777 gives ///7

                        Edit:

                        Switched browser to chrome from edge and the 7777 displays correctly

                        I have the plugin hooked up to a ecowitt rain gauge. It works.

                        Will you show multiple soil moisture probes?

                        The plugin correctly shows non-rain devices as unknown. But it is updating temp to 51F. It's 90F here, so I don't know where it is getting that value.

                        Comment


                          #27
                          Originally posted by dmiller View Post
                          I'm stuck on adding the port number on the plugin setup page. Entering 7777 gives ///7 Edit:Switched browser to chrome from edge and the 7777 displays correctly

                          Will you show multiple soil moisture probes?

                          The plugin correctly shows non-rain devices as unknown. But it is updating temp to 51F. It's 90F here, so I don't know where it is getting that value.
                          I'll check the Edge browser issue.

                          Multiple soil moisture sensors are supported up to 16.

                          Which temperature is 51F? Which devices are shown as Unknown? Can you please post screenshot.

                          Comment


                            #28
                            Click image for larger version

Name:	Screen Shot 2021-07-06 at 3.44.33 PM.png
Views:	103
Size:	449.0 KB
ID:	1482739

                            I don't know where these first two values come from. Everything else is correct, including the unknowns. I only have a rain sensor and a GW1000 connected.

                            Comment


                              #29
                              Thanks. And you are also saying that Temperature In is incorrect? Can you enable Log in location settings and see what you get in log.

                              Comment


                                #30
                                Sorry, it's been crazy just got a chance to take a look at the update for Local AmbientWeather WS-2000 Console

                                On my system it looks like the "AmbientWeather - Local" and the "CTRL" device are being populated from the "tempf" weather device and rounding up.

                                "Weekly Rain" did not update at the start of a new Week and is still showing the value from last week despite the Weather Data Stream updating and sending 0.0 for this week.
                                "Precipitation Event" is doing the same thing, did not reset to 0.0 when the data in the stream changed.

                                I see Precipitation Month was added and is correct, but Year was not added..

                                "Air Quality PM25" is showing as Unknown despite the fact that I do have a PM25 and it's data is in the Weather Stream.

                                "AQI" is not shown but it's data is also in the Weather Stream.

                                "Soil Moist [1]" , "Leak Sensor [1]", "Temperature[1]" and "Humidity [1]" all show as Unknown and that is correct I do not have those devices. Actual I do have a "Temperature[1]" and "Humidity [1]" but they are EcoWitt and are only read by my GW1000. Like I said these are good.

                                Comment

                                Working...
                                X