Announcement

Collapse
No announcement yet.

Created Local instance of Ambient Weather Station - not getting weather data

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Created Local instance of Ambient Weather Station - not getting weather data

    I added a second location and set it as my Ambient Weather Station - Local. I do already have my weather station communicating successfully on my network and reporting correctly to Ambient Weather as well as Wunderground. The device is only reporting Sunrise and Sunset values and those are also incorrect.. I selected 0 days to forecast, since I just wanted current weather. Any ideas? Thanks

    #2


    Also, I do not have minimal detail selected.

    Comment


      #3
      Did you follow instructions here: https://forums.homeseer.com/forum/hs...tocol-no-cloud

      Comment


        #4
        I added HSPI_AKWeather.exe to my app allow list on the HomeTroller Plus, but when I tried to create the Local Ambient Weather Device, I still only get the Sunset and Sunrise fields (this time they are correct though). Do I need to change the port to something besides the default 7777?

        Click image for larger version

Name:	image_104873.png
Views:	45
Size:	48.1 KB
ID:	1494927

        Comment


          #5
          I assume I would need to put the IP address of the Weather Station somewhere? I don't see where I should put it...

          Comment


            #6
            Originally posted by begunfx View Post
            I assume I would need to put the IP address of the Weather Station somewhere? I don't see where I should put it...
            Sure, the Weather Station needs to know where to send data. Can you provide more info - i.e. what station? How it's connected, etc?

            Comment


              #7


              I'm using an Ambient Weather Station (WS-2000). I have it setup with a static IP on my local network (ie. 192.168.1.15) via wifi. I also have it connected to ambientweather.net and underground. I did create an API key at ambientweather.net, but for the local setup, it sounds like I don't need the API key.

              Comment


                #8
                Are there settings in the Ambient Weather Station Console that I should be setting up?

                Comment


                  #9
                  Originally posted by begunfx View Post
                  Are there settings in the Ambient Weather Station Console that I should be setting up?
                  You have to configure your WS-2000 console to communicate with the PI. If you have not done so already, install AmbientWeather awnet app on your smartphone. Your phone and the WS-2000 need to be on the same network for this configuration. Launch the application and your WS-2000 Console should be listed in the Device List. Something like "AMBWeather-WIFIXXXX". XXXX = the last 4 characters of the mac address.

                  Select that device
                  In upper right corner press [next] 3 times or until you see the Customized screen
                  In the Server IP/Hostname enter the IP of the PC running the plugin
                  In the Port option enter the port that you defined in the PI
                  Set the upload interval, I found 20 - 30 seconds works well
                  Press Save...Don't forget this step
                  Press Finish in the upper right Corner

                  That's all there is to it

                  Comment


                    #10
                    Originally posted by jim@beersman.com View Post

                    You have to configure your WS-2000 console to communicate with the PI. If you have not done so already, install AmbientWeather awnet app on your smartphone. Your phone and the WS-2000 need to be on the same network for this configuration. Launch the application and your WS-2000 Console should be listed in the Device List. Something like "AMBWeather-WIFIXXXX". XXXX = the last 4 characters of the mac address.

                    Select that device
                    In upper right corner press [next] 3 times or until you see the Customized screen
                    In the Server IP/Hostname enter the IP of the PC running the plugin
                    In the Port option enter the port that you defined in the PI
                    Set the upload interval, I found 20 - 30 seconds works well
                    Press Save...Don't forget this step
                    Press Finish in the upper right Corner

                    That's all there is to it
                    Thanks Jim, I don't have Ambient Weather Station myself, I have Ecowitt and WSView app, which possibly also works with AW stations.

                    I'll copy your instructions to main AW/Ecowitt thread.

                    Comment


                      #11
                      You can do the same thing with the WS View app, it can communicate with the WS-2000 console as well. In fact this configuration option in WS View was available almost a year before it was available in awnet if not longer. So either app can be used to configure the WS-2000 console

                      Comment


                        #12
                        Originally posted by jim@beersman.com View Post
                        You can do the same thing with the WS View app, it can communicate with the WS-2000 console as well. In fact this configuration option in WS View was available almost a year before it was available in awnet if not longer. So either app can be used to configure the WS-2000 console
                        Thanks Jim. Yeah, I had just figured it out this morning, just before I read your thread. I also had to update the wifi firmware, otherwise I wasn't getting the custom server option on the console. After reading through your instructions I tried the Android version of the awnet app, but it doesn't have the option to setup a custom server. Instead I installed the WS View app and was able to set the IP address and Port # as expected.

                        After all the setup, then I went to the PI and created the new location. I renamed it to "Local" and selected Ambient Weather Local, then saved (I used the default port of 7777) (I turned on the log). Unfortunately, I'm not getting any device features still (except for sunrise and sunset). Instead I'm getting a socket error in the logs:
                        Code:
                         
                        System.Net.Sockets.SocketException (0x80004005): Only one usage of each socket address (protocol/network address/port) is normally permitted at: System.Net.Sockets.Socket.DoBind(EndPoint endPointSnapshot, SocketAddress socketAddress) at: System.Net.Sockets.Socket.Bind(EndPoint localEP) at: System.Net.Sockets.TcpListener.Start(Int32 backlog) at: System.Net.Sockets.TcpListener.Start() at: HSPI_AKWeather.Providers.AmbientWeatherLocal.Listen(Object o)

                        Comment


                          #13
                          Are you running HomeSeer on a Windows or Linux box? If Windows are you running HomeSeer as an Administrator? You also might change the default port to make sure it's not in use by another application. Be sure to change the port setting in the WS-2000 console as well.

                          Comment


                            #14


                            I'm running HomeSeer on a HomeTroller Plus (Windows). I'll change the port # and give that a try. Thanks jim.

                            Comment


                              #15


                              Okay finally success! I changed the port to 7795 and changed the Protocol to be "Ambient Weather". The default is Wunderground and only after changing the protocol did the device finally populate with weather features. Thanks guys!

                              Comment

                              Working...
                              X