Announcement

Collapse
No announcement yet.

Version 3 stopped working and upgrade to version 4 failed

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #16
    Ok, it recreated all my devices and seems to be working. Still have a red ? on CTRL for everything but it works. The CF devices have ToggleLight and LightOn but no LightOff like they did under version 3. Thanks for working with me on this and the quick replies.

    Comment


      #17
      Originally posted by oddjob View Post
      Ok, it recreated all my devices and seems to be working. Still have a red ? on CTRL for everything but it works. The CF devices have ToggleLight and LightOn but no LightOff like they did under version 3. Thanks for working with me on this and the quick replies.
      In HS4 I can't have controls on root device, so I have to add extra "Control" device. All commands "unassigned" to the child devices go to the "Control" device (before to the root). But it happens rarely, and usually you don't need the Control. So I made it configurable - you can disable "Add 'control' HS device to each Bond device" in plugin settings and delete Control devices.

      Was the LightOff on the child device or root?

      Comment


        #18
        Can you find CF device Template name in Bond mobile app please (in device settings)

        Comment


          #19
          RCF119v2 and 61d9e9be. Strange, there is no longer a LightOff there either but I swear there was one before the reboot, or I'm losing it.

          Comment


            #20
            According to the tempate, it appears the plugin is working properly

            Comment


              #21
              Originally posted by oddjob View Post
              RCF119v2 and 61d9e9be. Strange, there is no longer a LightOff there either but I swear there was one before the reboot, or I'm losing it.
              I'm checking.

              The Tmds mDNS issue affects the HS3 version also, probably Bond changed the mDNS record in their firmware (it's now empty). So I have to update both versions.

              Comment


                #22
                Ver 3.0.0.51 and 4.0.0.9 - Fixed Tmds mDNS crash

                Also in 4.0.0.9:
                - Fixed "Control" device status update
                - Added log template name
                - Fixed upgrade from HS3 - auto copy plugin config file from HS3

                Comment


                  #23
                  Originally posted by oddjob View Post
                  RCF119v2 and 61d9e9be. Strange, there is no longer a LightOff there either but I swear there was one before the reboot, or I'm losing it.
                  The list of reported actions does have TurnLightOff (you should be more specific) - so I need to check

                  Code:
                  [COLOR=#000000]["ToggleLight","TogglePower","SetSpeed","IncreaseSpeed","DecreaseSpeed","SetDirection","StartDimmer","DimMode","Stop","TurnOn","TurnOff","ToggleDirection","TurnLightOn","TurnLightOff"][/COLOR]

                  Comment


                    #24
                    Ok, found it - it's a new wonderful feature in HS4 - only allows three controls for HS device. Unless I explicitly set the controls layout (row/column).

                    Which is a problem for AKBond plugin - because I create controls dynamically based on device type. WTF???

                    Comment


                      #25
                      Ver 4.0.0.10 - fixed all issues discussed

                      Click image for larger version  Name:	RFC119V2.jpg Views:	0 Size:	35.8 KB ID:	1453380

                      Comment


                        #26
                        How long does it take for HS to show the update available generally?

                        Comment


                          #27
                          Originally posted by oddjob View Post
                          How long does it take for HS to show the update available generally?
                          That's unpredictable I always publish in BETA version, then they move to release

                          Click image for larger version

Name:	Screenshot 2021-02-03 010140.jpg
Views:	64
Size:	26.8 KB
ID:	1453481

                          Comment


                            #28
                            Got the beta, thanks for the quick turnaround. I installed, disabled and re-enabled. Still no LightOff. Do I need to delete the devices and re-enable?Click image for larger version

Name:	Bond v10.PNG
Views:	81
Size:	132.5 KB
ID:	1453485

                            Comment


                              #29
                              Yeah, I only set info when device is created - so you are free to change anything (except for address).

                              But instead of deleting device you can try setting row/column numbers in device settings (Status Graphics tab). By default they all are set to 1. You should set columns 1 to 3, and rows starting from 1.

                              Whatever is easier.

                              Comment


                                #30
                                Thanks, new to HomeSeer. It looks set already but it's not showing up

                                Click image for larger version

Name:	BondWill.PNG
Views:	64
Size:	211.2 KB
ID:	1453540

                                Comment

                                Working...
                                X