Announcement

Collapse
No announcement yet.

Plugin will not recognize light status (treats TurnLightOn as a ToggleLight)

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Plugin will not recognize light status (treats TurnLightOn as a ToggleLight)

    I've got an event that triggers the fan light to come on under certain conditions. The problem is that the plugin is not recognizing the status of the light (even when I check for that condition) and tries to turn the light on anyways. I've tried it a couple ways and it seems like the TurnLightOn function is acting like a ToggleLight. Any thoughts?

    #2
    Originally posted by rsc2a View Post
    I've got an event that triggers the fan light to come on under certain conditions. The problem is that the plugin is not recognizing the status of the light (even when I check for that condition) and tries to turn the light on anyways. I've tried it a couple ways and it seems like the TurnLightOn function is acting like a ToggleLight. Any thoughts?
    I need more info, i.e device type/model and template name.

    Comment


      #3
      The fixture itself is a River of Goods 52"W Caged Crystal 5-Blade Ceiling Fan with Remote (https://www.walmart.com/ip/River-of-...mote/393091731).

      A1 template is what my mobile app tells me. The mobile app is working fine.

      Here's a simple script I've tried to test with. It seems to be ignoring the "AND IF" part of it.
      Click image for larger version

Name:	Capture.PNG
Views:	32
Size:	189.9 KB
ID:	1464166

      Comment


        #4
        I'll check. But if you say "It seems to be ignoring the "AND IF" part of it" - it sounds like HS problem, not the plugin?

        The Template name is also available in the plugin:

        Click image for larger version  Name:	MyDevicesWithTemplate.jpg Views:	0 Size:	46.6 KB ID:	1464170

        Comment


          #5
          I added A1 device, but can't understand your issue.

          You say "The problem is that the plugin is not recognizing the status of the light (even when I check for that condition) and tries to turn the light on anyways"

          What do you mean by "is not recognizing the status of the light"? If you mean the event you setup in post #3 - if you trigger the event manually - it doesn't check the event conditions.

          Also, I don't get why you even have to check if the light is OFF? Because if it's already ON - it just shouldn't change.

          When you say "The mobile app is working fine" - what's the difference in behaviour between the app and the plugin? The app doesn't even have separate Light On/Off controls.

          "it seems like the TurnLightOn function is acting like a ToggleLight" - looks fine to me:

          Click image for larger version

Name:	A1Light.gif
Views:	17
Size:	139.3 KB
ID:	1464193

          You may need to enable "Trust State" https://olibra.zendesk.com/hc/en-us/...me-application

          If you have any questions related to the function of the device itself, Bond Forum is the place to ask.

          Click image for larger version

Name:	2021-03-20 (2).png
Views:	33
Size:	48.1 KB
ID:	1464192

          Comment


            #6
            Enabling "Trust state" fixed it. Thanks a ton!

            Comment


              #7
              NP

              Comment

              Working...
              X