Announcement

Collapse
No announcement yet.

Control Bond with Associations

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Control Bond with Associations

    This may be a noob question but.... I have a switch (Aeotec Wallmote Quad) that controls devices using group associations. I am trying to associate my ceiling fan light (and perhaps fan control) to this switch using the PI but, when I go to associate a group, the Bond devices aren't in the dropdown list of devices to select from (I'm guessing maybe because they don't have a node id (?)).

    Is it possible to accomplish what I'm trying to do?

    #2
    Probably you need to provide more detailed info, perhaps screenshots. I.e.

    - "associate my ceiling fan light (and perhaps fan control) to this switch" - where?
    - "Bond devices aren't in the dropdown list of devices to select from" - again, where?
    - " they don't have a node id" - what's node id?

    Comment


      #3
      All of my devices have a Node ID (set in the Z-Wave tab) -


      Click image for larger version  Name:	Node Settings.jpg Views:	0 Size:	42.6 KB ID:	1507961


      My remote switch uses Group Associations to control different devices.... When I go to the group associations of the remote switch, the dropdown list does not contain the Bond devices (I am just guessing, because it only lists Nodes) -



      Click image for larger version  Name:	Wallmote Associations.jpg Views:	0 Size:	68.5 KB ID:	1507962




      Comment


        #4
        Well, you should've mentioned Z-Wave in you original post.

        Z-Wave controller can control only Z-Wave devices (obviously) - it has nothing to do with HomeSeer at all. So it can't control any HS devices.

        Comment


          #5
          Originally posted by skidiver View Post
          This may be a noob question but.... I have a switch (Aeotec Wallmote Quad) that controls devices using group associations. I am trying to associate my ceiling fan light (and perhaps fan control) to this switch using the PI but, when I go to associate a group, the Bond devices aren't in the dropdown list of devices to select from (I'm guessing maybe because they don't have a node id (?)).

          Is it possible to accomplish what I'm trying to do?
          You have 3 options:

          1. Try "Linked Device" HS feature (screenshot below) - pick one of Z-Wave devices which have the same brightness range (i.e. 0-100) as Bond light device and add the bond light device to the Z-Wave device "Linked Device"

          2. Use HS event (when Z-Wave device value changes) and use EasyTrigger plugin to set Bond light device brightness to the Z-Wave brightness

          3. Possibly AKSmartDevice plugin
          Click image for larger version

Name:	Screenshot 2021-11-14 120717.png
Views:	87
Size:	45.8 KB
ID:	1508044

          Comment


            #6
            Thanks for the suggestions.... I still couldn't get it to work but, after looking closer, I noticed that when the button is pressed, held, etc.... the device logs a Scene Key pressed, not the "switch" key. I created the Event below and it is working as expected. I created a similar Event (Scene Key Held) to turn the fan on/off and that works too.


            Click image for larger version

Name:	Ceiling Fan Light Event.jpg
Views:	84
Size:	19.9 KB
ID:	1508328

            Comment

            Working...
            X