Announcement

Collapse
No announcement yet.

Event Template Error, Not Displaying Correctly

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Event Template Error, Not Displaying Correctly

    I click on an Event and all I get is the following:

    Here is as much as I could capture. I am on 4.2.18.3

    Click image for larger version

Name:	pic1.png
Views:	98
Size:	158.3 KB
ID:	1598779

    #2
    This is probably in the wrong area. Please move it to the right one if that is the case.

    Comment


      #3
      Looks like the style sheet is not being served. Try a reboot of the HS machine first.
      If that doesnt work, hit F12 in the browser and check the console for any errors.
      HS4Pro Running on a Raspberry Pi4
      67 Z-Wave Nodes, 111 Events, 422 Devices
      Z-Wave, UPB, WiFi
      Plugins: EasyTrigger, weatherXML, OMNI, Z-Wave, Tuya, Device History
      HSTouch Clients: 3 Android, 1 Joggler

      Comment


        #4
        Originally posted by rmasonjr View Post
        Looks like the style sheet is not being served. Try a reboot of the HS machine first.
        If that doesnt work, hit F12 in the browser and check the console for any errors.
        Here is what I found.

        Source map error: Error: JSON.parse: unexpected character at line 1 column 1 of the JSON data Resource URL: http://192.168.1.176/bootstrap/js/js.cookie.min.js Source Map URL: /sm/b0ce608ffc029736e9ac80a8dd6a7db2da8e1d45d2dcfc92043deb2214aa 30d8.map​

        Comment


          #5
          I'm not sure what that means - maybe the minified javascript file is corrupt?
          If you have a backup, maybe restore just that file and see if that helps.
          HS4Pro Running on a Raspberry Pi4
          67 Z-Wave Nodes, 111 Events, 422 Devices
          Z-Wave, UPB, WiFi
          Plugins: EasyTrigger, weatherXML, OMNI, Z-Wave, Tuya, Device History
          HSTouch Clients: 3 Android, 1 Joggler

          Comment


            #6
            Originally posted by rmasonjr View Post
            I'm not sure what that means - maybe the minified javascript file is corrupt?
            If you have a backup, maybe restore just that file and see if that helps.
            I am not placing blame on anything but this happened right after I set up Sonos4. Could be coincidence.

            Comment


              #7
              rjh I am not sure what has happened here but when I select an event to look at I get an error in the logs and the text in post #1 shows instead of the event as we know it. Here is the error.

              3/17/2023 5:15:12 PM
              HomeSeer
              Warning
              Problem parsing HTML: This template has errors. Check the and before evaluating a template. Messages: (72,7) : error : Error while parsing expression statement: Invalid token found `\`. Expecting /end of line after: Querystring: ref=107&subpage=event.html

              3/17/2023 5:15:12 PM
              HomeSeer
              Error
              Template parse error: Error while parsing expression statement: Invalid token found `\`. Expecting /end of line after:

              3/17/2023 5:14:47 PM
              HomeSeer
              Warning
              File does not exist: C:\Program Files (x86)\HomeSeer HS4\html\images\Sonos\Artwork\CoverRINCON_347E5CF1B5A001400_ 56.jpg

              ​

              Comment


                #8
                Does this happen with all events, or just a specific one? What is the URL of the page you are displaying?

                Originally posted by cowinger View Post
                rjh I am not sure what has happened here but when I select an event to look at I get an error in the logs and the text in post #1 shows instead of the event as we know it. Here is the error.

                3/17/2023 5:15:12 PM
                HomeSeer
                Warning
                Problem parsing HTML: This template has errors. Check the and before evaluating a template. Messages: (72,7) : error : Error while parsing expression statement: Invalid token found `\`. Expecting /end of line after: Querystring: ref=107&subpage=event.html

                3/17/2023 5:15:12 PM
                HomeSeer
                Error
                Template parse error: Error while parsing expression statement: Invalid token found `\`. Expecting /end of line after:

                3/17/2023 5:14:47 PM
                HomeSeer
                Warning
                File does not exist: C:\Program Files (x86)\HomeSeer HS4\html\images\Sonos\Artwork\CoverRINCON_347E5CF1B5A001400_ 56.jpg

                ​
                💁‍♂️ Support & Customer Service 🙋‍♂️ Sales Questions 🛒 Shop HomeSeer Products

                Comment


                  #9
                  The url is in his screenshot. Looks like it might be expecting a Linux delimiter and seeing a Windows.


                  Click image for larger version  Name:	image.png Views:	0 Size:	158.3 KB ID:	1598915​
                  HS4 Pro, 4.2.18.3 Windows 10 pro, Supermicro LP Xeon

                  Comment


                    #10
                    I just upgraded to HS4 Pro 4.2.18.3 and am having this same issue with old events and when trying to create new events.

                    Click image for larger version

Name:	image.png
Views:	35
Size:	205.9 KB
ID:	1599154​

                    Comment


                      #11
                      I was instructed to do a repair installation by downloading the installer from the downloads page. This resolved the issue for me.

                      Comment


                        #12
                        Originally posted by AggieSoundman View Post
                        I was instructed to do a repair installation by downloading the installer from the downloads page. This resolved the issue for me.
                        That did the trick. Thanks

                        Thanks randy and rjh and rmasonjr.

                        Comment

                        Working...
                        X